aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfig/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-26 16:39:14 +0000
commitbc62127a69294fd3340ea793685953d98ff835dc (patch)
treed124c4d6f965d5152806ebfbf40e1b5a25860ddb /graphics/xfig/Makefile
parente8dd5f52410bdf2a989023706699373d47296008 (diff)
downloadports-bc62127a69294fd3340ea793685953d98ff835dc.tar.gz
ports-bc62127a69294fd3340ea793685953d98ff835dc.zip
Notes
Diffstat (limited to 'graphics/xfig/Makefile')
-rw-r--r--graphics/xfig/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/graphics/xfig/Makefile b/graphics/xfig/Makefile
index 2ea50a8166b6..c06dcea4859d 100644
--- a/graphics/xfig/Makefile
+++ b/graphics/xfig/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xfig
-# Date created: 4 January 1995
-# Whom: roberto
-#
+# Created by: roberto
# $FreeBSD$
-#
PORTNAME= xfig
PORTVERSION= 3.2.5b
@@ -36,23 +32,24 @@ MAKE_ARGS+= INSTALLFLAGS="${COPY}" \
INSTDATFLAGS="${_SHROWNGRP} -m ${SHAREMODE}" \
INSTMANFLAGS="${_MANOWNGRP} -m ${MANMODE}"
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install.libs install.html
-.endif
+OPTIONS_DEFINE= GHOSTSCRIPT I18N DOCS
+OPTIONS_DEFAULT= GHOSTSCRIPT I18N
+I18N_DESC= I18N support and Japanese docs
-OPTIONS= GHOSTSCRIPT "Ghostscript support" on \
- I18N "I18N support and Japanese docs" on
+.include <bsd.port.options.mk>
-.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MDOCS}
+INSTALL_TARGET= install install.libs install.html
+.endif
-.if defined(WITHOUT_I18N) || defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MI18N} || ! ${PORT_OPTIONS:MDOCS}
PLIST_SUB+= JPORTDOCS="@comment "
.else
PLIST_SUB= JPORTDOCS=""
.endif
-.if !defined(WITHOUT_I18N)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MI18N}
+USES+= gettext
.endif
post-extract:
@@ -64,15 +61,15 @@ post-extract:
@${CP} ${WRKSRC}/Doc/xfig.man ${WRKSRC}
post-patch:
-.if defined(WITHOUT_GHOSTSCRIPT)
-.if defined(WITHOUT_I18N)
+.if ! ${PORT_OPTIONS:MGHOSTSCRIPT}
+.if ! ${PORT_OPTIONS:MI18N}
@${REINPLACE_CMD} -e 's|-DGSBIT ||g' ${WRKSRC}/Imakefile
.else
@${REINPLACE_CMD} -e '/^XCOMM #define I18N/s|XCOMM ||' \
-e 's|-DGSBIT ||g' ${WRKSRC}/Imakefile
.endif
-.elif !defined(WITHOUT_I18N)
+.elif ${PORT_OPTIONS:MI18N}
@${REINPLACE_CMD} -e '/^XCOMM #define I18N/s|XCOMM ||' ${WRKSRC}/Imakefile
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>