aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfig
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-15 20:48:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-15 20:48:48 +0000
commit7120c495245c489739a5ed087d3e925b288a2602 (patch)
tree4f54732010f3c4c9966bceccd015bbd8d2c8b8af /graphics/xfig
parentfb68a5185acb4a34bafe10bc316e57de2c3e7728 (diff)
downloadports-7120c495245c489739a5ed087d3e925b288a2602.tar.gz
ports-7120c495245c489739a5ed087d3e925b288a2602.zip
- Fix xfig to be able to use Ghostscript fonts again
- While here, update download location PR: ports/117253 Submitted by: Steven G. Kargl <kargl@troutmask.apl.washington.edu>
Notes
Notes: svn path=/head/; revision=203796
Diffstat (limited to 'graphics/xfig')
-rw-r--r--graphics/xfig/Makefile4
-rw-r--r--graphics/xfig/files/patch-u_fonts.c11
-rw-r--r--graphics/xfig/files/patch-w_fontpanel.c18
3 files changed, 31 insertions, 2 deletions
diff --git a/graphics/xfig/Makefile b/graphics/xfig/Makefile
index c917895e06b4..89215c6f139a 100644
--- a/graphics/xfig/Makefile
+++ b/graphics/xfig/Makefile
@@ -7,9 +7,9 @@
PORTNAME= xfig
PORTVERSION= 3.2.5
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://xfig.org/software/xfig/${PORTVERSION}/ \
- ftp://www-epb.lbl.gov/xfig/
+MASTER_SITES= http://files.xfig.org/
DISTNAME= ${PORTNAME}.${PORTVERSION}.full
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/xfig/files/patch-u_fonts.c b/graphics/xfig/files/patch-u_fonts.c
new file mode 100644
index 000000000000..4ea1704b38cc
--- /dev/null
+++ b/graphics/xfig/files/patch-u_fonts.c
@@ -0,0 +1,11 @@
+--- u_fonts.c.old 2007-10-17 12:22:24.000000000 -0700
++++ u_fonts.c 2007-10-17 12:23:36.000000000 -0700
+@@ -107,7 +107,7 @@
+ /* PostScript font names matched with X11 font names in x_fontinfo */
+
+ struct _fstruct ps_fontinfo[NUM_FONTS + 1] = {
+- {"Default", -1},
++ {"Default", 0},
+ {"Times-Roman", 0},
+ {"Times-Italic", 1},
+ {"Times-Bold", 2},
diff --git a/graphics/xfig/files/patch-w_fontpanel.c b/graphics/xfig/files/patch-w_fontpanel.c
index 1ddf0d4ab2be..cc1275714a74 100644
--- a/graphics/xfig/files/patch-w_fontpanel.c
+++ b/graphics/xfig/files/patch-w_fontpanel.c
@@ -1,5 +1,14 @@
--- w_fontpanel.c.orig Fri Feb 24 12:23:06 2006
+++ w_fontpanel.c
+@@ -143,7 +143,7 @@
+ ps_fontmenu_items[i].type = MENU_IMAGESTRING; /* put the fontnames in
+ * menu */
+ ps_fontmenu_items[i].label = ps_fontinfo[i].name;
+- ps_fontmenu_items[i].info = (caddr_t) (i - 1); /* index for font # */
++ ps_fontmenu_items[i].info = (caddr_t) i; /* index for font # */
+ }
+
+ for (i = 0; i < NUM_LATEX_FONTS; i++) {
@@ -183,7 +183,7 @@
ps_cancel = XtCreateManagedWidget("cancel", commandWidgetClass,
ps_form, Args, ArgCount);
@@ -36,3 +45,12 @@
XtInstallAccelerators(ps_form, ps_cancel);
XtInstallAccelerators(latex_form, latex_cancel);
+@@ -359,7 +359,7 @@
+ char *font_name = mi->label;
+
+ if (*flag_sel)
+- *font_ps_sel = (int) mi->info; /* set ps font to one selected */
++ *font_ps_sel = (int) mi->info - 1; /* set ps font to one selected */
+ else
+ *font_latex_sel = (int) mi->info; /* set latex font to one
+ * selected */