aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfractint
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-09-09 04:21:57 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-09-09 04:21:57 +0000
commit3b77cfee25bda16084217aca99a6e869ba7fcf25 (patch)
tree7f0825736659222e84b5fc612a7065b5befc0cb1 /graphics/xfractint
parent04317b984dd167b5e1e9c6be2b56725d33223380 (diff)
downloadports-3b77cfee25bda16084217aca99a6e869ba7fcf25.tar.gz
ports-3b77cfee25bda16084217aca99a6e869ba7fcf25.zip
The Unix port of fractint, a program to calculate pretty fractals.
Submitted by: "Hector Gonzalez Jaime." <CACHO@mexicano.gdl.iteso.mx>
Notes
Notes: svn path=/head/; revision=2138
Diffstat (limited to 'graphics/xfractint')
-rw-r--r--graphics/xfractint/Makefile25
-rw-r--r--graphics/xfractint/distinfo1
-rw-r--r--graphics/xfractint/files/patch-aa104
-rw-r--r--graphics/xfractint/files/patch-ab33
-rw-r--r--graphics/xfractint/pkg-comment1
-rw-r--r--graphics/xfractint/pkg-descr6
-rw-r--r--graphics/xfractint/pkg-plist37
7 files changed, 207 insertions, 0 deletions
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
new file mode 100644
index 000000000000..c189cc0fffc4
--- /dev/null
+++ b/graphics/xfractint/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: xfractint
+# Version required: 3.00
+# Date created: 7 Sept 1995
+# Whom: cacho@mexicano.gdl.iteso.mx
+#
+# $Id$
+#
+
+DISTNAME= xfract300
+PKGNAME= xfractint-3.00
+CATEGORIES+= graphics
+MASTER_SITES= ftp://ftp.cs.berkeley.edu/ucb/sprite/
+EXTRACT_SUFX= .shar.Z
+
+EXTRACT_CMD= zcat
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= |sh
+NO_WRKSUBDIR= yes
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/xfractint.1
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/xfractint/distinfo b/graphics/xfractint/distinfo
new file mode 100644
index 000000000000..1f36da611c69
--- /dev/null
+++ b/graphics/xfractint/distinfo
@@ -0,0 +1 @@
+MD5 (xfract300.shar.Z) = 30090fa5f1a508b2687128ed1c73fcc1
diff --git a/graphics/xfractint/files/patch-aa b/graphics/xfractint/files/patch-aa
new file mode 100644
index 000000000000..c4ff08eb3b28
--- /dev/null
+++ b/graphics/xfractint/files/patch-aa
@@ -0,0 +1,104 @@
+*** Makefile.orig Fri Sep 8 10:19:18 1995
+--- Makefile Fri Sep 8 11:12:39 1995
+***************
+*** 5,15 ****
+ # SRCDIR should be a path to the directory that will hold fractint.hlp
+ # You will have to copy fractint.hlp to SRCDIR and make it world readable.
+ # SRCDIR should also hold the .par, .frm, etc. files
+! SRCDIR = /usr/local/bin/X11/fractint
+ # BINDIR is where you put your X11 binaries
+! BINDIR = /usr/local/bin/X11
+ # MANDIR is where you put your chapter 1 man pages
+! MANDIR = /user/local/man/man1
+
+ #SRCDIR = /users/shirriff/fractfiles
+ #BINDIR = /users/shirriff/fractfiles
+--- 5,15 ----
+ # SRCDIR should be a path to the directory that will hold fractint.hlp
+ # You will have to copy fractint.hlp to SRCDIR and make it world readable.
+ # SRCDIR should also hold the .par, .frm, etc. files
+! SRCDIR = ${PREFIX}/lib/fractint
+ # BINDIR is where you put your X11 binaries
+! BINDIR = ${PREFIX}/bin
+ # MANDIR is where you put your chapter 1 man pages
+! MANDIR = ${PREFIX}/man/man1
+
+ #SRCDIR = /users/shirriff/fractfiles
+ #BINDIR = /users/shirriff/fractfiles
+***************
+*** 32,38 ****
+ # prompts2.c to "#else".
+ #
+
+! #NOBSTRING = -DNOBSTRING
+ #HAVESTRI = -DHAVESTRI
+ #DEBUG adds some sanity checking but will slow xfractint down
+ #DEBUG = -DEBUG
+--- 32,38 ----
+ # prompts2.c to "#else".
+ #
+
+! NOBSTRING = -DNOBSTRING
+ #HAVESTRI = -DHAVESTRI
+ #DEBUG adds some sanity checking but will slow xfractint down
+ #DEBUG = -DEBUG
+***************
+*** 56,62 ****
+ #For Solaris, use CFLAGS = -I. -I/usr/openwin/include $(DEFINES) -g
+
+ #CFLAGS = -I. -D_CONST $(DEFINES)
+! CFLAGS = -I. $(DEFINES) -g
+
+ # Gcc is often the only compiler that works for this
+ # For HPUX, use CC = cc -Aa -D_HPUX_SOURCE
+--- 56,62 ----
+ #For Solaris, use CFLAGS = -I. -I/usr/openwin/include $(DEFINES) -g
+
+ #CFLAGS = -I. -D_CONST $(DEFINES)
+! CFLAGS = -I. $(DEFINES) -O2 -m486 -I/usr/X11R6/include
+
+ # Gcc is often the only compiler that works for this
+ # For HPUX, use CC = cc -Aa -D_HPUX_SOURCE
+***************
+*** 72,78 ****
+ # For 386BSD, add -L/usr/X386/lib to LIBS
+ # For Apollo, change -lX11 to -L/usr/X11/libX11
+ # For Solaris, add -L/usr/openwin/lib
+! LIBS = -lX11 -lm -lcurses -ltermcap
+
+ # HPUX fixes thanks to David Allport, Bill Broadley, and R. Lloyd.
+ # AIX fixes thanks to David Sanderson & Elliot Jaffe.
+--- 72,78 ----
+ # For 386BSD, add -L/usr/X386/lib to LIBS
+ # For Apollo, change -lX11 to -L/usr/X11/libX11
+ # For Solaris, add -L/usr/openwin/lib
+! LIBS = -lX11 -lm -lcurses -ltermcap -L/usr/X11R6/lib
+
+ # HPUX fixes thanks to David Allport, Bill Broadley, and R. Lloyd.
+ # AIX fixes thanks to David Sanderson & Elliot Jaffe.
+***************
+*** 147,152 ****
+--- 147,154 ----
+ .SUFFIXES:
+ .SUFFIXES: .o .c .s .h
+
++ all: xfractint
++
+ xfractint: fractint.hlp .WAIT $(OBJS)
+ $(CC) -o xfractint $(CFLAGS) $(OBJS) $(LIBS)
+ strip xfractint
+***************
+*** 164,169 ****
+--- 166,177 ----
+ cp xfractint $(BINDIR)/xfractint
+ strip $(BINDIR)/xfractint
+ chmod a+x $(BINDIR)/xfractint
++ if [ ! -d $(SRCDIR) ]; then \
++ echo "Making $(SRCDIR)"; \
++ mkdir $(SRCDIR); \
++ chmod 755 $(SRCDIR); \
++ else true; \
++ fi;
+ cp fractint.hlp $(PARFILES) $(FRMFILES) $(IFSFILES) $(LFILES) $(MAPFILES) $(SRCDIR)
+ (cd $(SRCDIR); chmod a+r fractint.hlp $(PARFILES) $(FRMFILES) $(IFSFILES) $(LFILES) $(MAPFILES) )
+ cp xfractint.man $(MANDIR)/xfractint.1
diff --git a/graphics/xfractint/files/patch-ab b/graphics/xfractint/files/patch-ab
new file mode 100644
index 000000000000..96ed84ff67d1
--- /dev/null
+++ b/graphics/xfractint/files/patch-ab
@@ -0,0 +1,33 @@
+*** port.h.orig Thu Sep 7 20:55:27 1995
+--- port.h Thu Sep 7 21:27:45 1995
+***************
+*** 150,156 ****
+ #endif
+
+ /* Keep this defined for Unix, even on a little-endian machine */
+! #define BIG_ENDIAN
+
+ #define USE_BIGNUM_C_CODE
+
+--- 150,158 ----
+ #endif
+
+ /* Keep this defined for Unix, even on a little-endian machine */
+! #ifndef BIG_ENDIAN
+! #define BIG_ENDIAN 4321
+! #endif
+
+ #define USE_BIGNUM_C_CODE
+
+***************
+*** 202,207 ****
+--- 204,212 ----
+ #undef LDBL_DIG
+ #endif
+ #ifdef sun
++ #undef LDBL_DIG
++ #endif
++ #ifdef __FreeBSD__
+ #undef LDBL_DIG
+ #endif
+
diff --git a/graphics/xfractint/pkg-comment b/graphics/xfractint/pkg-comment
new file mode 100644
index 000000000000..081fac67b8f2
--- /dev/null
+++ b/graphics/xfractint/pkg-comment
@@ -0,0 +1 @@
+Xfractint-3.00 - The Unix port of fractint.
diff --git a/graphics/xfractint/pkg-descr b/graphics/xfractint/pkg-descr
new file mode 100644
index 000000000000..4f3a7496296f
--- /dev/null
+++ b/graphics/xfractint/pkg-descr
@@ -0,0 +1,6 @@
+Xfractint - The Unix port of fractint.
+
+Fractint is an IBM PC program to generate fractals, and was written by
+the Stone Soup Group.
+
+The unix port was done by Ken Shirriff (shirriff@Sprite.Berkeley.EDU)
diff --git a/graphics/xfractint/pkg-plist b/graphics/xfractint/pkg-plist
new file mode 100644
index 000000000000..666f2cf96b88
--- /dev/null
+++ b/graphics/xfractint/pkg-plist
@@ -0,0 +1,37 @@
+bin/xfractint
+lib/fractint/altern.map
+lib/fractint/blues.map
+lib/fractint/cellular.par
+lib/fractint/chroma.map
+lib/fractint/default.map
+lib/fractint/firestrm.map
+lib/fractint/fractint.frm
+lib/fractint/fractint.hlp
+lib/fractint/fractint.ifs
+lib/fractint/fractint.l
+lib/fractint/fractint.par
+lib/fractint/froth3.map
+lib/fractint/froth316.map
+lib/fractint/froth6.map
+lib/fractint/froth616.map
+lib/fractint/gamma1.map
+lib/fractint/gamma2.map
+lib/fractint/glasses1.map
+lib/fractint/glasses2.map
+lib/fractint/goodega.map
+lib/fractint/green.map
+lib/fractint/grey.map
+lib/fractint/grid.map
+lib/fractint/headache.map
+lib/fractint/icons.par
+lib/fractint/landscap.map
+lib/fractint/lyapunov.map
+lib/fractint/neon.map
+lib/fractint/paintjet.map
+lib/fractint/penrose.l
+lib/fractint/phoenix.par
+lib/fractint/royal.map
+lib/fractint/tiling.l
+lib/fractint/topo.map
+lib/fractint/volcano.map
+man/man1/xfractint.1.gz