aboutsummaryrefslogtreecommitdiff
path: root/graphics/xfractint
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-03-24 16:51:18 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-03-24 16:51:18 +0000
commitca4a6cf153e3ca0b04d4dc280109847cfb367a6d (patch)
tree5db515aff53d5f59c98631e18849f831bfdce2f3 /graphics/xfractint
parent31174c8e75b72b2380f31bf4c1a8305c6354c1c0 (diff)
downloadports-ca4a6cf153e3ca0b04d4dc280109847cfb367a6d.tar.gz
ports-ca4a6cf153e3ca0b04d4dc280109847cfb367a6d.zip
- Update to version 20.04p12 [1]
- Project has new homepage [1] - Port needs USE_XORG+=xft to compile now - Use INSTALL_DATA and COPYTREE_SHARE macros instead of CP for proper file permissions - Add desktop entry file PR: ports/165911 [1] Submitted by: Pedro Giffuni <giffunip@tutopia.com> [1] Approved by: maintainer [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=293765
Diffstat (limited to 'graphics/xfractint')
-rw-r--r--graphics/xfractint/Makefile30
-rw-r--r--graphics/xfractint/distinfo4
-rw-r--r--graphics/xfractint/files/extra-unix__fpu087.c20
-rw-r--r--graphics/xfractint/files/patch-Makefile24
-rw-r--r--graphics/xfractint/files/patch-common__biginit.c17
-rw-r--r--graphics/xfractint/files/patch-common__fractalb.c10
-rw-r--r--graphics/xfractint/files/patch-common__fractals.c10
-rw-r--r--graphics/xfractint/files/patch-common__frasetup.c10
-rw-r--r--graphics/xfractint/files/patch-common__lsys.c10
-rw-r--r--graphics/xfractint/files/patch-common__lsysf.c10
-rw-r--r--graphics/xfractint/files/patch-common__memory.c16
-rw-r--r--graphics/xfractint/files/patch-common__miscres.c17
-rw-r--r--graphics/xfractint/files/patch-common__mpmath_c.c11
-rw-r--r--graphics/xfractint/files/patch-common__prompts1.c10
-rw-r--r--graphics/xfractint/files/patch-common__prompts2.c10
-rw-r--r--graphics/xfractint/files/patch-common__soi.c19
-rw-r--r--graphics/xfractint/files/patch-common__soi1.c17
-rw-r--r--graphics/xfractint/files/patch-unix__fpu087.c22
-rw-r--r--graphics/xfractint/pkg-descr2
19 files changed, 168 insertions, 101 deletions
diff --git a/graphics/xfractint/Makefile b/graphics/xfractint/Makefile
index 624951e9afd4..1bc8b103d92a 100644
--- a/graphics/xfractint/Makefile
+++ b/graphics/xfractint/Makefile
@@ -6,31 +6,37 @@
#
PORTNAME= xfractint
-PORTVERSION= 20.04p09
+PORTVERSION= 20.04p12
CATEGORIES= graphics
-MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
+MASTER_SITES= http://www.fractint.org/ftp/current/linux/ \
http://twegner.dyndns.org/fractint/ftp/current/linux/
MAINTAINER= onemda@gmail.com
COMMENT= The Unix port of fractint
USE_GMAKE= yes
-USE_XORG= x11
+USE_XORG= x11 xft
ALL_TARGET= ${PORTNAME}
MAN1= ${PORTNAME}.1
+DESKTOP_ENTRIES+="Xfracint" "${COMMENT}" "" "${PORTNAME}" "" "false"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800000
+EXTRA_PATCHES+= ${FILESDIR}/extra-unix__fpu087.c
+.endif
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/xfractint ${PREFIX}/bin/${PORTNAME}
@${INSTALL_MAN} ${WRKSRC}/unix/xfractint.man ${PREFIX}/man/man1/${MAN1}
@${MKDIR} ${DATADIR}
- @${CP} ${WRKSRC}/fractint.hlp ${DATADIR}
- @${CP} ${WRKSRC}/sstools.ini ${DATADIR}
- @${CP} -R ${WRKSRC}/formulas ${DATADIR}
- @${CP} -R ${WRKSRC}/ifs ${DATADIR}
- @${CP} -R ${WRKSRC}/lsystem ${DATADIR}
- @${CP} -R ${WRKSRC}/maps ${DATADIR}
- @${CP} -R ${WRKSRC}/pars ${DATADIR}
-
-.include <bsd.port.mk>
+ @${INSTALL_DATA} ${WRKSRC}/fractint.hlp ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/sstools.ini ${DATADIR}
+.for dir in formulas ifs lsystem maps pars
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${DATADIR}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/graphics/xfractint/distinfo b/graphics/xfractint/distinfo
index ed8df22912fc..0b7694fc5ccd 100644
--- a/graphics/xfractint/distinfo
+++ b/graphics/xfractint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfractint-20.04p09.tar.gz) = 296e6da82a81210b2d9ccde0eb15059d27f561f23ef1221f39fbefe48ebe5d69
-SIZE (xfractint-20.04p09.tar.gz) = 1333141
+SHA256 (xfractint-20.04p12.tar.gz) = e81affa9d3b3826f14502cedf1fc4a4dd41bcfa71ba32f8e4224748c5b9c69e0
+SIZE (xfractint-20.04p12.tar.gz) = 1335480
diff --git a/graphics/xfractint/files/extra-unix__fpu087.c b/graphics/xfractint/files/extra-unix__fpu087.c
new file mode 100644
index 000000000000..b9f49dff013f
--- /dev/null
+++ b/graphics/xfractint/files/extra-unix__fpu087.c
@@ -0,0 +1,20 @@
+--- unix/fpu087.c.orig 2012-03-24 17:16:18.000000000 +0100
++++ unix/fpu087.c 2012-03-24 17:17:15.000000000 +0100
+@@ -31,7 +31,7 @@
+ if (isnan(*x) || isnan(*y) || isinf(*x) || isinf(*y))
+ *atan = 1.0;
+ else
+- *atan = (double)atan2l(*y,*x);
++ *atan = (double)atan2f((float)*y,(float)*x);
+ }
+
+ void FPUcplxmul(_CMPLX *x, _CMPLX *y, _CMPLX *z)
+@@ -112,7 +112,7 @@
+ if (isnan(xx) || isnan(xy) || isinf(xx) || isinf(xy))
+ z->y = 1.0;
+ else
+- z->y = (double)atan2l(xy,xx);
++ z->y = (double)atan2f((float)xy,(float)xx);
+ }
+
+ void FPUcplxexp387(_CMPLX *x, _CMPLX *z)
diff --git a/graphics/xfractint/files/patch-Makefile b/graphics/xfractint/files/patch-Makefile
index d50ea36a5509..b1a03108ccff 100644
--- a/graphics/xfractint/files/patch-Makefile
+++ b/graphics/xfractint/files/patch-Makefile
@@ -1,6 +1,15 @@
---- ./Makefile.orig 2008-09-25 20:55:39.000000000 -0400
-+++ ./Makefile 2010-01-27 13:52:46.000000000 -0500
-@@ -27,8 +27,8 @@
+--- Makefile.orig 2011-05-08 14:39:40.000000000 -0500
++++ Makefile 2012-03-10 17:22:45.000000000 -0500
+@@ -20,7 +20,7 @@
+
+ # Use Xft/fontconfig libraries
+ WITHXFT = -DWITH_XFT
+-XFTHFD = /usr/include/freetype2
++XFTHFD = $(LOCALBASE)/include/freetype2
+ # Or not
+ # WITHXFT =
+ # XFTHFD =
+@@ -34,7 +34,7 @@
# SRCDIR should be a path to the directory that will hold fractint.hlp
# SRCDIR should also hold the .par, .frm, etc. files
@@ -9,8 +18,7 @@
SHRDIR = $(PREFIX)/share/xfractint
# BINDIR is where you put your X11 binaries
BINDIR = $(DESTDIR)/bin
- # MANDIR is where you put your chapter 1 man pages
-@@ -116,22 +116,18 @@
+@@ -123,22 +123,18 @@
#For Solaris, use CFLAGS = -I. -I/usr/openwin/include $(DEFINES) -g
#If you have the nasm assembler on your system add -DNASM to CFLAGS
@@ -25,7 +33,7 @@
-else
-CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX -fno-builtin
-+CFLAGS += -I$(LOCALBASE)/include -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX -fno-builtin
++CFLAGS += -I$(LOCALBASE)/include -I$(HFD) $(DEFINES) -DBIG_ANSI_C -DLINUX -fno-builtin
#CFLAGS = -I$(HFD) $(DEFINES) -g -DBIG_ANSI_C -DLINUX \
# -march=$(ARCH) -fno-builtin
#CFLAGS = -I. $(DEFINES) -g -DBIG_ANSI_C -DLINUX -Os -fno-builtin
@@ -34,7 +42,7 @@
# Gcc is often the only compiler that works for this
# For HPUX, use CC = cc -Aa -D_HPUX_SOURCE
-@@ -140,7 +136,6 @@
+@@ -147,7 +143,6 @@
# For Sun Solaris 2.x w/SparcCompilerC (cc), use CC = cc.
# For Sun Solaris 2.x w/GNU gcc, use CC = gcc
#CC = gcc
@@ -42,7 +50,7 @@
# For HPUX, use LIBS = -L/usr/lib/X11R4 -lX11 -lm -lcurses -ltermcap
# For AIX or OSF/1, add -lbsd
-@@ -152,11 +147,7 @@
+@@ -159,11 +154,7 @@
# LIBS = -L/usr/X11R6/lib -lX11 -lm -lncurses
# LIBS = -lX11 -lm -lcurses
diff --git a/graphics/xfractint/files/patch-common__biginit.c b/graphics/xfractint/files/patch-common__biginit.c
index 1115230d646c..67a5e1800319 100644
--- a/graphics/xfractint/files/patch-common__biginit.c
+++ b/graphics/xfractint/files/patch-common__biginit.c
@@ -1,12 +1,11 @@
---- ./common/biginit.c.orig 2008-09-18 21:58:09.000000000 -0400
-+++ ./common/biginit.c 2010-01-27 13:52:46.000000000 -0500
-@@ -7,7 +7,9 @@
- */
-
+--- common/biginit.c.orig 2011-05-07 15:28:14.000000000 -0500
++++ common/biginit.c 2012-03-10 17:13:34.000000000 -0500
+@@ -9,7 +9,7 @@
#include <string.h>
-+#ifndef BIG_ANSI_C
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+-#else
++#elif !defined(BIG_ANSI_C)
#include <malloc.h>
-+#endif
+ #endif
/* see Fractint.c for a description of the "include" hierarchy */
- #include "port.h"
- #include "prototyp.h"
diff --git a/graphics/xfractint/files/patch-common__fractalb.c b/graphics/xfractint/files/patch-common__fractalb.c
index d472b1fa36a5..55e40226f0e2 100644
--- a/graphics/xfractint/files/patch-common__fractalb.c
+++ b/graphics/xfractint/files/patch-common__fractalb.c
@@ -1,9 +1,9 @@
---- ./common/fractalb.c.orig 2008-09-17 21:52:35.000000000 -0400
-+++ ./common/fractalb.c 2010-01-27 13:52:46.000000000 -0500
-@@ -10,7 +10,7 @@
- #include <string.h>
- #ifdef __TURBOC__
+--- common/fractalb.c.orig 2011-05-07 15:31:02.000000000 -0500
++++ common/fractalb.c 2012-03-10 16:31:30.000000000 -0500
+@@ -12,7 +12,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__fractals.c b/graphics/xfractint/files/patch-common__fractals.c
index ffe231c3c51b..3e95b15bec55 100644
--- a/graphics/xfractint/files/patch-common__fractals.c
+++ b/graphics/xfractint/files/patch-common__fractals.c
@@ -1,9 +1,9 @@
---- ./common/fractals.c.orig 2008-09-17 21:52:35.000000000 -0400
-+++ ./common/fractals.c 2010-01-27 13:52:46.000000000 -0500
-@@ -41,7 +41,7 @@
- #include <string.h>
- #ifdef __TURBOC__
+--- common/fractals.c.orig 2011-05-08 11:47:58.000000000 -0500
++++ common/fractals.c 2012-03-10 16:33:40.000000000 -0500
+@@ -43,7 +43,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__frasetup.c b/graphics/xfractint/files/patch-common__frasetup.c
index 2c756960162e..bfe0eb2c5124 100644
--- a/graphics/xfractint/files/patch-common__frasetup.c
+++ b/graphics/xfractint/files/patch-common__frasetup.c
@@ -1,9 +1,9 @@
---- ./common/frasetup.c.orig 2004-11-23 08:13:37.000000000 -0500
-+++ ./common/frasetup.c 2010-01-27 13:52:46.000000000 -0500
-@@ -2,7 +2,7 @@
- #include <string.h>
- #ifdef __TURBOC__
+--- common/frasetup.c.orig 2011-05-07 15:32:06.000000000 -0500
++++ common/frasetup.c 2012-03-10 16:35:22.000000000 -0500
+@@ -4,7 +4,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__lsys.c b/graphics/xfractint/files/patch-common__lsys.c
index 9f00583c4263..f1c6ac799389 100644
--- a/graphics/xfractint/files/patch-common__lsys.c
+++ b/graphics/xfractint/files/patch-common__lsys.c
@@ -1,9 +1,9 @@
---- ./common/lsys.c.orig 2005-12-21 21:15:40.000000000 -0500
-+++ ./common/lsys.c 2010-01-27 13:52:46.000000000 -0500
-@@ -2,7 +2,7 @@
- #include <string.h>
- #ifdef __TURBOC__
+--- common/lsys.c.orig 2011-05-07 15:34:46.000000000 -0500
++++ common/lsys.c 2012-03-10 16:37:40.000000000 -0500
+@@ -4,7 +4,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#else
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__lsysf.c b/graphics/xfractint/files/patch-common__lsysf.c
index 1e1c479c5fb3..de1039b6b943 100644
--- a/graphics/xfractint/files/patch-common__lsysf.c
+++ b/graphics/xfractint/files/patch-common__lsysf.c
@@ -1,9 +1,9 @@
---- ./common/lsysf.c.orig 2004-11-23 08:13:37.000000000 -0500
-+++ ./common/lsysf.c 2010-01-27 13:52:46.000000000 -0500
-@@ -1,7 +1,7 @@
- #include <string.h>
- #ifdef __TURBOC__
+--- common/lsysf.c.orig 2011-05-07 15:35:02.000000000 -0500
++++ common/lsysf.c 2012-03-10 16:50:40.000000000 -0500
+@@ -3,7 +3,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#else
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__memory.c b/graphics/xfractint/files/patch-common__memory.c
index 3562852fd515..fd53097a5873 100644
--- a/graphics/xfractint/files/patch-common__memory.c
+++ b/graphics/xfractint/files/patch-common__memory.c
@@ -1,9 +1,11 @@
---- ./common/memory.c.orig 2006-12-17 12:06:05.000000000 -0500
-+++ ./common/memory.c 2010-01-27 13:52:46.000000000 -0500
-@@ -1,6 +1,5 @@
- #include <string.h>
+--- common/memory.c.orig 2012-03-10 16:57:05.000000000 -0500
++++ common/memory.c 2012-03-10 16:57:36.000000000 -0500
+@@ -2,7 +2,7 @@
#include <limits.h>
--#include <malloc.h>
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+-#else
++#elif !defined(BIG_ANSI_C)
+ #include <malloc.h>
+ #endif
- #if (!defined(XFRACT) && !defined(WINFRACT))
- #include <io.h>
diff --git a/graphics/xfractint/files/patch-common__miscres.c b/graphics/xfractint/files/patch-common__miscres.c
index 06451bc6451e..be2f253d8d25 100644
--- a/graphics/xfractint/files/patch-common__miscres.c
+++ b/graphics/xfractint/files/patch-common__miscres.c
@@ -1,10 +1,11 @@
---- ./common/miscres.c.orig 2007-05-02 20:32:43.000000000 -0400
-+++ ./common/miscres.c 2010-01-27 13:52:46.000000000 -0500
-@@ -5,7 +5,6 @@
- #include <string.h>
- #include <ctype.h>
+--- common/miscres.c.orig 2011-05-08 10:19:52.000000000 -0500
++++ common/miscres.c 2012-03-10 16:58:44.000000000 -0500
+@@ -7,7 +7,7 @@
#include <time.h>
--#include <malloc.h>
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+-#else
++#elif !defined(BIG_ANSI_C)
+ #include <malloc.h>
+ #endif
- #ifndef XFRACT
- #include <io.h>
diff --git a/graphics/xfractint/files/patch-common__mpmath_c.c b/graphics/xfractint/files/patch-common__mpmath_c.c
new file mode 100644
index 000000000000..a81264466a2e
--- /dev/null
+++ b/graphics/xfractint/files/patch-common__mpmath_c.c
@@ -0,0 +1,11 @@
+--- common/mpmath_c.c.orig 2012-03-10 17:28:37.000000000 -0500
++++ common/mpmath_c.c 2012-03-10 17:34:32.000000000 -0500
+@@ -220,7 +220,7 @@
+ if(t.x < -690)
+ e2x = 0.0;
+ else
+- e2x = expl(t.x);
++ e2x = exp(t.x);
+ #ifdef XFRACT
+ if (isnan(e2x) || isinf(e2x))
+ e2x = 1.0;
diff --git a/graphics/xfractint/files/patch-common__prompts1.c b/graphics/xfractint/files/patch-common__prompts1.c
index 2415ddc5e9d9..69f56e40cf20 100644
--- a/graphics/xfractint/files/patch-common__prompts1.c
+++ b/graphics/xfractint/files/patch-common__prompts1.c
@@ -1,9 +1,9 @@
---- ./common/prompts1.c.orig 2008-08-04 21:44:54.000000000 -0400
-+++ ./common/prompts1.c 2010-01-27 13:52:46.000000000 -0500
-@@ -12,7 +12,7 @@
- #endif
- #ifdef __TURBOC__
+--- common/prompts1.c.orig 2011-05-07 15:32:26.000000000 -0500
++++ common/prompts1.c 2012-03-10 17:02:06.000000000 -0500
+@@ -14,7 +14,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__prompts2.c b/graphics/xfractint/files/patch-common__prompts2.c
index cea9ae8748de..077dc9e8a918 100644
--- a/graphics/xfractint/files/patch-common__prompts2.c
+++ b/graphics/xfractint/files/patch-common__prompts2.c
@@ -1,5 +1,5 @@
---- ./common/prompts2.c.orig 2008-02-17 11:10:04.000000000 -0500
-+++ ./common/prompts2.c 2010-01-27 13:52:46.000000000 -0500
+--- common/prompts2.c.orig 2011-05-08 10:20:02.000000000 -0500
++++ common/prompts2.c 2012-03-10 17:04:43.000000000 -0500
@@ -12,7 +12,7 @@
#ifdef DIRENT
@@ -9,10 +9,10 @@
#include <sys/dir.h>
#else
#include <dirent.h>
-@@ -24,7 +24,7 @@
- #endif
- #ifdef __TURBOC__
+@@ -26,7 +26,7 @@
#include <alloc.h>
+ #elif defined(__APPLE__)
+ #include <malloc/malloc.h>
-#elif !defined(__386BSD__)
+#elif !defined(BIG_ANSI_C)
#include <malloc.h>
diff --git a/graphics/xfractint/files/patch-common__soi.c b/graphics/xfractint/files/patch-common__soi.c
index 5e3675523756..9f35b9f8ff35 100644
--- a/graphics/xfractint/files/patch-common__soi.c
+++ b/graphics/xfractint/files/patch-common__soi.c
@@ -1,16 +1,15 @@
---- ./common/soi.c.orig 2004-11-23 08:13:37.000000000 -0500
-+++ ./common/soi.c 2010-01-27 13:52:46.000000000 -0500
-@@ -13,7 +13,9 @@
- */
- #include <time.h>
+--- common/soi.c.orig 2011-05-07 15:36:36.000000000 -0500
++++ common/soi.c 2012-03-10 17:08:47.000000000 -0500
+@@ -15,7 +15,7 @@
#include <string.h>
-+#ifndef BIG_ANSI_C
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+-#else
++#elif !defined(BIG_ANSI_C)
#include <malloc.h>
-+#endif
+ #endif
#include "port.h"
- #include "prototyp.h"
-
-@@ -21,7 +23,7 @@
+@@ -25,7 +25,7 @@
#define FABS(x) fabsl(x)
/* the following needs to be changed back to frexpl once the portability
issue has been addressed JCO */
diff --git a/graphics/xfractint/files/patch-common__soi1.c b/graphics/xfractint/files/patch-common__soi1.c
index e086d8a0cc4d..fbb0c5a285be 100644
--- a/graphics/xfractint/files/patch-common__soi1.c
+++ b/graphics/xfractint/files/patch-common__soi1.c
@@ -1,12 +1,11 @@
---- ./common/soi1.c.orig 2004-11-23 08:13:37.000000000 -0500
-+++ ./common/soi1.c 2010-01-27 13:52:46.000000000 -0500
-@@ -13,7 +13,9 @@
- */
- #include <time.h>
+--- common/soi1.c.orig 2011-05-07 15:36:50.000000000 -0500
++++ common/soi1.c 2012-03-10 17:10:37.000000000 -0500
+@@ -15,7 +15,7 @@
#include <string.h>
-+#ifndef BIG_ANSI_C
+ #ifdef __APPLE__
+ #include <malloc/malloc.h>
+-#else
++#elif !defined(BIG_ANSI_C)
#include <malloc.h>
-+#endif
+ #endif
#include "port.h"
- #include "prototyp.h"
-
diff --git a/graphics/xfractint/files/patch-unix__fpu087.c b/graphics/xfractint/files/patch-unix__fpu087.c
new file mode 100644
index 000000000000..28023b9df7ae
--- /dev/null
+++ b/graphics/xfractint/files/patch-unix__fpu087.c
@@ -0,0 +1,22 @@
+--- unix/fpu087.c.orig 2012-03-10 17:28:49.000000000 -0500
++++ unix/fpu087.c 2012-03-10 17:36:40.000000000 -0500
+@@ -86,8 +86,8 @@
+ *Sinh = 1.0;
+ *Cosh = 1.0;
+ } else {
+- *Sinh = (double)sinhl(*Angle);
+- *Cosh = (double)coshl(*Angle);
++ *Sinh = (double)sinh(*Angle);
++ *Cosh = (double)cosh(*Angle);
+ }
+ if (isnan(*Sinh) || isinf(*Sinh))
+ *Sinh = 1.0;
+@@ -119,7 +119,7 @@
+ {
+ LDBL pwr,y;
+ y = x->y;
+- pwr = expl(x->x);
++ pwr = exp(x->x);
+ if (isnan(pwr) || isinf(pwr))
+ pwr = 1.0;
+ z->x = (double)(pwr*cosl(y));
diff --git a/graphics/xfractint/pkg-descr b/graphics/xfractint/pkg-descr
index 15a72df570f3..b96220443ea7 100644
--- a/graphics/xfractint/pkg-descr
+++ b/graphics/xfractint/pkg-descr
@@ -5,4 +5,4 @@ the Stone Soup Group.
The unix port was done by Ken Shirriff and modified by Scott D. Boyd.
-WWW: http://spanky.triumf.ca/www/fractint/xfractint_port.html
+WWW: http://www.nahee.com/spanky/www/fractint/