aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmlgraphics-commons
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-08-21 19:42:25 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-08-21 19:42:25 +0000
commit83a13ea186ce8be877e35f034f40351d0d208b34 (patch)
treea8b40422ce6446570183f805a759d02cebc4c811 /graphics/xmlgraphics-commons
parentbf1bbaa10fc743793fd49c6e01f18f9a3b3b5879 (diff)
downloadports-83a13ea186ce8be877e35f034f40351d0d208b34.tar.gz
ports-83a13ea186ce8be877e35f034f40351d0d208b34.zip
graphics/xmlgraphics-commons:
- Update to 2.3 - Switch to the binary distribution since building from the sources requires maven
Notes
Notes: svn path=/head/; revision=509549
Diffstat (limited to 'graphics/xmlgraphics-commons')
-rw-r--r--graphics/xmlgraphics-commons/Makefile33
-rw-r--r--graphics/xmlgraphics-commons/distinfo5
2 files changed, 25 insertions, 13 deletions
diff --git a/graphics/xmlgraphics-commons/Makefile b/graphics/xmlgraphics-commons/Makefile
index 331f21cc67ae..d8ed0f9b2a42 100644
--- a/graphics/xmlgraphics-commons/Makefile
+++ b/graphics/xmlgraphics-commons/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= xmlgraphics-commons
-PORTVERSION= 1.5
-DISTVERSIONSUFFIX= -src
+PORTVERSION= 2.3
+DISTVERSIONSUFFIX= -bin
CATEGORIES= graphics textproc java
-MASTER_SITES= APACHE/xmlgraphics/commons/source
+MASTER_SITES= APACHE/xmlgraphics/commons/binaries
MAINTAINER= makc@FreeBSD.org
COMMENT= Several reusable components used by Apache Batik and FOP
@@ -13,18 +13,29 @@ COMMENT= Several reusable components used by Apache Batik and FOP
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_JAVA= 1.6+
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
-USE_ANT= yes
NO_ARCH= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+PLIST_FILES= ${JAVAJARDIR}/${JARFILE_VER} \
+ ${JAVAJARDIR}/${JARFILE}
+PORTDOCS= *
+
+JARFILE= ${PORTNAME}.jar
+JARFILE_VER= ${PORTNAME}-${PORTVERSION}.jar
+
+OPTIONS_DEFINE= DOCS
do-install:
- @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar \
- ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_DATA} ${WRKSRC}/build/${JARFILE_VER} ${STAGEDIR}${JAVAJARDIR}
+ ${LN} -sf ${JARFILE_VER} ${STAGEDIR}${JAVAJARDIR}/${JARFILE}
+
+do-install-DOCS-on:
+ (cd ${WRKSRC}/javadocs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} \
+ NOTICE README ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/graphics/xmlgraphics-commons/distinfo b/graphics/xmlgraphics-commons/distinfo
index b25b2dbc1fed..b34808e20891 100644
--- a/graphics/xmlgraphics-commons/distinfo
+++ b/graphics/xmlgraphics-commons/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xmlgraphics-commons-1.5-src.tar.gz) = f73322f1fafdcf5391d0411a377ac6c566e17536daf64b29f1370d6e718d0867
-SIZE (xmlgraphics-commons-1.5-src.tar.gz) = 2597097
+TIMESTAMP = 1566386836
+SHA256 (xmlgraphics-commons-2.3-bin.tar.gz) = 7c6817800eab92f92054ea4bed57aba7dafb9229adf5f82b955449eb51f9c1f4
+SIZE (xmlgraphics-commons-2.3-bin.tar.gz) = 1545178