aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmlgraphics-commons
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:26:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-13 11:26:45 +0000
commitc29b862b754d453c9fe092c9694c15d6f235c15a (patch)
tree8295dfe6e8af8443381327004977880af2181f4d /graphics/xmlgraphics-commons
parentdb3fd8aecf7fe436b2ff65cdc4f7390791eb97e7 (diff)
downloadports-c29b862b754d453c9fe092c9694c15d6f235c15a.tar.gz
ports-c29b862b754d453c9fe092c9694c15d6f235c15a.zip
Apache XML Graphics Commons is a library that consists of several reusable
components used by Apache Batik and Apache FOP. Many of these components can easily be used separately outside the domains of SVG and XSL-FO. You will find components such as a PDF library, an RTF library, Graphics2D implementations that let you generate PDF & PostScript files, and much more. WWW: http://xmlgraphics.apache.org/commons/ PR: ports/143862 Submitted by: Rob Farmer <rfarmer@predatorlabs.net> (maintainer)
Notes
Notes: svn path=/head/; revision=249768
Diffstat (limited to 'graphics/xmlgraphics-commons')
-rw-r--r--graphics/xmlgraphics-commons/Makefile28
-rw-r--r--graphics/xmlgraphics-commons/distinfo3
-rw-r--r--graphics/xmlgraphics-commons/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/xmlgraphics-commons/Makefile b/graphics/xmlgraphics-commons/Makefile
new file mode 100644
index 000000000000..12230ae8beff
--- /dev/null
+++ b/graphics/xmlgraphics-commons/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xmlgraphics-commons
+# Date created: 11 February 2010
+# Whom: rfarmer@predatorlabs.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlgraphics-commons
+PORTVERSION= 1.3.1
+CATEGORIES= graphics textproc java
+MASTER_SITES= APACHE/xmlgraphics/commons/source
+EXTRACT_SUFX= -src.tar.gz
+
+MAINTAINER= rfarmer@predatorlabs.net
+COMMENT= Several reusable components used by Apache Batik and FOP
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+JAVA_BUILD= yes
+JAVA_RUN= yes
+USE_ANT= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+
+.include <bsd.port.mk>
diff --git a/graphics/xmlgraphics-commons/distinfo b/graphics/xmlgraphics-commons/distinfo
new file mode 100644
index 000000000000..9bef81577fc2
--- /dev/null
+++ b/graphics/xmlgraphics-commons/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmlgraphics-commons-1.3.1-src.tar.gz) = 4dcac6600df8282685be6972bf9b4de4
+SHA256 (xmlgraphics-commons-1.3.1-src.tar.gz) = 1dd2acfe892af34196d5365addd8e106dd355a2b4bead5f44feea4edcfc452b1
+SIZE (xmlgraphics-commons-1.3.1-src.tar.gz) = 751502
diff --git a/graphics/xmlgraphics-commons/pkg-descr b/graphics/xmlgraphics-commons/pkg-descr
new file mode 100644
index 000000000000..bd0909e4070b
--- /dev/null
+++ b/graphics/xmlgraphics-commons/pkg-descr
@@ -0,0 +1,7 @@
+Apache XML Graphics Commons is a library that consists of several reusable
+components used by Apache Batik and Apache FOP. Many of these components can
+easily be used separately outside the domains of SVG and XSL-FO. You will
+find components such as a PDF library, an RTF library, Graphics2D
+implementations that let you generate PDF & PostScript files, and much more.
+
+WWW: http://xmlgraphics.apache.org/commons/