aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmorph/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-16 14:07:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-16 14:07:06 +0000
commitdaee40370ec57dad348b49c2dcd61b3862a5dde4 (patch)
treeddcb73771305f6ad99b99bf9a39f454e201f7207 /graphics/xmorph/Makefile
parentb377416de98547ec3a1ba07cd49029db0b6bc3aa (diff)
downloadports-daee40370ec57dad348b49c2dcd61b3862a5dde4.tar.gz
ports-daee40370ec57dad348b49c2dcd61b3862a5dde4.zip
Notes
Diffstat (limited to 'graphics/xmorph/Makefile')
-rw-r--r--graphics/xmorph/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index 0004d9acf537..427b0bcda459 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -6,23 +6,23 @@
#
PORTNAME= xmorph
-PORTVERSION= 2003.05.27
-PORTREVISION= 1
+PORTVERSION= 2004.01.10
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_DEBIAN}
-MASTER_SITE_SUBDIR= pool/main/x/xmorph
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A digital image warping program
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
+WRKSRC= ${WRKDIR}/${PORTNAME}-current
CONFLICTS= libmorph*
USE_X_PREFIX= yes
WANT_GNOME= yes
-USE_LIBTOOL_VER=13
+USE_GNOME= gnometarget lthack
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
INSTALLS_SHLIB= yes
@@ -36,13 +36,18 @@ INFO= xmorph
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-gtk2
MAN1+= gtkmorph.1
-PLIST_SUB+= GTK2=""
.else
CONFIGURE_ARGS+= --without-gtkmorph
-PLIST_SUB+= GTK2="@comment "
.endif
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.post.mk>