aboutsummaryrefslogtreecommitdiff
path: root/graphics/xournal
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-09-07 00:45:27 +0000
committerSteve Wills <swills@FreeBSD.org>2017-09-07 00:45:27 +0000
commiteaa76a85f0834caa5d96705c6fb04b047627ece8 (patch)
tree20060ae756ac752ebeb21631b9bb5889fae82a85 /graphics/xournal
parent6ea79f805eacaab7a530e2b74f77a2e5ee9341ab (diff)
downloadports-eaa76a85f0834caa5d96705c6fb04b047627ece8.tar.gz
ports-eaa76a85f0834caa5d96705c6fb04b047627ece8.zip
graphics/xournal: make DATADIR clean
While here, put back USES=desktop-file-utils shared-mime-info which was mistakenly removed in previous commits. PR: 221713 Approved by: me@janh.de (maintainer timeout, >2 weeks)
Notes
Notes: svn path=/head/; revision=449383
Diffstat (limited to 'graphics/xournal')
-rw-r--r--graphics/xournal/Makefile8
-rw-r--r--graphics/xournal/files/patch-Makefile.in19
-rw-r--r--graphics/xournal/files/patch-configure6
-rw-r--r--graphics/xournal/files/patch-src_Makefile.in11
-rw-r--r--graphics/xournal/files/patch-src_main.c11
5 files changed, 41 insertions, 14 deletions
diff --git a/graphics/xournal/Makefile b/graphics/xournal/Makefile
index d2fbc717a78a..20b7d115d99c 100644
--- a/graphics/xournal/Makefile
+++ b/graphics/xournal/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= pkgconfig
+USES= pkgconfig desktop-file-utils shared-mime-info
USE_GNOME= cairo libgnomecanvas
USE_XORG= x11
GNU_CONFIGURE= yes
@@ -29,6 +29,7 @@ GHOSTSCRIPT_DESC= Install ghostscript (PS/PDF as bitmap bg)
OPTIONS_DEFAULT= GHOSTSCRIPT
GHOSTSCRIPT_USES= ghostscript:run
+MAKE_ENV+= DATADIR=${DATADIR}
PORTDOCS_MAIN= AUTHORS \
ChangeLog \
@@ -68,11 +69,6 @@ PORTDOCS= ${PORTDOCS_MAIN} \
html-doc/pixmaps/black.png \
html-doc/pixmaps/text-tool.png
-post-patch:
- @${REINPLACE_CMD} \
- -e 's|$$(DESTDIR)/usr/share/|$$(DESTDIR)$$$$desktopdir/|g' \
- ${WRKSRC}/Makefile.in
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS_MAIN:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/xournal/files/patch-Makefile.in b/graphics/xournal/files/patch-Makefile.in
index 69fd92721e57..bf675f78355b 100644
--- a/graphics/xournal/files/patch-Makefile.in
+++ b/graphics/xournal/files/patch-Makefile.in
@@ -1,6 +1,15 @@
---- Makefile.in.orig 2014-06-29 08:53:20.000000000 +0200
-+++ Makefile.in 2015-02-23 22:51:49.000000000 +0100
-@@ -796,31 +796,29 @@
+--- Makefile.in.orig 2017-07-20 18:30:27 UTC
++++ Makefile.in
+@@ -809,38 +809,36 @@ uninstall-am:
+ install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+- $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/pixmaps; \
++ $(mkinstalldirs) $(DESTDIR)$(DATADIR)/pixmaps; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+- $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
++ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(DATADIR)/pixmaps; \
fi \
done \
fi; \
@@ -33,7 +42,7 @@
- else \
- desktopdir=/usr/local/share; \
- fi; \
-+ desktopdir=$(pkgdatadir); \
++ desktopdir=$(DATADIR); \
$(mkinstalldirs) $(DESTDIR)$$desktopdir/icons/hicolor/scalable/apps; \
$(mkinstalldirs) $(DESTDIR)$$desktopdir/icons/hicolor/scalable/mimetypes; \
$(mkinstalldirs) $(DESTDIR)$$desktopdir/mime/packages; \
@@ -43,7 +52,7 @@
$(INSTALL_DATA) $(srcdir)/pixmaps/xournal.svg $(DESTDIR)$$desktopdir/icons/hicolor/scalable/apps; \
$(INSTALL_DATA) $(srcdir)/pixmaps/xoj.svg $(DESTDIR)$$desktopdir/icons/hicolor/scalable/mimetypes; \
if test ! -e $(DESTDIR)$$desktopdir/icons/hicolor/scalable/mimetypes/gnome-mime-application-x-xoj.svg; then \
-@@ -828,7 +826,7 @@
+@@ -851,7 +849,7 @@ desktop-install:
fi; \
$(INSTALL_DATA) $(srcdir)/xournal.xml $(DESTDIR)$$desktopdir/mime/packages; \
$(INSTALL_DATA) $(srcdir)/xournal.desktop $(DESTDIR)$$desktopdir/applications; \
diff --git a/graphics/xournal/files/patch-configure b/graphics/xournal/files/patch-configure
index 25d8b47efd97..9b2b3e4b3c48 100644
--- a/graphics/xournal/files/patch-configure
+++ b/graphics/xournal/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-07-20 18:30:25.000000000 +0000
-+++ configure 2017-08-01 14:05:24.637135000 +0000
-@@ -5605,6 +5605,8 @@
+--- configure.orig 2017-07-20 18:30:25 UTC
++++ configure
+@@ -5605,6 +5605,8 @@ fi
case "$host" in
*-*-linux*)
os_linux=yes;;
diff --git a/graphics/xournal/files/patch-src_Makefile.in b/graphics/xournal/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..aaeb25339077
--- /dev/null
+++ b/graphics/xournal/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2017-08-20 23:55:48 UTC
++++ src/Makefile.in
+@@ -342,7 +342,7 @@ top_srcdir = @top_srcdir@
+ @WIN32_FALSE@SUBDIRS = ttsubset
+ @WIN32_TRUE@SUBDIRS = ttsubset win32
+ INCLUDES = \
+- -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
++ -DPACKAGE_DATA_DIR=\""$(DATADIR)/pixmaps"\" \
+ -DPACKAGE_LOCALE_DIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ @PACKAGE_CFLAGS@
+
diff --git a/graphics/xournal/files/patch-src_main.c b/graphics/xournal/files/patch-src_main.c
new file mode 100644
index 000000000000..cfaac9b4a744
--- /dev/null
+++ b/graphics/xournal/files/patch-src_main.c
@@ -0,0 +1,11 @@
+--- src/main.c.orig 2015-10-25 04:26:29 UTC
++++ src/main.c
+@@ -360,7 +360,7 @@ main (int argc, char *argv[])
+ g_free(path);
+ g_free(path1);
+ g_free(path2);
+- add_pixmap_directory (PACKAGE_DATA_DIR "/" PACKAGE "/pixmaps");
++ add_pixmap_directory (PACKAGE_DATA_DIR);
+
+ /*
+ * The following code was added by Glade to create one of each component