aboutsummaryrefslogtreecommitdiff
path: root/graphics/xournalpp
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-08 02:44:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-08 02:44:42 +0000
commitf9c7c3aa9a0b330f92e20388c8b98f24ccbd8106 (patch)
treeb58a84a5e580e578431584e4d924ede103561e41 /graphics/xournalpp
parentc998c5b9f22a1be271cd2bbffc98fd69ff64b53d (diff)
downloadports-f9c7c3aa9a0b330f92e20388c8b98f24ccbd8106.tar.gz
ports-f9c7c3aa9a0b330f92e20388c8b98f24ccbd8106.zip
New port: graphics/xournalpp: Handwriting notetaking software with PDF annotation support
Notes
Notes: svn path=/head/; revision=492405
Diffstat (limited to 'graphics/xournalpp')
-rw-r--r--graphics/xournalpp/Makefile26
-rw-r--r--graphics/xournalpp/distinfo3
-rw-r--r--graphics/xournalpp/pkg-descr8
-rw-r--r--graphics/xournalpp/pkg-plist89
4 files changed, 126 insertions, 0 deletions
diff --git a/graphics/xournalpp/Makefile b/graphics/xournalpp/Makefile
new file mode 100644
index 000000000000..270a5c660eb0
--- /dev/null
+++ b/graphics/xournalpp/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= xournalpp
+DISTVERSION= 1.0.7-135
+DISTVERSIONSUFFIX= -g2f5b575e
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Handwriting notetaking software with PDF annotation support
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib \
+ libportaudio.so:audio/portaudio \
+ libsndfile.so:audio/libsndfile
+
+USES= cmake compiler:c++11-lang gettext-tools gnome pkgconfig
+USE_GITHUB= yes
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 libxml2 pango
+USE_XORG= x11 xi
+USE_TEX= latex:build
+
+WITH_DEBUG= 1 # workaround for https://github.com/xournalpp/xournalpp/issues/844 (symbol not found)
+
+.include <bsd.port.mk>
diff --git a/graphics/xournalpp/distinfo b/graphics/xournalpp/distinfo
new file mode 100644
index 000000000000..37e460fea7f4
--- /dev/null
+++ b/graphics/xournalpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549589007
+SHA256 (xournalpp-xournalpp-1.0.7-135-g2f5b575e_GH0.tar.gz) = 76a724f5f7ae21b6f7d7e01d871f67e6d5df58e5bdbb421fc9c5e9582d070fc9
+SIZE (xournalpp-xournalpp-1.0.7-135-g2f5b575e_GH0.tar.gz) = 8480613
diff --git a/graphics/xournalpp/pkg-descr b/graphics/xournalpp/pkg-descr
new file mode 100644
index 000000000000..98f3ec36611f
--- /dev/null
+++ b/graphics/xournalpp/pkg-descr
@@ -0,0 +1,8 @@
+Xournal++ is a handwriting Notetaking software with PDF annotation support.
+Written in C++ with plattform independent GTK, supporting Linux, e.g. Ubuntu,
+Debian, Arch, Suse, macOS and Windows 10. Supports Pen input like Wacom Tablets.
+
+Xournal++ is an evolution, and a rewrite of the pdf annotating program Xournal
+that is also available as a port: graphics/xournal
+
+WWW: https://github.com/xournalpp/xournalpp
diff --git a/graphics/xournalpp/pkg-plist b/graphics/xournalpp/pkg-plist
new file mode 100644
index 000000000000..8d6a9fd74099
--- /dev/null
+++ b/graphics/xournalpp/pkg-plist
@@ -0,0 +1,89 @@
+bin/xournal-thumbnailer
+bin/xournalpp
+share/locale/cs/LC_MESSAGES/xournalpp.mo
+share/locale/de/LC_MESSAGES/xournalpp.mo
+share/locale/it/LC_MESSAGES/xournalpp.mo
+share/locale/pl/LC_MESSAGES/xournalpp.mo
+share/locale/zh/LC_MESSAGES/xournalpp.mo
+share/locale/zh_HK/LC_MESSAGES/xournalpp.mo
+share/locale/zh_TW/LC_MESSAGES/xournalpp.mo
+%%DATADIR%%/ui/about.glade
+%%DATADIR%%/ui/exportSettings.glade
+%%DATADIR%%/ui/fillTransparency.glade
+%%DATADIR%%/ui/goto.glade
+%%DATADIR%%/ui/images.glade
+%%DATADIR%%/ui/main.glade
+%%DATADIR%%/ui/pageTemplate.glade
+%%DATADIR%%/ui/pagesize.glade
+%%DATADIR%%/ui/pagetemplates.ini
+%%DATADIR%%/ui/pdfpages.glade
+%%DATADIR%%/ui/pixmaps/addPage.svg
+%%DATADIR%%/ui/pixmaps/application-x-xojpp.svg
+%%DATADIR%%/ui/pixmaps/application-x-xopp.svg
+%%DATADIR%%/ui/pixmaps/application-x-xopt.svg
+%%DATADIR%%/ui/pixmaps/arrow-draw.svg
+%%DATADIR%%/ui/pixmaps/centerPage.svg
+%%DATADIR%%/ui/pixmaps/circle-draw.svg
+%%DATADIR%%/ui/pixmaps/coordinate-system-draw.svg
+%%DATADIR%%/ui/pixmaps/dark/arrow-draw.svg
+%%DATADIR%%/ui/pixmaps/dark/circle-draw.svg
+%%DATADIR%%/ui/pixmaps/dark/coordinate-system-draw.svg
+%%DATADIR%%/ui/pixmaps/dark/fill.svg
+%%DATADIR%%/ui/pixmaps/dark/grid_snapping.svg
+%%DATADIR%%/ui/pixmaps/dark/rect-draw.svg
+%%DATADIR%%/ui/pixmaps/dark/ruler.svg
+%%DATADIR%%/ui/pixmaps/dark/shape_recognizer.svg
+%%DATADIR%%/ui/pixmaps/dark/snapping.svg
+%%DATADIR%%/ui/pixmaps/dark/thickness_medium.svg
+%%DATADIR%%/ui/pixmaps/dark/thickness_thick.svg
+%%DATADIR%%/ui/pixmaps/dark/thickness_thin.svg
+%%DATADIR%%/ui/pixmaps/dark/tool_text.svg
+%%DATADIR%%/ui/pixmaps/default.svg
+%%DATADIR%%/ui/pixmaps/delPage.svg
+%%DATADIR%%/ui/pixmaps/empty.svg
+%%DATADIR%%/ui/pixmaps/fill.svg
+%%DATADIR%%/ui/pixmaps/fullscreen.svg
+%%DATADIR%%/ui/pixmaps/gnome-mime-application-x-xopp.svg
+%%DATADIR%%/ui/pixmaps/gnome-mime-application-x-xopt.svg
+%%DATADIR%%/ui/pixmaps/goto.svg
+%%DATADIR%%/ui/pixmaps/grid_snapping.svg
+%%DATADIR%%/ui/pixmaps/hand.svg
+%%DATADIR%%/ui/pixmaps/lasso.svg
+%%DATADIR%%/ui/pixmaps/layer.svg
+%%DATADIR%%/ui/pixmaps/line-style-dash-dot.svg
+%%DATADIR%%/ui/pixmaps/line-style-dash.svg
+%%DATADIR%%/ui/pixmaps/line-style-dot.svg
+%%DATADIR%%/ui/pixmaps/line-style-plain.svg
+%%DATADIR%%/ui/pixmaps/nextAnnotatedPage.svg
+%%DATADIR%%/ui/pixmaps/object-play.svg
+%%DATADIR%%/ui/pixmaps/object-select.svg
+%%DATADIR%%/ui/pixmaps/pageSpinner.png
+%%DATADIR%%/ui/pixmaps/rec.svg
+%%DATADIR%%/ui/pixmaps/rect-draw.svg
+%%DATADIR%%/ui/pixmaps/rect-select.svg
+%%DATADIR%%/ui/pixmaps/ruler.svg
+%%DATADIR%%/ui/pixmaps/shape_recognizer.svg
+%%DATADIR%%/ui/pixmaps/showtwopages.svg
+%%DATADIR%%/ui/pixmaps/sidebar-page-preview.svg
+%%DATADIR%%/ui/pixmaps/sidebar_bookmarks.svg
+%%DATADIR%%/ui/pixmaps/sidebar_index.svg
+%%DATADIR%%/ui/pixmaps/snapping.svg
+%%DATADIR%%/ui/pixmaps/stretch.svg
+%%DATADIR%%/ui/pixmaps/thickness_medium.svg
+%%DATADIR%%/ui/pixmaps/thickness_thick.svg
+%%DATADIR%%/ui/pixmaps/thickness_thin.svg
+%%DATADIR%%/ui/pixmaps/tool_camera.svg
+%%DATADIR%%/ui/pixmaps/tool_eraser.svg
+%%DATADIR%%/ui/pixmaps/tool_highlighter.svg
+%%DATADIR%%/ui/pixmaps/tool_image.svg
+%%DATADIR%%/ui/pixmaps/tool_pencil.svg
+%%DATADIR%%/ui/pixmaps/tool_text.svg
+%%DATADIR%%/ui/pixmaps/xopt.svg
+%%DATADIR%%/ui/pixmaps/xournalpp.png
+%%DATADIR%%/ui/pixmaps/xournalpp.svg
+%%DATADIR%%/ui/settings.glade
+%%DATADIR%%/ui/settingsButtonConfig.glade
+%%DATADIR%%/ui/texdialog.glade
+%%DATADIR%%/ui/toolbar.ini
+%%DATADIR%%/ui/toolbarCustomizeDialog.glade
+%%DATADIR%%/ui/toolbarManageDialog.glade