aboutsummaryrefslogtreecommitdiff
path: root/graphics/yafaray
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-11 00:44:26 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:40 +0000
commit581762cb8de91504f0e76cb5f1ef9f6e17576eeb (patch)
tree08fd44c41cda269dd4726ccd08bd56626a008c1d /graphics/yafaray
parent136cf0c62d8bbf420ca40d06a905819e80b95edf (diff)
downloadports-581762cb8de91504f0e76cb5f1ef9f6e17576eeb.tar.gz
ports-581762cb8de91504f0e76cb5f1ef9f6e17576eeb.zip
Diffstat (limited to 'graphics/yafaray')
-rw-r--r--graphics/yafaray/Makefile6
-rw-r--r--graphics/yafaray/files/patch-CMakeModules_FindOpenEXR.cmake56
-rw-r--r--graphics/yafaray/files/patch-src_image__handlers_exrHandler.cc11
3 files changed, 70 insertions, 3 deletions
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index ee91598859de..53d79228d907 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -3,7 +3,7 @@
PORTNAME= yafaray
DISTVERSIONPREFIX= v
DISTVERSION= 3.5.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MAINTAINER= yuri@FreeBSD.org
@@ -19,8 +19,8 @@ ONLY_FOR_ARCHS_REASON= assembly is only for amd64 and i386, but it breaks on i38
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
- libHalf.so:graphics/ilmbase \
- libIlmImf.so:graphics/openexr \
+ libImath.so:math/Imath \
+ libOpenEXR.so:graphics/openexr \
libopencv_photo.so:graphics/opencv \
libopencv_core.so:graphics/opencv \
libpng.so:graphics/png \
diff --git a/graphics/yafaray/files/patch-CMakeModules_FindOpenEXR.cmake b/graphics/yafaray/files/patch-CMakeModules_FindOpenEXR.cmake
new file mode 100644
index 000000000000..1f23d9bbcf63
--- /dev/null
+++ b/graphics/yafaray/files/patch-CMakeModules_FindOpenEXR.cmake
@@ -0,0 +1,56 @@
+--- CMakeModules/FindOpenEXR.cmake.orig 2020-07-13 08:15:40 UTC
++++ CMakeModules/FindOpenEXR.cmake
+@@ -26,10 +26,13 @@ IF(ZLIB_FOUND)
+ /sw/include
+ /opt/local/include)
+
+- FIND_LIBRARY(OPENEXR_HALF_LIBRARY
+- NAMES Half
+- PATHS ${LIBRARY_DIRS})
+-
++ FIND_PATH(IMATH_INCLUDE_PATH ImathVec.h
++ PATH_SUFFIXES Imath
++ /usr/include
++ /usr/local/include
++ /sw/include
++ /opt/local/include)
++
+ FIND_LIBRARY(OPENEXR_IEX_LIBRARY
+ NAMES Iex
+ PATHS ${LIBRARY_DIRS})
+@@ -39,7 +42,7 @@ IF(ZLIB_FOUND)
+ PATHS ${LIBRARY_DIRS})
+
+ FIND_LIBRARY(OPENEXR_ILMIMF_LIBRARY
+- NAMES IlmImf
++ NAMES OpenEXR
+ PATHS ${LIBRARY_DIRS})
+
+ FIND_LIBRARY(OPENEXR_ILMTHREAD_LIBRARY
+@@ -50,15 +53,15 @@ ENDIF(ZLIB_FOUND)
+
+ #MESSAGE(STATUS ${OPENEXR_IMATH_LIBRARY} ${OPENEXR_ILMIMF_LIBRARY} ${OPENEXR_IEX_LIBRARY} ${OPENEXR_HALF_LIBRARY} ${OPENEXR_ILMTHREAD_LIBRARY} ${ZLIB_LIBRARY})
+
+-IF (OPENEXR_INCLUDE_PATH AND OPENEXR_IMATH_LIBRARY AND OPENEXR_ILMIMF_LIBRARY AND OPENEXR_IEX_LIBRARY AND OPENEXR_HALF_LIBRARY)
++IF (OPENEXR_INCLUDE_PATH AND IMATH_INCLUDE_PATH AND OPENEXR_IMATH_LIBRARY AND OPENEXR_ILMIMF_LIBRARY AND OPENEXR_IEX_LIBRARY)
+ SET(OPENEXR_FOUND TRUE)
+- SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_PATH} CACHE STRING "The include paths needed to use OpenEXR")
+- SET(OPENEXR_LIBRARIES ${OPENEXR_IMATH_LIBRARY} ${OPENEXR_ILMIMF_LIBRARY} ${OPENEXR_IEX_LIBRARY} ${OPENEXR_HALF_LIBRARY} ${ZLIB_LIBRARY} CACHE STRING "The libraries needed to use OpenEXR")
++ SET(OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_PATH} ${IMATH_INCLUDE_PATH} CACHE STRING "The include paths needed to use OpenEXR")
++ SET(OPENEXR_LIBRARIES ${OPENEXR_IMATH_LIBRARY} ${OPENEXR_ILMIMF_LIBRARY} ${OPENEXR_IEX_LIBRARY} ${ZLIB_LIBRARY} CACHE STRING "The libraries needed to use OpenEXR")
+
+ IF(OPENEXR_ILMTHREAD_LIBRARY)
+ SET(OPENEXR_LIBRARIES ${OPENEXR_LIBRARIES} ${OPENEXR_ILMTHREAD_LIBRARY})
+ ENDIF(OPENEXR_ILMTHREAD_LIBRARY)
+-ENDIF (OPENEXR_INCLUDE_PATH AND OPENEXR_IMATH_LIBRARY AND OPENEXR_ILMIMF_LIBRARY AND OPENEXR_IEX_LIBRARY AND OPENEXR_HALF_LIBRARY)
++ENDIF (OPENEXR_INCLUDE_PATH AND OPENEXR_IMATH_LIBRARY AND OPENEXR_ILMIMF_LIBRARY AND OPENEXR_IEX_LIBRARY)
+
+ IF(OPENEXR_FOUND)
+ IF(NOT OPENEXR_FIND_QUIETLY)
+@@ -75,5 +78,4 @@ MARK_AS_ADVANCED(
+ OPENEXR_LIBRARIES
+ OPENEXR_ILMIMF_LIBRARY
+ OPENEXR_IMATH_LIBRARY
+- OPENEXR_IEX_LIBRARY
+- OPENEXR_HALF_LIBRARY)
++ OPENEXR_IEX_LIBRARY)
diff --git a/graphics/yafaray/files/patch-src_image__handlers_exrHandler.cc b/graphics/yafaray/files/patch-src_image__handlers_exrHandler.cc
new file mode 100644
index 000000000000..066f94667c07
--- /dev/null
+++ b/graphics/yafaray/files/patch-src_image__handlers_exrHandler.cc
@@ -0,0 +1,11 @@
+--- src/image_handlers/exrHandler.cc.orig 2020-07-13 08:15:40 UTC
++++ src/image_handlers/exrHandler.cc
+@@ -35,6 +35,8 @@
+ #include <ImfVersion.h>
+ #include <IexThrowErrnoExc.h>
+
++typedef uint64_t Int64;
++
+ using namespace Imf;
+ using namespace Imath;
+