aboutsummaryrefslogtreecommitdiff
path: root/graphics/yafaray
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 04:47:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-06 04:47:58 +0000
commitccd2323721d58b63e4466f1a3be5404c33d9ee5c (patch)
tree702ec1987e63bea3876a718610658c689d2d1081 /graphics/yafaray
parent24c0e6d51ab1198a9c9a811fc32145ac4cc4eca0 (diff)
downloadports-ccd2323721d58b63e4466f1a3be5404c33d9ee5c.tar.gz
ports-ccd2323721d58b63e4466f1a3be5404c33d9ee5c.zip
Unbreak on 5.X and -CURRENT.
Reported by: kris Approved by: portmgr (krion), fjoe (mentor, implicit)
Notes
Notes: svn path=/head/; revision=118557
Diffstat (limited to 'graphics/yafaray')
-rw-r--r--graphics/yafaray/Makefile4
-rw-r--r--graphics/yafaray/files/patch-src::loader::gram_loader.h13
-rw-r--r--graphics/yafaray/files/patch-src::yafraycore::buffer.h13
3 files changed, 26 insertions, 4 deletions
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index 6a8a47ae9ee9..bbe6fdc8ca49 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -39,10 +39,6 @@ pre-everything::
BROKEN= "Does not compile (bad C++ code)"
.endif
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | \
${XARGS} ${REINPLACE_CMD} -E -e \
diff --git a/graphics/yafaray/files/patch-src::loader::gram_loader.h b/graphics/yafaray/files/patch-src::loader::gram_loader.h
new file mode 100644
index 000000000000..2f43ae477901
--- /dev/null
+++ b/graphics/yafaray/files/patch-src::loader::gram_loader.h
@@ -0,0 +1,13 @@
+--- src/loader/gram_loader.h.orig Thu Sep 30 14:48:47 2004
++++ src/loader/gram_loader.h Thu Sep 30 14:49:18 2004
+@@ -22,6 +22,10 @@
+ #ifndef __GRAML_H
+ #define __GRAML_H
+
++#include <iostream>
++
++using namespace std;
++
+ #include "gram_lex.h"
+
+ struct sym_t
diff --git a/graphics/yafaray/files/patch-src::yafraycore::buffer.h b/graphics/yafaray/files/patch-src::yafraycore::buffer.h
new file mode 100644
index 000000000000..84dd8b1e22fe
--- /dev/null
+++ b/graphics/yafaray/files/patch-src::yafraycore::buffer.h
@@ -0,0 +1,13 @@
+--- src/yafraycore/buffer.h.orig Thu Sep 30 14:31:34 2004
++++ src/yafraycore/buffer.h Thu Sep 30 14:42:42 2004
+@@ -27,7 +27,10 @@
+ #include<config.h>
+ #endif
+
++#include <iostream>
+ #include <stdio.h>
++
++using namespace std;
+
+ __BEGIN_YAFRAY
+