aboutsummaryrefslogtreecommitdiff
path: root/graphics/yafray
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-07-07 11:52:21 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-07-07 11:52:21 +0000
commit01c6e9bb9287f8d5736d68dfe5300170ad6f7a65 (patch)
treea44f602b749b0886180a457fcb9ecc29aff4dafc /graphics/yafray
parentc7ee67f144ec3673cdc645de63ece510c559d103 (diff)
downloadports-01c6e9bb9287f8d5736d68dfe5300170ad6f7a65.tar.gz
ports-01c6e9bb9287f8d5736d68dfe5300170ad6f7a65.zip
Notes
Diffstat (limited to 'graphics/yafray')
-rw-r--r--graphics/yafray/Makefile1
-rw-r--r--graphics/yafray/files/patch-src_yafraycore_ccthreads.h12
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index fdf375ad2a1f..9dda6ae36ed5 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -15,7 +15,6 @@ COMMENT= A fast XML based raytracer
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_SCONS= yes
-USE_GETOPT_LONG=yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/yafray/files/patch-src_yafraycore_ccthreads.h b/graphics/yafray/files/patch-src_yafraycore_ccthreads.h
new file mode 100644
index 000000000000..082cf1d35429
--- /dev/null
+++ b/graphics/yafray/files/patch-src_yafraycore_ccthreads.h
@@ -0,0 +1,12 @@
+--- src/yafraycore/ccthreads.h.orig 2007-07-02 17:04:18.000000000 -0400
++++ src/yafraycore/ccthreads.h 2007-07-02 17:04:33.000000000 -0400
+@@ -81,9 +81,7 @@
+ virtual void body()=0;
+ void run();
+ void wait();
+- int getId() {return (int)id;};
+ pthread_t getPid() {return id;};
+- int getSelf() {return (int)pthread_self();};
+ bool isRunning()const {return running;};
+ protected:
+ bool running;