aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-05-02 11:17:26 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-05-02 11:17:26 +0000
commit5fdb435d8cb25a0454c00b0429d87201065b89e5 (patch)
treeb474dfd36a00d37e16fe026dd12e865b3f90f045 /graphics/zathura
parent6932b6426b09cfb872349d25069246e8a2582954 (diff)
downloadports-5fdb435d8cb25a0454c00b0429d87201065b89e5.tar.gz
ports-5fdb435d8cb25a0454c00b0429d87201065b89e5.zip
Update to 0.3.3.
PR: 199592 Submitted by: me Approved by: quentin.stievenart at gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=385173
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile3
-rw-r--r--graphics/zathura/distinfo4
-rw-r--r--graphics/zathura/files/patch-Makefile11
-rw-r--r--graphics/zathura/files/patch-zathura_page-widget.c76
-rw-r--r--graphics/zathura/files/patch-zathura_shortcuts.c20
5 files changed, 3 insertions, 111 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index d2e8268a44f3..422cab6df98a 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.3.3
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/projects/zathura/download/
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index d54c0647eff0..83962a20cfc2 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-0.3.2.tar.gz) = fda6503dc5b21f7c667301798fbd2c978897e68b4555e8c731945cecd9d165e2
-SIZE (zathura-0.3.2.tar.gz) = 202943
+SHA256 (zathura-0.3.3.tar.gz) = 3347decfc8d4b918a6bca1d44657c3b97d4afcea3c8c1f162c57198b13e8dce7
+SIZE (zathura-0.3.3.tar.gz) = 203604
diff --git a/graphics/zathura/files/patch-Makefile b/graphics/zathura/files/patch-Makefile
deleted file mode 100644
index 6854c78fb623..000000000000
--- a/graphics/zathura/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2014-11-09 22:50:01 UTC
-+++ Makefile
-@@ -12,7 +12,7 @@ LIBS += $(SQLITE_LIB)
- SOURCE = $(OSOURCE)
- CPPFLAGS += -DWITH_SQLITE
- else
--SOURCE = $(filter-out database-sqlite.c,$(OSOURCE))
-+SOURCE = $(filter-out ${PROJECT}/database-sqlite.c,$(OSOURCE))
- endif
-
- ifneq ($(WITH_MAGIC),0)
diff --git a/graphics/zathura/files/patch-zathura_page-widget.c b/graphics/zathura/files/patch-zathura_page-widget.c
deleted file mode 100644
index 4b092ed1e3ab..000000000000
--- a/graphics/zathura/files/patch-zathura_page-widget.c
+++ /dev/null
@@ -1,76 +0,0 @@
-X-Git-Url: https://git.pwmt.org/?p=zathura.git;a=blobdiff_plain;f=zathura%2Fpage-widget.c;h=ad27c273f1ba04b66dd8a84337febec3729a68af;hp=309f63321cdbc27694fcba964faa3c4ecc48295f;hb=8d71a755d648c5856ef91d214bfdb46925f6c2f0;hpb=10f3da57c65a8ed7d4d3beff3e49da2bcddcf7a7
-
-diff --git zathura/page-widget.c zathura/page-widget.c.orig
-index 309f633..ad27c27 100644
---- zathura/page-widget.c
-+++ zathura/page-widget.c.orig
-@@ -28,8 +28,8 @@ typedef struct zathura_page_widget_private_s {
-
- struct {
- girara_list_t* list; /**< List of links on the page */
-- bool retrieved; /**< True if we already tried to retrieve the list of links */
-- bool draw; /**< True if links should be drawn */
-+ gboolean retrieved; /**< True if we already tried to retrieve the list of links */
-+ gboolean draw; /**< True if links should be drawn */
- unsigned int offset; /**< Offset to the links */
- unsigned int n; /**< Number */
- } links;
-@@ -37,12 +37,12 @@ typedef struct zathura_page_widget_private_s {
- struct {
- girara_list_t* list; /**< A list if there are search results that should be drawn */
- int current; /**< The index of the current search result */
-- bool draw; /**< Draw search results */
-+ gboolean draw; /**< Draw search results */
- } search;
-
- struct {
- girara_list_t* list; /**< List of images on the page */
-- bool retrieved; /**< True if we already tried to retrieve the list of images */
-+ gboolean retrieved; /**< True if we already tried to retrieve the list of images */
- zathura_image_t* current; /**< Image data of selected image */
- } images;
-
-@@ -52,7 +52,7 @@ typedef struct zathura_page_widget_private_s {
- int x; /**< X coordinate */
- int y; /**< Y coordinate */
- } selection_basepoint;
-- bool over_link;
-+ gboolean over_link;
- } mouse;
- } zathura_page_widget_private_t;
-
-@@ -313,13 +313,13 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
- case PROP_DRAW_LINKS:
- priv->links.draw = g_value_get_boolean(value);
- /* get links */
-- if (priv->links.draw == true && priv->links.retrieved == false) {
-+ if (priv->links.draw == TRUE && priv->links.retrieved == FALSE) {
- priv->links.list = zathura_page_links_get(priv->page, NULL);
-- priv->links.retrieved = true;
-+ priv->links.retrieved = TRUE;
- priv->links.n = (priv->links.list == NULL) ? 0 : girara_list_size(priv->links.list);
- }
-
-- if (priv->links.retrieved == true && priv->links.list != NULL) {
-+ if (priv->links.retrieved == TRUE && priv->links.list != NULL) {
- GIRARA_LIST_FOREACH(priv->links.list, zathura_link_t*, iter, link)
- if (link != NULL) {
- zathura_rectangle_t rectangle = recalc_rectangle(priv->page, zathura_link_get_position(link));
-@@ -338,7 +338,7 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
- }
- priv->search.list = g_value_get_pointer(value);
- if (priv->search.list != NULL && priv->search.draw) {
-- priv->links.draw = false;
-+ priv->links.draw = FALSE;
- redraw_all_rects(pageview, priv->search.list);
- }
- priv->search.current = -1;
-@@ -355,7 +355,7 @@ zathura_page_widget_set_property(GObject* object, guint prop_id, const GValue* v
- priv->search.current = girara_list_size(priv->search.list);
- } else {
- priv->search.current = val;
-- if (priv->search.draw == true && val >= 0 && val < (signed) girara_list_size(priv->search.list)) {
-+ if (priv->search.draw == TRUE && val >= 0 && val < (signed) girara_list_size(priv->search.list)) {
- zathura_rectangle_t* rect = girara_list_nth(priv->search.list, priv->search.current);
- zathura_rectangle_t rectangle = recalc_rectangle(priv->page, *rect);
- redraw_rect(pageview, &rectangle);
diff --git a/graphics/zathura/files/patch-zathura_shortcuts.c b/graphics/zathura/files/patch-zathura_shortcuts.c
deleted file mode 100644
index 067a64416fe2..000000000000
--- a/graphics/zathura/files/patch-zathura_shortcuts.c
+++ /dev/null
@@ -1,20 +0,0 @@
-X-Git-Url: https://git.pwmt.org/?p=zathura.git;a=blobdiff_plain;f=zathura%2Fshortcuts.c;h=93182c0835f3c41157637f7d2b78dbb7ff3b1328;hp=0e6ca6349a529a9faff75f2a445f7cf0b7a3c98c;hb=8d71a755d648c5856ef91d214bfdb46925f6c2f0;hpb=10f3da57c65a8ed7d4d3beff3e49da2bcddcf7a7
-
-diff --git zathura/shortcuts.c zathura/shortcuts.c.orig
-index 0e6ca63..93182c0 100644
---- zathura/shortcuts.c
-+++ zathura/shortcuts.c.orig
-@@ -861,9 +861,11 @@ sc_search(girara_session_t* session, girara_argument_t* argument,
- const unsigned int num_pages = zathura_document_get_number_of_pages(zathura->document);
- const unsigned int cur_page = zathura_document_get_current_page_number(zathura->document);
- GtkWidget *cur_page_widget = zathura_page_get_widget(zathura, zathura_document_get_page(zathura->document, cur_page));
-- bool nohlsearch, first_time_after_abort, draw;
-+ bool nohlsearch, first_time_after_abort;
-+ gboolean draw;
-
-- nohlsearch = first_time_after_abort = draw = false;
-+ nohlsearch = first_time_after_abort = false;
-+ draw = FALSE;
- girara_setting_get(session, "nohlsearch", &nohlsearch);
-
- if (nohlsearch == false) {