aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-10-10 07:03:18 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-10-10 07:03:18 +0000
commitc99095ca7c03481f806e66b536c2a00c94b165af (patch)
tree12ac14c323af45f784cab68e49ba6d4ec1e06188 /graphics/zathura
parent827a01cc4fe0ee383a09db6e6752171ecefe5ba6 (diff)
downloadports-c99095ca7c03481f806e66b536c2a00c94b165af.tar.gz
ports-c99095ca7c03481f806e66b536c2a00c94b165af.zip
graphics/zathura: Fix SQLITE option
There is no opt_MESON_ARGS_OFF helper and Zathura also does not have an enable-sqlite option. It has an 'sqlite' feature which can be turned on/off with the MESON_ENABLED helper. SQLite support has been auto-enabled for ~7 months by always having USES=sqlite in the port. Since the SQLITE option can now properly turn that support off, enable it by default to not cause too many surprises.
Notes
Notes: svn path=/head/; revision=514208
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index ddbaac081070..08f8f47393ce 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zathura
DISTVERSION= 0.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics print
MASTER_SITES= https://pwmt.org/projects/zathura/download/ \
http://www.madpilot.net/~mad/pwmt.org/
@@ -20,14 +20,15 @@ LIB_DEPENDS= libcairo.so:graphics/cairo \
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR}
-USES= compiler:c11 gettext-tools:build gnome meson ninja \
- pkgconfig python sqlite tar:xz
+USES= compiler:c11 gettext-tools:build gnome meson ninja pkgconfig \
+ python tar:xz
USE_GNOME= glib20 gtk30 gdkpixbuf2
INSTALLS_ICONS= yes
-OPTIONS_DEFINE= SQLITE
+OPTIONS_DEFINE= SQLITE
+OPTIONS_DEFAULT= SQLITE
-SQLITE_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
-SQLITE_MESON_ARGS_OFF= -Denable-sqlite=false
+SQLITE_USES= sqlite
+SQLITE_MESON_ENABLED= sqlite
.include <bsd.port.mk>