aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-12-31 14:07:26 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-12-31 14:07:26 +0000
commitf5f5bb93e7f3fa3c71e0f79b89da4eda504ae018 (patch)
tree8729ef04eabef9ea75080fd9493452067acf5b62 /graphics/zathura
parent984c68eb3e307ea38f844c869a24a62829a71a1e (diff)
downloadports-f5f5bb93e7f3fa3c71e0f79b89da4eda504ae018.tar.gz
ports-f5f5bb93e7f3fa3c71e0f79b89da4eda504ae018.zip
- Update to 0.3.4
- Now requires a C11 capable compiler - Use make option target helpers PR: 205550 Submitted by: me Approved by: quentin.stievenart at gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=404938
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile14
-rw-r--r--graphics/zathura/distinfo4
-rw-r--r--graphics/zathura/files/patch-zathura_main.c36
3 files changed, 44 insertions, 10 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 422cab6df98a..dd7d5e382f71 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.3.3
+PORTVERSION= 0.3.4
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/projects/zathura/download/
@@ -19,7 +19,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
USE_GNOME= glib20 gtk30
-USES= gmake pkgconfig
+USES= compiler:c11 gmake pkgconfig
MAKE_ENV= SFLAGS="${STRIP}" \
RSTTOMAN=${LOCALBASE}/bin/rst2man \
ZLIB_INC= \
@@ -33,8 +33,6 @@ SQLITE_MAKE_ENV= WITH_SQLITE=1
SQLITE_MAKE_ENV_OFF= WITH_SQLITE=0
NLS_USES= gettext
-.include <bsd.port.options.mk>
-
post-patch: .SILENT
${REINPLACE_CMD} -e 's|man[15]|man/&|g' \
-e 's|$${LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g'\
@@ -43,10 +41,6 @@ post-patch: .SILENT
${WRKSRC}/config.mk
${REINPLACE_CMD} -e '/^CC /d'\
${WRKSRC}/colors.mk
-.if ! ${PORT_OPTIONS:MNLS}
- ${REINPLACE_CMD} -e '/-C po/d'\
- ${WRKSRC}/Makefile
-.endif
${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
-e 's/-lc//' \
-e 's/DL_LIB /#&/' \
@@ -56,4 +50,8 @@ post-patch: .SILENT
${WRKSRC}/doc/man/zathurarc.5.rst
(cd ${WRKSRC}; ${RM} -f zathura.1 zathurarc.5)
+post-patch-NLS-off: .SILENT
+ ${REINPLACE_CMD} -e '/-C po/d'\
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 83962a20cfc2..02a1670a345d 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-0.3.3.tar.gz) = 3347decfc8d4b918a6bca1d44657c3b97d4afcea3c8c1f162c57198b13e8dce7
-SIZE (zathura-0.3.3.tar.gz) = 203604
+SHA256 (zathura-0.3.4.tar.gz) = 52c4a3efc5843ce7c720ea7357667699363c809fd34ada4cb350d0e1031d0234
+SIZE (zathura-0.3.4.tar.gz) = 167584
diff --git a/graphics/zathura/files/patch-zathura_main.c b/graphics/zathura/files/patch-zathura_main.c
new file mode 100644
index 000000000000..36378fabc64a
--- /dev/null
+++ b/graphics/zathura/files/patch-zathura_main.c
@@ -0,0 +1,36 @@
+--- zathura/main.c.orig 2015-12-21 10:19:18 UTC
++++ zathura/main.c
+@@ -85,10 +85,13 @@ run_synctex_forward(const char* synctex_
+ static zathura_t*
+ init_zathura(const char* config_dir, const char* data_dir,
+ const char* cache_dir, const char* plugin_path, char** argv,
++#ifdef WITH_SYNCTEX
++ char* synctex_editor,
++#endif
+ #ifdef GDK_WINDOWING_X11
+- char* synctex_editor, Window embed)
++ Window embed)
+ #else
+- char* synctex_editor)
++ )
+ #endif
+ {
+ /* create zathura session */
+@@ -249,11 +252,14 @@ main(int argc, char* argv[])
+ gtk_init(&argc, &argv);
+
+ /* Create zathura session */
+- zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir,
++ zathura_t* zathura = init_zathura(config_dir, data_dir, cache_dir, plugin_path, argv,
++#ifdef WITH_SYNCTEX
++ synctex_editor,
++#endif
+ #ifdef GDK_WINDOWING_X11
+- plugin_path, argv, synctex_editor, embed);
++ embed);
+ #else
+- plugin_path, argv, synctex_editor);
++ );
+ #endif
+ if (zathura == NULL) {
+ girara_error("Could not initialize zathura.");