aboutsummaryrefslogtreecommitdiff
path: root/graphics/zbar
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 20:09:42 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 20:09:42 +0000
commit9746d6524b4b8f6eec917896d1814e3f731dcc21 (patch)
treec75f110b500f3e806943eb33a78c2b5c25d7b18e /graphics/zbar
parentb559f5897ca3904e005ac65efdfc3ce548f46f88 (diff)
graphics category: Remove $PTHREAD_LIBS
graphics/zbar didn't pass check-plist (pre-existing), fixed. approved by: PTHREAD blanket
Notes
Notes: svn path=/head/; revision=382266
Diffstat (limited to 'graphics/zbar')
-rw-r--r--graphics/zbar/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
index a7b0f60a3dc1..5f4359ab8852 100644
--- a/graphics/zbar/Makefile
+++ b/graphics/zbar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zbar
PORTVERSION= 0.10
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= SF
@@ -17,6 +17,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USES= iconv libtool gmake pkgconfig
+INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --with-jpeg=yes
@@ -56,7 +57,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
@${REINPLACE_CMD} 's|^pkgconfigdir = .*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
.if empty(PORT_OPTIONS:MDOCS)
@@ -64,4 +64,8 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
+post-install:
+ # make check-plist happy
+ ${RMDIR} ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>