aboutsummaryrefslogtreecommitdiff
path: root/graphics/zint
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-03-26 07:21:07 +0000
committerWen Heping <wen@FreeBSD.org>2010-03-26 07:21:07 +0000
commit5f1a22c32d817de4ed09b9a70df175e25ca6a6fc (patch)
tree25d13806db65d8b05492c2624b4837b8ee96e5a0 /graphics/zint
parent0979688cc2d5c8cae4b82a6821a2d0ca6af0e57c (diff)
downloadports-5f1a22c32d817de4ed09b9a70df175e25ca6a6fc.tar.gz
ports-5f1a22c32d817de4ed09b9a70df175e25ca6a6fc.zip
A barcode encoding library supporting over 50 symbologies including Code 128,
Data Matrix, USPS OneCode, EAN-128, UPC/EAN, ITF, QR Code, Code 16k, PDF417, MicroPDF417, LOGMARS, Maxicode, GS1 DataBar, Aztec, Composite Symbols and more. WWW: http://www.zint.org.uk/ PR: ports/144958 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
Notes
Notes: svn path=/head/; revision=251524
Diffstat (limited to 'graphics/zint')
-rw-r--r--graphics/zint/Makefile27
-rw-r--r--graphics/zint/distinfo3
-rw-r--r--graphics/zint/files/patch-backend_CMakeLists.txt24
-rw-r--r--graphics/zint/files/patch-backend_code1.c13
-rw-r--r--graphics/zint/files/patch-backend_maxicode.c13
-rw-r--r--graphics/zint/pkg-descr5
-rw-r--r--graphics/zint/pkg-plist11
7 files changed, 96 insertions, 0 deletions
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
new file mode 100644
index 000000000000..6e5a19633c78
--- /dev/null
+++ b/graphics/zint/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: zint
+# Date created: 2010-03-13
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zint
+PORTVERSION= 2.3.1
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Zint Barcode Generator
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build designer
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/graphics/zint/distinfo b/graphics/zint/distinfo
new file mode 100644
index 000000000000..b51c6e68b3f0
--- /dev/null
+++ b/graphics/zint/distinfo
@@ -0,0 +1,3 @@
+MD5 (zint-2.3.1.src.tar.gz) = d8e12cc60505e3e89b99fc16ff6b38b8
+SHA256 (zint-2.3.1.src.tar.gz) = 2d997a9fb825370adedd2c0ad8491d79460635f707b9878d0e39f07b2a164388
+SIZE (zint-2.3.1.src.tar.gz) = 490520
diff --git a/graphics/zint/files/patch-backend_CMakeLists.txt b/graphics/zint/files/patch-backend_CMakeLists.txt
new file mode 100644
index 000000000000..e8d354cddcb8
--- /dev/null
+++ b/graphics/zint/files/patch-backend_CMakeLists.txt
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- backend/CMakeLists.txt.orig
++++ backend/CMakeLists.txt
+@@ -2,7 +2,8 @@
+
+ project(zint)
+
+-find_package(PNG)
++find_package(PNG REQUIRED)
++include_directories(${PNG_INCLUDE_DIR})
+
+ set(zint_COMMON_SRCS common.c library.c ps.c large.c reedsol.c gs1.c svg.c png.c)
+ set(zint_ONEDIM_SRCS code.c code128.c 2of5.c upcean.c telepen.c medical.c plessey.c rss.c)
+@@ -21,7 +22,7 @@
+ set_target_properties(zint PROPERTIES SOVERSION "${ZINT_VERSION_MAJOR}.${ZINT_VERSION_MINOR}"
+ VERSION ${ZINT_VERSION})
+
+-target_link_libraries(zint ${PNG_LIBRARIES} )
++target_link_libraries(zint ${PNG_LIBRARY} )
+
+ install(TARGETS zint ${INSTALL_TARGETS_DEFAULT_ARGS} )
+ install(FILES zint.h DESTINATION ${INCLUDE_INSTALL_DIR} COMPONENT Devel)
diff --git a/graphics/zint/files/patch-backend_code1.c b/graphics/zint/files/patch-backend_code1.c
new file mode 100644
index 000000000000..f6a225480d6d
--- /dev/null
+++ b/graphics/zint/files/patch-backend_code1.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- backend/code1.c.orig
++++ backend/code1.c
+@@ -28,7 +28,6 @@
+ #ifdef __APPLE__
+ #include <sys/malloc.h>
+ #else
+-#include <malloc.h>
+ #endif
+
+ void horiz(struct zint_symbol *symbol, int row_no, int full)
diff --git a/graphics/zint/files/patch-backend_maxicode.c b/graphics/zint/files/patch-backend_maxicode.c
new file mode 100644
index 000000000000..f6b242d32e50
--- /dev/null
+++ b/graphics/zint/files/patch-backend_maxicode.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- backend/maxicode.c.orig
++++ backend/maxicode.c
+@@ -29,7 +29,6 @@
+ #ifdef __APPLE__
+ #include <sys/malloc.h>
+ #else
+-#include <malloc.h>
+ #endif
+
+ int maxi_codeword[144];
diff --git a/graphics/zint/pkg-descr b/graphics/zint/pkg-descr
new file mode 100644
index 000000000000..f35d8ac1e170
--- /dev/null
+++ b/graphics/zint/pkg-descr
@@ -0,0 +1,5 @@
+A barcode encoding library supporting over 50 symbologies including Code 128,
+Data Matrix, USPS OneCode, EAN-128, UPC/EAN, ITF, QR Code, Code 16k, PDF417,
+MicroPDF417, LOGMARS, Maxicode, GS1 DataBar, Aztec, Composite Symbols and more.
+
+WWW: http://www.zint.org.uk/
diff --git a/graphics/zint/pkg-plist b/graphics/zint/pkg-plist
new file mode 100644
index 000000000000..baff23a4888d
--- /dev/null
+++ b/graphics/zint/pkg-plist
@@ -0,0 +1,11 @@
+bin/zint
+bin/zint-qt
+include/qzint.h
+include/zint.h
+lib/libQZint.so
+lib/libQZint.so.2.3
+lib/libQZint.so.2.3.1
+lib/libzint.so
+lib/libzint.so.2.3
+lib/libzint.so.2.3.1
+share/cmake/Modules/FindZint.cmake