aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-02 09:48:23 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-02 09:48:23 +0000
commit1ba909d4de0560efa4a09031cafd930e6ffa140a (patch)
tree110009f6d6ca65d2ba38847f70ab8de650b0c9a5 /graphics/zphoto
parenta49d5fc71c141d3a8ff83310c7834676607913ce (diff)
downloadports-1ba909d4de0560efa4a09031cafd930e6ffa140a.tar.gz
ports-1ba909d4de0560efa4a09031cafd930e6ffa140a.zip
Upgrade to 0.7.
PR: ports/63627 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=102712
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile11
-rw-r--r--graphics/zphoto/distinfo3
-rw-r--r--graphics/zphoto/files/patch-configure11
3 files changed, 20 insertions, 5 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index f446a00d6759..dc2d1ed01233 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.6
-PORTREVISION= 1
+PORTVERSION= 0.7
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,11 +20,15 @@ LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
aviplay.0:${PORTSDIR}/multimedia/avifile
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming \
+ CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
-USE_GMAKE= yes
+USE_GMAKE= yes
USE_XLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index 150c47ec9723..cfead5665647 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1 +1,2 @@
-MD5 (zphoto-0.6.tar.gz) = a3246c0ed9c072fe39f926d08dae45f5
+MD5 (zphoto-0.7.tar.gz) = e158889b25fbfa985e431897f6309e96
+SIZE (zphoto-0.7.tar.gz) = 143468
diff --git a/graphics/zphoto/files/patch-configure b/graphics/zphoto/files/patch-configure
new file mode 100644
index 000000000000..77d98e263a07
--- /dev/null
+++ b/graphics/zphoto/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Feb 26 19:09:36 2004
++++ configure Tue Mar 2 10:21:20 2004
+@@ -3725,7 +3725,7 @@
+ SWFMovie_save(movie, "foo"); /* 0.2a API */
+ }
+ EOF
+-if $CC -c tmp.c > /dev/null 2>&1; then
++if $CC -c $CFLAGS $CPPFLAGS tmp.c > /dev/null 2>&1; then
+
+ cat >>confdefs.h <<_ACEOF
+ #define MING_0_2a 1