aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:12:16 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-04-29 13:29:50 +0000
commit0bcd20b238ac35ec0db95a496b8c9ce7b6015b4e (patch)
tree7d5a80fdf8bdf540cf10cf63ca573627941787ab /graphics
parent58aaf801faec7fd27602ede48e8a6d46273d08de (diff)
downloadports-0bcd20b238ac35ec0db95a496b8c9ce7b6015b4e.tar.gz
ports-0bcd20b238ac35ec0db95a496b8c9ce7b6015b4e.zip
graphics/glfw: fix build with EXAMPLES enabled and PREEDIT disabled
Both options are non-default. MFH: 2024Q2
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glfw/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 8b33dd90eda3..3b2e330c99ac 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -65,6 +65,7 @@ X11_CMAKE_BOOL= GLFW_BUILD_X11
.if ${PORT_OPTIONS:MEXAMPLES} && ${PORT_OPTIONS:MPREEDIT}
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
+TESTS_FILES= input_text
.endif
do-install-DOCS-on:
@@ -83,8 +84,9 @@ do-install-EXAMPLES-on:
${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/tests && ${INSTALL_PROGRAM} \
allocator clipboard cursor empty events gamma glfwinfo icon \
- iconify input_text inputlag joysticks monitors msaa reopen \
+ iconify inputlag joysticks monitors msaa reopen \
tearing threads timeout title triangle-vulkan window \
+ ${TESTS_FILES} \
${STAGEDIR}${EXAMPLESDIR}/tests
.include <bsd.port.mk>