aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:38:15 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-17 07:38:15 +0000
commit15c4a5ecf338d0133b87647ab773c6df26f3ea15 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /graphics
parenta9836219c62bdf7cdcfc3af658d25ae25aeaeb11 (diff)
downloadports-15c4a5ecf338d0133b87647ab773c6df26f3ea15.tar.gz
ports-15c4a5ecf338d0133b87647ab773c6df26f3ea15.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile3
-rw-r--r--graphics/bugle/Makefile3
-rw-r--r--graphics/gnash/Makefile2
-rw-r--r--graphics/graphviz/Makefile4
-rw-r--r--graphics/libgphoto2/Makefile3
5 files changed, 9 insertions, 6 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 45974f0ea146..bc80a289c73b 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -34,10 +34,11 @@ COMMENT= Image processing tools
#LICENSE= APACHE20
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
# This port uses .la files, keep libtool:keepla! (magick/module.c)
USES= gmake libtool:keepla pathfix perl5 pkgconfig shebangfix tar:xz
SHEBANG_FILES= www/source/examples.pl
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKE=${MAKE_CMD}
CONFIGURE_ARGS= --without-dps \
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 6846ef6c1f62..fa9ec2e54445 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -12,10 +12,11 @@ COMMENT= Debugging library for OpenGL
LICENSE= GPLv2
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= libtool pathfix perl5
USE_GL= gl
USE_GCC= yes
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ltdl-install=no
INSTALL_TARGET= install-strip
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index a53a42bccd74..f0d892466fa0 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNU Flash movie player
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libltdl.so:${PORTSDIR}/devel/libltdl \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libcurl.so:${PORTSDIR}/ftp/curl \
libgif.so:${PORTSDIR}/graphics/giflib \
@@ -20,7 +21,6 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
CONFLICTS= gnash-devel-[0-9]*
USES= tar:bzip2 pkgconfig gmake libtool
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
WANT_SDL= yes
USE_GCC= any
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index fbcdb15248de..a790cbad42b6 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -10,7 +10,8 @@ MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Graph Visualization Software from AT&T and Bell Labs
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
@@ -18,7 +19,6 @@ LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libgd.so:${PORTSDIR}/${GD_PORT}
USES= gmake bison libtool:oldver pkgconfig pathfix shebangfix
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 7d59b947820b..faf0814581cf 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -11,9 +11,10 @@ COMMENT= Universal digital camera control library
LICENSE= LGPL21
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= gmake iconv libtool pkgconfig tar:bzip2
USE_CSTD= gnu89
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ENV= LTDLINCL="-I${LOCALBASE}/include" \
LIBLTDL="-L${LOCALBASE}/lib -lltdl" \