aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:23:35 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:19:52 +0000
commit1930871df37d21d1c4773227c1b237b5682c1233 (patch)
tree29395dd6bfce1d484b5ea1aaabc7423a808bbdc4 /graphics
parent7789f5d26494c4d5288953042c1ebd98f422127c (diff)
downloadports-1930871df37d21d1c4773227c1b237b5682c1233.tar.gz
ports-1930871df37d21d1c4773227c1b237b5682c1233.zip
graphics/glad: Add explicit Python build dependency (D29353)
This unbreaks the build when using devel/samurai. It previously got it through ninja which has a run dependency on Python. [ 0% 1/3] cd /wrkdirs/usr/ports/graphics/glad/work/glad-0.1.34 && _Python_EXECUTABLE-NOTFOUND -m glad --profile=compatibility --out-path=/wrkdirs/usr/ports/graphics/glad/work/.build --api= --generator=c --extensions= --spec=gl --reproducible samu: job failed: cd /wrkdirs/usr/ports/graphics/glad/work/glad-0.1.34 && _Python_EXECUTABLE-NOTFOUND -m glad --profile=compatibility --out-path=/wrkdirs/usr/ports/graphics/glad/work/.build --api= --generator=c --extensions= --spec=gl --reproducible /bin/sh: _Python_EXECUTABLE-NOTFOUND: not found samu: subcommand failed http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/glad-0.1.34.log PR: 254678
Diffstat (limited to 'graphics')
-rw-r--r--graphics/glad/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/glad/Makefile b/graphics/glad/Makefile
index 2b73927116a6..de11935a0b12 100644
--- a/graphics/glad/Makefile
+++ b/graphics/glad/Makefile
@@ -10,7 +10,7 @@ COMMENT= Multi-Language Vulkan/GL/GLES/EGL/GLX/WGL loader-generator
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake
+USES= cmake python:build
USE_GITHUB= yes
GH_ACCOUNT= Dav1dde
USE_LDCONFIG= yes