aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-05-10 14:15:43 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-05-10 14:15:43 +0000
commit2c26e29083c3d93111c45383f0baa0018b955630 (patch)
tree2a7ae73e008bb8edbbe755ea61923ed96d0543e7 /graphics
parent05655c34fc858223a797371b5b738acf14576d17 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gx/Makefile15
-rw-r--r--graphics/gx/files/patch-Makefile.am15
-rw-r--r--graphics/gx/files/patch-Makefile.in14
-rw-r--r--graphics/gx/files/patch-gx.desktop11
-rw-r--r--graphics/gx/pkg-descr6
-rw-r--r--graphics/gx/pkg-plist5
6 files changed, 54 insertions, 12 deletions
diff --git a/graphics/gx/Makefile b/graphics/gx/Makefile
index eb7ee378a80d..de0886283f6a 100644
--- a/graphics/gx/Makefile
+++ b/graphics/gx/Makefile
@@ -3,19 +3,24 @@
PORTNAME= gx
PORTVERSION= 0.4.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
-MASTER_SITES= http://perticone.homelinux.net/sergio/c++/gx/src/
+MASTER_SITES= http://BSDforge.com/projects/source/graphics/gx/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Lightweight image viewer
-BROKEN= No public distfiles
+LICENSE= BSD2CLAUSE
LIB_DEPENDS= libgnomevfsmm-2.6.so:${PORTSDIR}/devel/gnome-vfsmm
-USES= gettext pkgconfig
+USES= desktop-file-utils gettext pkgconfig
USE_GNOME= gconfmm26 gtkmm24
GNU_CONFIGURE= yes
+PLIST_FILES= bin/gx \
+ share/applications/gx.desktop \
+ share/pixmaps/gx.png \
+ share/pixmaps/gx_logo.png \
+
.include <bsd.port.mk>
diff --git a/graphics/gx/files/patch-Makefile.am b/graphics/gx/files/patch-Makefile.am
new file mode 100644
index 000000000000..d07de5fb2c58
--- /dev/null
+++ b/graphics/gx/files/patch-Makefile.am
@@ -0,0 +1,15 @@
+--- Makefile.am.orig 2007-06-05 23:08:39 UTC
++++ Makefile.am
+@@ -3,10 +3,10 @@ SUBDIRS = src
+ icondir = $(datadir)/pixmaps
+ icon_DATA = icons/gx_logo.png icons/gx.png
+
+-desktopdir = $(datadir)/app-install/desktop
++desktopdir = $(datadir)/applications
+ desktop_DATA = gx.desktop
+
+-desk_icondir = $(datadir)/app-install/icons
++desk_icondir = $(datadir)/pixmaps
+ desk_icon_DATA = icons/gx.png
+
+ EXTRA_DIST = AUTHORS \
diff --git a/graphics/gx/files/patch-Makefile.in b/graphics/gx/files/patch-Makefile.in
new file mode 100644
index 000000000000..2b69f5bc6c7a
--- /dev/null
+++ b/graphics/gx/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2007-06-07 14:21:06 UTC
++++ Makefile.in
+@@ -176,9 +176,9 @@ target_alias = @target_alias@
+ SUBDIRS = src
+ icondir = $(datadir)/pixmaps
+ icon_DATA = icons/gx_logo.png icons/gx.png
+-desktopdir = $(datadir)/app-install/desktop
++desktopdir = $(datadir)/applications
+ desktop_DATA = gx.desktop
+-desk_icondir = $(datadir)/app-install/icons
++desk_icondir = $(datadir)/pixmaps
+ desk_icon_DATA = icons/gx.png
+ EXTRA_DIST = AUTHORS \
+ ChangeLog \
diff --git a/graphics/gx/files/patch-gx.desktop b/graphics/gx/files/patch-gx.desktop
new file mode 100644
index 000000000000..ad7b92ad955a
--- /dev/null
+++ b/graphics/gx/files/patch-gx.desktop
@@ -0,0 +1,11 @@
+--- gx.desktop.orig 2007-06-07 16:00:13 UTC
++++ gx.desktop
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+ Name=gx
+-GenericName=Image Viewer
++GenericName=GX Image Viewer
+ Comment=The lightweight image viewer
+ TryExec=gx
+ Exec=gx %U
diff --git a/graphics/gx/pkg-descr b/graphics/gx/pkg-descr
index 42e16f22e918..f63089174fa5 100644
--- a/graphics/gx/pkg-descr
+++ b/graphics/gx/pkg-descr
@@ -1,2 +1,4 @@
-gx is a small image viewer for Unix written in C++ (using gtkmm). It
-can rotate, rescale, and zoom in/out an image.
+gx is a small image viewer for UNIX like systems. It's written
+in C++ (using gtkmm). It can rotate, rescale, and zoom images.
+
+WWW: http://BSDforge.com/projects/graphics/gx/
diff --git a/graphics/gx/pkg-plist b/graphics/gx/pkg-plist
deleted file mode 100644
index f2d24da8737b..000000000000
--- a/graphics/gx/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/gx
-share/app-install/icons/gx.png
-share/app-install/desktop/gx.desktop
-share/pixmaps/gx.png
-share/pixmaps/gx_logo.png