aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-08 15:54:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-04-08 15:57:05 +0000
commit2f263c94fda22791a1bfa3ac9c291f76fc13df13 (patch)
treec8c217004f46d000a96e0f4a705baf36a378950a /graphics
parentc618b1501762ea9cd7ef0a3ae44cec7970dfbd5c (diff)
downloadports-2f263c94fda22791a1bfa3ac9c291f76fc13df13.tar.gz
ports-2f263c94fda22791a1bfa3ac9c291f76fc13df13.zip
graphics/cimg: upgrade to v.2.9.7.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile4
-rw-r--r--graphics/cimg/distinfo6
-rw-r--r--graphics/cimg/files/patch-examples__Makefile22
3 files changed, 16 insertions, 16 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index ea96dcf7922a..1934340d4a4e 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,8 +2,7 @@
PORTNAME= cimg
DISTVERSIONPREFIX= v.
-DISTVERSION= 2.9.6
-PORTREVISION= 1
+DISTVERSION= 2.9.7
PORTEPOCH= 3
CATEGORIES= graphics devel
@@ -51,6 +50,7 @@ LIB_DEPENDS+= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libHalf.so:graphics/ilmbase \
+ libheif.so:graphics/libheif \
libIlmImf.so:graphics/openexr \
libgimp-2.0.so:graphics/gimp-app \
libfftw3.so:math/fftw3 \
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index a0daf87760f4..ed8fa8e71e2c 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612961523
-SHA256 (dtschump-CImg-v.2.9.6_GH0.tar.gz) = b060fb0eadc3b34b7b1985c076ef88d9cd1057505fd43360ae1f555661a19106
-SIZE (dtschump-CImg-v.2.9.6_GH0.tar.gz) = 11225938
+TIMESTAMP = 1617894438
+SHA256 (dtschump-CImg-v.2.9.7_GH0.tar.gz) = 0e1cce730abf8ab5b6ac23628115ec1980109481bead977ef74f58231797b53c
+SIZE (dtschump-CImg-v.2.9.7_GH0.tar.gz) = 11267353
diff --git a/graphics/cimg/files/patch-examples__Makefile b/graphics/cimg/files/patch-examples__Makefile
index 0a406c49bbf4..91b8048819cb 100644
--- a/graphics/cimg/files/patch-examples__Makefile
+++ b/graphics/cimg/files/patch-examples__Makefile
@@ -1,4 +1,4 @@
---- examples/Makefile.orig 2020-11-23 20:31:46 UTC
+--- examples/Makefile.orig 2021-04-02 13:11:36 UTC
+++ examples/Makefile
@@ -89,7 +89,7 @@ VERSION2 = $(shell grep 'cimg_version\ ' ../CImg.h | t
VERSION3 = $(shell grep 'cimg_version\ ' ../CImg.h | tail -c2 | head -c1)
@@ -34,8 +34,8 @@
# Flags to enable OpenCV support.
OPENCV_DEFINE = -Dcimg_use_opencv
--OPENCV_INCDIR = $(shell pkg-config opencv --cflags || echo -I/usr/include/opencv) -I/usr/include/opencv
-+OPENCV_INCDIR = $(shell pkg-config opencv4 --cflags || echo -I/usr/include/opencv) -I/usr/include/opencv
+-OPENCV_INCDIR = $(shell pkg-config opencv --cflags || echo -I/usr/include/opencv) -I/usr/include/opencv -I/usr/include/opencv4
++OPENCV_INCDIR = $(shell pkg-config opencv4 --cflags || echo -I/usr/include/opencv) -I/usr/include/opencv -I/usr/include/opencv4
OPENCV_CFLAGS = $(OPENCV_DEFINE) $(OPENCV_INCDIR)
-OPENCV_LIBS = $(shell pkg-config opencv --libs || echo -lopencv_core -lopencv_highgui)
+OPENCV_LIBS = $(shell pkg-config opencv4 --libs || echo -lopencv_core -lopencv_highgui)
@@ -49,9 +49,9 @@
-TIFF_LIBS = -ltiff
+TIFF_LIBS = -ltiff -ltiffxx
- # Flags to enable native support for MINC2 image files, using the MINC2 library.
- # ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
-@@ -236,16 +236,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
+ # Flags to enable native support for loading HEIF image files, using the libheif library.
+ # ( https://github.com/strukturag/libheif )
+@@ -243,16 +243,16 @@ MINC2_LIBS = -lminc_io -lvolume_io2 -lminc2 -lnetcdf -
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
OPENEXR_DEFINE = -Dcimg_use_openexr
@@ -73,7 +73,7 @@
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
# ( http://www.zlib.net/ )
-@@ -281,15 +281,15 @@ endif
+@@ -288,15 +288,15 @@ endif
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -93,15 +93,15 @@
BOARD_CFLAGS = $(BOARD_DEFINE) $(BOARD_INCDIR)
BOARD_LIBS = -lboard
-@@ -368,6 +368,7 @@ $(X11_LIBS) \
- $(TIFF_LIBS) \
+@@ -368,6 +368,7 @@ $(TIFF_LIBS) \
+ $(HEIF_LIBS) \
$(LAPACK_LIBS) \
$(XSHM_LIBS)" \
+$(PTHREAD_LIBS)" \
all $(EXTRA_FILES)
# Linux/BSD/Mac OSX targets, with X11 display.
-@@ -460,8 +461,11 @@ $(ZLIB_CFLAGS) \
+@@ -461,8 +462,11 @@ $(ZLIB_CFLAGS) \
$(CURL_CFLAGS) \
$(OPENCV_CFLAGS) \
$(MAGICK_CFLAGS) \
@@ -113,7 +113,7 @@
$(X11_LIBS) \
$(XSHM_LIBS) \
$(XRANDR_LIBS) \
-@@ -473,6 +477,8 @@ $(ZLIB_LIBS) \
+@@ -475,6 +479,8 @@ $(ZLIB_LIBS) \
$(CURL_LIBS) \
$(OPENCV_LIBS) \
$(MAGICK_LIBS) \