aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-07 11:02:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-07 11:02:18 +0000
commit31d3413e6766d90344245e107b57f81358639c39 (patch)
tree1f1cbda0a8556fd345d0e077c4860963e26dd4bf /graphics
parentf6f0b1b78a101726992ae089bab0658de020f080 (diff)
downloadports-31d3413e6766d90344245e107b57f81358639c39.tar.gz
ports-31d3413e6766d90344245e107b57f81358639c39.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/silgraphite/Makefile37
-rw-r--r--graphics/silgraphite/distinfo3
-rw-r--r--graphics/silgraphite/files/patch-engine_Makefile.in11
-rw-r--r--graphics/silgraphite/pkg-descr10
-rw-r--r--graphics/silgraphite/pkg-plist35
6 files changed, 97 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 3a3b756fda48..eecba5f30383 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -755,6 +755,7 @@
SUBDIR += shim
SUBDIR += show
SUBDIR += showimg
+ SUBDIR += silgraphite
SUBDIR += simage
SUBDIR += skanlite
SUBDIR += skencil
diff --git a/graphics/silgraphite/Makefile b/graphics/silgraphite/Makefile
new file mode 100644
index 000000000000..1203f212143f
--- /dev/null
+++ b/graphics/silgraphite/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: silgraphite
+# Date created: 30 November 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silgraphite
+PORTVERSION= 2.3
+CATEGORIES= graphics devel
+MASTER_SITES= SF
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Font engine for complex non-Roman writing systems
+
+OPTIONS= FREETYPE "Build with Freetype support" on
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-xft --without-pangographite
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+USE_ICONV= yes
+CONFIGURE_ARGS+= --with-freetype
+PLIST_SUB+= WITH_FREETYPE=""
+.else
+CONFIGURE_ARGS+= --without-freetype
+PLIST_SUB+= WITH_FREETYPE="@comment "
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/silgraphite/distinfo b/graphics/silgraphite/distinfo
new file mode 100644
index 000000000000..c32d951e4dba
--- /dev/null
+++ b/graphics/silgraphite/distinfo
@@ -0,0 +1,3 @@
+MD5 (silgraphite-2.3.tar.gz) = 76a6daa2ec802bdd5e5f9a233b4e2ff8
+SHA256 (silgraphite-2.3.tar.gz) = 574dbccd0480e7c571612251afafd8de2019997ee1450ee3e68039f64797f1ec
+SIZE (silgraphite-2.3.tar.gz) = 3394463
diff --git a/graphics/silgraphite/files/patch-engine_Makefile.in b/graphics/silgraphite/files/patch-engine_Makefile.in
new file mode 100644
index 000000000000..37f59e66b7cb
--- /dev/null
+++ b/graphics/silgraphite/files/patch-engine_Makefile.in
@@ -0,0 +1,11 @@
+--- engine/Makefile.in.orig 2008-11-30 19:57:26.000000000 +0100
++++ engine/Makefile.in 2008-11-30 19:58:25.000000000 +0100
+@@ -196,7 +196,7 @@
+ build.bat build_d.bat makefile.vc \
+ README
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = ${PREFIX}/libdata/pkgconfig
+ pkgconfig_DATA = silgraphite.pc
+
+ # VC_VERSION is the last released version of the software
diff --git a/graphics/silgraphite/pkg-descr b/graphics/silgraphite/pkg-descr
new file mode 100644
index 000000000000..85d79c5ee6ae
--- /dev/null
+++ b/graphics/silgraphite/pkg-descr
@@ -0,0 +1,10 @@
+Graphite is a project under development within SIL'ss Non-Roman Script
+Initiative and Language Software Development groups to provide
+rendering capabilities for complex non-Roman writing systems. The
+original goal was a system for the Windows platform; the system has
+also been ported to Linux. Graphite can be used to create "smart
+fonts" capable of displaying writing systems with various complex
+behaviors. With respect to the Text Encoding Model, Graphite handles
+the "Rendering" aspect of writing system implementation.
+
+WWW: http://silgraphite.sourceforge.net/
diff --git a/graphics/silgraphite/pkg-plist b/graphics/silgraphite/pkg-plist
new file mode 100644
index 000000000000..c605c176549d
--- /dev/null
+++ b/graphics/silgraphite/pkg-plist
@@ -0,0 +1,35 @@
+%%WITH_FREETYPE%%include/graphite/FreetypeFont.h
+%%WITH_FREETYPE%%lib/libgraphite-ft.a
+%%WITH_FREETYPE%%lib/libgraphite-ft.la
+%%WITH_FREETYPE%%lib/libgraphite-ft.so
+%%WITH_FREETYPE%%lib/libgraphite-ft.so.0
+include/graphite/FileFont.h
+include/graphite/Font.h
+include/graphite/GrAppData.h
+include/graphite/GrClient.h
+include/graphite/GrCommon.h
+include/graphite/GrConstants.h
+include/graphite/GrData.h
+include/graphite/GrDebug.h
+include/graphite/GrExt.h
+include/graphite/GrFeature.h
+include/graphite/GrMstypes.h
+include/graphite/GrPlatform.h
+include/graphite/GrResult.h
+include/graphite/GrStructs.h
+include/graphite/GrWrappers.h
+include/graphite/GraphiteProcess.h
+include/graphite/IGrEngine.h
+include/graphite/IGrJustifier.h
+include/graphite/IGraphiteProcess.h
+include/graphite/ITextSource.h
+include/graphite/MemoryUsage.h
+include/graphite/Segment.h
+include/graphite/SegmentAux.h
+include/graphite/SegmentPainter.h
+lib/libgraphite.a
+lib/libgraphite.la
+lib/libgraphite.so
+lib/libgraphite.so.3
+libdata/pkgconfig/silgraphite.pc
+@dirrm include/graphite