aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-01-11 19:09:58 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-01-11 19:09:58 +0000
commit339f59d1cf856d76bbd505ad72ce7373c1f42040 (patch)
treea67ebbb3e7a59cceb78b015bf01cc6ca1b1ddcad /graphics
parenta589d8a4e79864a2ecb40b31a7e4562cf340cd96 (diff)
downloadports-339f59d1cf856d76bbd505ad72ce7373c1f42040.tar.gz
ports-339f59d1cf856d76bbd505ad72ce7373c1f42040.zip
Minor build fixes, includes WITH_DEBUG builds
- under WITH_DEBUG=yes builds, avoid renaming the libraries with _d suffix. (else it breaks packaging, and we don't want separate lib names) [1] - while here, avoid creating symlinks from cmake, this causes staging violations due to cmake bug #17340, (poudriere testport) see https://gitlab.kitware.com/cmake/cmake/issues/17340 - while here, fix "make test" target - it is a left over from 2.3's gmake build. Use ctest instead. No PORTREVISION bump necessary because each and every fixed bug would cause a broken build and no install. PR: 243274 [1] Reported by: Marcin Cieślak [1]
Notes
Notes: svn path=/head/; revision=522706
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ilmbase/Makefile7
-rw-r--r--graphics/ilmbase/files/patch-config_CMakeLists.txt (renamed from graphics/ilmbase/files/patch-CMakeLists.txt)0
-rw-r--r--graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake13
-rw-r--r--graphics/ilmbase/files/patch-config_LibraryDefine.cmake11
4 files changed, 25 insertions, 6 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 8350d8738ce1..183b06fa7207 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -22,11 +22,6 @@ USE_GITHUB= yes
GH_TUPLE= AcademySoftwareFoundation:openexr:v2.4.0
WRKSRC_SUBDIR= IlmBase
-# libtool links C++ libraries with -nostdlib, which prevents -pthread from
-# having an effect (at least with clang). Make sure we also pass -lpthread so
-# we do link against libthr.so.
-TEST_TARGET= check
-
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS LARGE_STACK
LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
@@ -46,7 +41,7 @@ PLIST_SUB+= VER=${VER}
HALF_BIN= eLut toFloat
-regression-test regression check::
+test regression-test regression check::
cd ${BUILD_WRKSRC} && ctest
post-install:
diff --git a/graphics/ilmbase/files/patch-CMakeLists.txt b/graphics/ilmbase/files/patch-config_CMakeLists.txt
index 89525edad2d8..89525edad2d8 100644
--- a/graphics/ilmbase/files/patch-CMakeLists.txt
+++ b/graphics/ilmbase/files/patch-config_CMakeLists.txt
diff --git a/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake b/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake
new file mode 100644
index 000000000000..1ec7bf625aee
--- /dev/null
+++ b/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake
@@ -0,0 +1,13 @@
+--- config/IlmBaseSetup.cmake.orig 2019-09-18 01:02:06 UTC
++++ config/IlmBaseSetup.cmake
+@@ -48,10 +48,6 @@ set(ILMBASE_OUTPUT_SUBDIR OpenEXR CACHE STRING "Destin
+ # but is pretty harmless to set globally
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+-# Suffix for debug configuration libraries
+-# (if you should choose to install those)
+-set(CMAKE_DEBUG_POSTFIX "_d" CACHE STRING "Suffix for debug builds")
+-
+ # Usual cmake option to build shared libraries or not
+ option(BUILD_SHARED_LIBS "Build shared library" ON)
+ # This allows a "double library" setup, where we compile both
diff --git a/graphics/ilmbase/files/patch-config_LibraryDefine.cmake b/graphics/ilmbase/files/patch-config_LibraryDefine.cmake
new file mode 100644
index 000000000000..673944251930
--- /dev/null
+++ b/graphics/ilmbase/files/patch-config_LibraryDefine.cmake
@@ -0,0 +1,11 @@
+--- config/LibraryDefine.cmake.orig 2019-09-18 01:02:06 UTC
++++ config/LibraryDefine.cmake
+@@ -100,8 +100,6 @@ function(ILMBASE_DEFINE_LIBRARY libname)
+ if(BUILD_SHARED_LIBS AND (NOT "${ILMBASE_LIB_SUFFIX}" STREQUAL ""))
+ set(verlibname ${CMAKE_SHARED_LIBRARY_PREFIX}${libname}${ILMBASE_LIB_SUFFIX}${CMAKE_SHARED_LIBRARY_SUFFIX})
+ set(baselibname ${CMAKE_SHARED_LIBRARY_PREFIX}${libname}${CMAKE_SHARED_LIBRARY_SUFFIX})
+- install(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E chdir ${CMAKE_INSTALL_FULL_LIBDIR} ${CMAKE_COMMAND} -E create_symlink ${verlibname} ${baselibname})")
+- install(CODE "message(\"-- Creating symlink in ${CMAKE_INSTALL_FULL_LIBDIR} ${baselibname} -> ${verlibname}\")")
+ set(verlibname)
+ set(baselibname)
+ endif()