aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-06-27 12:32:16 +0000
committerWen Heping <wen@FreeBSD.org>2018-06-27 12:32:16 +0000
commit3d35c22866d4b2e8e3c126caf86826f961a86b0e (patch)
tree7fca5a83e75a3e5f766139f29bfcd5cd063f34e3 /graphics
parent4b80eb005c175c5e6cd7a509965f392a8feb484f (diff)
downloadports-3d35c22866d4b2e8e3c126caf86826f961a86b0e.tar.gz
ports-3d35c22866d4b2e8e3c126caf86826f961a86b0e.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-fiona/Makefile26
-rw-r--r--graphics/py-fiona/distinfo3
-rw-r--r--graphics/py-fiona/pkg-descr9
4 files changed, 39 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 1ba03ba5078f..7df2031e6010 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -892,6 +892,7 @@
SUBDIR += py-exif
SUBDIR += py-exifread
SUBDIR += py-exiv2
+ SUBDIR += py-fiona
SUBDIR += py-freeimagepy
SUBDIR += py-gd
SUBDIR += py-gdal
diff --git a/graphics/py-fiona/Makefile b/graphics/py-fiona/Makefile
new file mode 100644
index 000000000000..73de70a64706
--- /dev/null
+++ b/graphics/py-fiona/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= Fiona
+DISTVERSION= 1.7.12
+#DISTVERSIONSUFFIX= .post2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= OGR's neat and nimble API for Python programmers
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cligj>=0.4:devel/py-cligj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-plugins>0:devel/py-click-plugins@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.7:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}munch>0:devel/py-munch@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${FLAVOR} \
+ ${PY_ENUM34}
+LIB_DEPENDS+= libgdal.so:graphics/gdal
+
+USES= python
+USE_PYTHON= autoplist distutils cython
+
+.include <bsd.port.mk>
diff --git a/graphics/py-fiona/distinfo b/graphics/py-fiona/distinfo
new file mode 100644
index 000000000000..9854714e2081
--- /dev/null
+++ b/graphics/py-fiona/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530101810
+SHA256 (Fiona-1.7.12.tar.gz) = 8b54eb8422d7c502bb7776b184018186bede1a489cf438a7a47f992ade6a0e51
+SIZE (Fiona-1.7.12.tar.gz) = 727409
diff --git a/graphics/py-fiona/pkg-descr b/graphics/py-fiona/pkg-descr
new file mode 100644
index 000000000000..13f4d36b2c66
--- /dev/null
+++ b/graphics/py-fiona/pkg-descr
@@ -0,0 +1,9 @@
+Fiona is designed to be simple and dependable. It focuses on reading and
+writing data in standard Python IO style and relies upon familiar Python
+types and protocols such as files, dictionaries, mappings, and iterators
+instead of classes specific to OGR. Fiona can read and write real-world
+data using multi-layered GIS formats and zipped virtual file systems and
+integrates readily with other Python GIS packages such as pyproj, Rtree,
+and Shapely. Fiona is supported only on CPython versions 2.7 and 3.4+.
+
+WWW: https://pypi.python.org/pypi/fiona