aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-06-27 00:52:16 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-06-27 00:52:16 +0000
commit4136c68147b4208bc96c31ccfd5dc79626bd2357 (patch)
tree21c925c92004a8fb364f72321cb37b173ee693e1 /graphics
parentc4b593f737ff39ab9dc45a9f882ae5a0d768214b (diff)
downloadports-4136c68147b4208bc96c31ccfd5dc79626bd2357.tar.gz
ports-4136c68147b4208bc96c31ccfd5dc79626bd2357.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/digikam-kde4/Makefile3
-rw-r--r--graphics/digikam-kde4/files/patch-CMakeLists.txt27
-rw-r--r--graphics/digikam-kde4/pkg-message9
3 files changed, 32 insertions, 7 deletions
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 47d81e8c5c7c..90054227a7bc 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -84,4 +84,7 @@ post-patch:
${LN} -s ../po ${WRKSRC}/po
${RM} ${WRKSRC}/po/*/libkgeomap.po ${WRKSRC}/po/*/kipi*
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/graphics/digikam-kde4/files/patch-CMakeLists.txt b/graphics/digikam-kde4/files/patch-CMakeLists.txt
index 4da9d2b0975e..0cc5595e7a9e 100644
--- a/graphics/digikam-kde4/files/patch-CMakeLists.txt
+++ b/graphics/digikam-kde4/files/patch-CMakeLists.txt
@@ -1,18 +1,31 @@
---- ./CMakeLists.txt.orig 2012-01-02 19:32:49.000000000 -0500
-+++ ./CMakeLists.txt 2012-05-14 20:29:54.000000000 -0400
-@@ -160,6 +160,11 @@
+--- ./CMakeLists.txt.orig 2012-06-04 16:38:57.000000000 -0400
++++ ./CMakeLists.txt 2012-06-24 12:52:32.000000000 -0400
+@@ -203,9 +203,10 @@
FIND_LIBRARY(MATH_LIBRARY m)
ENDIF(NOT WIN32)
+-IF(Boost_FOUND)
+- INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
+-ENDIF(Boost_FOUND)
+STRING(TOLOWER ${CMAKE_SYSTEM_NAME} node_platform)
+IF(${node_platform} MATCHES freebsd)
+ FIND_LIBRARY(KVM_LIBRARY NAMES kvm)
+ENDIF(${node_platform} MATCHES freebsd)
+
+ #-------------------------------------------------------------------------------------
+
+@@ -595,6 +596,10 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/digikam
+ )
+
++ IF(Boost_FOUND)
++ INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
++ ENDIF(Boost_FOUND)
+
- IF(Boost_FOUND)
- INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIRS})
- ENDIF(Boost_FOUND)
-@@ -1624,6 +1629,16 @@
+ IF(USE_SCRIPT_IFACE)
+ INCLUDE_DIRECTORIES(${QT_QTSCRIPT_INCLUDE_DIR})
+ ENDIF(USE_SCRIPT_IFACE)
+@@ -1689,6 +1694,16 @@
MACRO_OPTIONAL_ADD_SUBDIRECTORY(tests)
ENDIF(KDE4_BUILD_TESTS)
diff --git a/graphics/digikam-kde4/pkg-message b/graphics/digikam-kde4/pkg-message
new file mode 100644
index 000000000000..ee13bb8c94ea
--- /dev/null
+++ b/graphics/digikam-kde4/pkg-message
@@ -0,0 +1,9 @@
+=============================================================================
+ You might want to consider increasing the kern.maxfiles tunable using
+ sysctl(8) if you have a large photo collection. Otherwise, Digikam may
+ crash upon startup.
+
+ Add the following line to /boot/loader.conf, then reboot the system:
+
+ kern.maxfiles="25000"
+=============================================================================