aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 20:36:33 +0000
commit41d8c3385c21ae51629c8997035eae8a9423ff6c (patch)
tree246d960cb714ce0095c452017819f6b1c64a7dfb /graphics
parent5e3b0872db18497aacc353b3ef94ad8dac11183f (diff)
downloadports-41d8c3385c21ae51629c8997035eae8a9423ff6c.tar.gz
ports-41d8c3385c21ae51629c8997035eae8a9423ff6c.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ale/Makefile8
-rw-r--r--graphics/cqcam/Makefile8
-rw-r--r--graphics/exact-image/Makefile8
-rw-r--r--graphics/fusefs-gphotofs/Makefile8
-rw-r--r--graphics/imlib2/Makefile6
-rw-r--r--graphics/ivtools/Makefile6
-rw-r--r--graphics/k3d/Makefile4
-rw-r--r--graphics/libvisual04-plugins/Makefile8
-rw-r--r--graphics/libwpcg/Makefile9
-rw-r--r--graphics/linux_dri-devel/Makefile5
-rw-r--r--graphics/linux_dri/Makefile5
-rw-r--r--graphics/pencil/Makefile8
-rw-r--r--graphics/pgplot/files/Makefile.demo3
-rw-r--r--graphics/py-cgkit/Makefile4
-rw-r--r--graphics/ufraw/Makefile8
-rw-r--r--graphics/xmorph/Makefile4
-rw-r--r--graphics/xnview/Makefile17
-rw-r--r--graphics/xsane/Makefile4
18 files changed, 11 insertions, 112 deletions
diff --git a/graphics/ale/Makefile b/graphics/ale/Makefile
index be31455bf1fb..11870390e7c8 100644
--- a/graphics/ale/Makefile
+++ b/graphics/ale/Makefile
@@ -31,14 +31,6 @@ PLIST_FILES= bin/ale
BROKEN= Does not build on alpha
.endif
-.if ${OSVERSION} < 600000
-BROKEN= Does not build on 5.x due to internal gcc error
-.endif
-
-.if ${OSVERSION} < 502114
-CFLAGS+= -Dround=rint
-.endif
-
.if defined(WITH_DOUBLE)
MAKE_ARGS+= COLORS=DOUBLE COORDINATES=DOUBLE
.endif
diff --git a/graphics/cqcam/Makefile b/graphics/cqcam/Makefile
index 6d533e057536..de22e7bea3c8 100644
--- a/graphics/cqcam/Makefile
+++ b/graphics/cqcam/Makefile
@@ -32,12 +32,6 @@ MLINKS= cqcam.1 webcam.1 \
MYPORTDOCS= README docs/APINOTES docs/CHANGES docs/README.webcam \
docs/refresh.html docs/webcam.html docs/README.movies
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502108
-BROKEN= "Does not compile: ffs()-clash"
-.endif
-
post-install:
.for file in cqcam gtkcam webcam xcqcam
@${STRIP_CMD} ${PREFIX}/bin/${file}
@@ -54,4 +48,4 @@ post-install:
.endif
@${SED} -e "s:/usr/local:${PREFIX}:" ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/exact-image/Makefile b/graphics/exact-image/Makefile
index f0c248deea05..642ad2a53246 100644
--- a/graphics/exact-image/Makefile
+++ b/graphics/exact-image/Makefile
@@ -38,12 +38,6 @@ PLIST_FILES= ${BINS:S|^|bin/|} %%SITE_PERL%%/ExactImage.so \
%%SITE_PERL%%/ExactImage.pm
PORT_VERBS= ExactImage ${BINS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile, missing endian.h header
-.endif
-
post-extract:
@${RM} -rf ${WRKSRC}/agg-2.4/
@@ -73,4 +67,4 @@ do-install:
${INSTALL_PROGRAM} ExactImage.so ${SITE_PERL}/;\
${INSTALL_DATA} ExactImage.pm ${SITE_PERL}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/fusefs-gphotofs/Makefile b/graphics/fusefs-gphotofs/Makefile
index 6372c235b49b..ba32ba973f7b 100644
--- a/graphics/fusefs-gphotofs/Makefile
+++ b/graphics/fusefs-gphotofs/Makefile
@@ -26,10 +26,4 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/gphotofs
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= depends on kernel module that requires FreeBSD 6 or later
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 6baa57c37ee2..419764665ae1 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -91,10 +91,4 @@ CONFIGURE_ARGS+= --without-id3
PLIST_SUB+= ID3="@comment "
.endif
-post-patch:
-.if ${OSVERSION} < 503000
- @${REINPLACE_CMD} -e \
- 's|round|rint|g' ${WRKSRC}/src/lib/color_helpers.c
-.endif
-
.include <bsd.port.post.mk>
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index 970e6711e3e0..94c9cb3f5df0 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -34,8 +34,4 @@ MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
BROKEN= Incomplete pkg-plist
.endif
-.if ${OSVERSION} >= 600000 && ${OSVERSION} < 700000
-PLIST_SUB+= IVDL="@comment"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index effaa74878bc..458f276b5854 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -47,10 +47,6 @@ OPTIONS= GNOME "Build for Gnome" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on FreeBSD 5.x
-.endif
-
.if defined(WITH_GNOME)
USE_GNOME+= libgnome
CONFIGURE_ARGS+=--with-gnome
diff --git a/graphics/libvisual04-plugins/Makefile b/graphics/libvisual04-plugins/Makefile
index efeeeb3863a9..f902025a876f 100644
--- a/graphics/libvisual04-plugins/Makefile
+++ b/graphics/libvisual04-plugins/Makefile
@@ -39,12 +39,6 @@ DATADIR= ${PREFIX}/share/${PORTNAME}-${PKGNAMESUFFIX:C/.*-//}-${MAJORMINOR}
PLIST_SUB= PLUGINS_BASE_DIR=${LOCALBASE}/lib/${PORTNAME}-${MAJORMINOR} \
DATADIR_REL=${DATADIR_REL}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on 5.x
-.endif
-
pre-configure:
# /usr/bin/objformat is obsolete, hardcode the object format
@${REINPLACE_CMD} -e 's,objformat=.*,objformat=elf,' \
@@ -58,4 +52,4 @@ pre-configure:
@${REINPLACE_CMD} -e 's,^\(SUBDIRS = plugins\) po,\1,' \
${WRKSRC}/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/libwpcg/Makefile b/graphics/libwpcg/Makefile
index 41d3aa0ef42e..45ac3a23eba3 100644
--- a/graphics/libwpcg/Makefile
+++ b/graphics/libwpcg/Makefile
@@ -22,11 +22,4 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lGL -lGLU -lglut"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501103
-# Work around bsd.port.mk bug: Does not currently set up MAKE_ENV for gcc 3.2 and 3.3
-MAKE_ENV+= CC="${CC}" CXX="${CXX}"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/linux_dri-devel/Makefile b/graphics/linux_dri-devel/Makefile
index ec90b49d6acc..bfc60c041823 100644
--- a/graphics/linux_dri-devel/Makefile
+++ b/graphics/linux_dri-devel/Makefile
@@ -35,11 +35,6 @@ LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502111
-EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
-TAR= bsdtar
-.endif
-
do-install:
${MKDIR} ${PREFIX}/usr/X11R6/lib/modules/dri
${INSTALL_PROGRAM} ${WRKSRC}/linux_dri/libGL.so.1.2 \
diff --git a/graphics/linux_dri/Makefile b/graphics/linux_dri/Makefile
index a76e4dae66e6..84c2ac367aa8 100644
--- a/graphics/linux_dri/Makefile
+++ b/graphics/linux_dri/Makefile
@@ -45,11 +45,6 @@ LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502111
-EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
-TAR= bsdtar
-.endif
-
do-install:
${MKDIR} ${PREFIX}/usr/X11R6/lib/modules/dri
${INSTALL_PROGRAM} ${WRKSRC}/linux_dri/libGL.so.1.2 \
diff --git a/graphics/pencil/Makefile b/graphics/pencil/Makefile
index d4eef5486163..55444df7b6c2 100644
--- a/graphics/pencil/Makefile
+++ b/graphics/pencil/Makefile
@@ -35,12 +35,6 @@ USE_XORG= xi xrender xrandr xfixes xcursor xinerama xext x11 xau xdmcp \
USE_GL= gl glu
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile
-.endif
-
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} -unix PREFIX=${PREFIX} \
@@ -61,4 +55,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pgplot/files/Makefile.demo b/graphics/pgplot/files/Makefile.demo
index 2d2ff02104a1..7b7455923034 100644
--- a/graphics/pgplot/files/Makefile.demo
+++ b/graphics/pgplot/files/Makefile.demo
@@ -2,10 +2,7 @@ PGPLOT_LIB = -L/usr/local/lib -lpgplot
CPGPLOT_LIB = -L/usr/local/lib -lcpgplot
LIBS= -L${LOCALBASE}/lib -lX11 -lm
-OSVERSION!= /sbin/sysctl -n kern.osreldate
-.if ${OSVERSION} > 400004
FFLAGS+= -fno-backslash
-.endif
all: cpgdemo pgdemo1 pgdemo2 pgdemo3 pgdemo4 pgdemo5 pgdemo6 pgdemo7 pgdemo8 \
pgdemo9 pgdemo10 pgdemo11 pgdemo12 pgdemo13 pgdemo14 pgdemo15 \
diff --git a/graphics/py-cgkit/Makefile b/graphics/py-cgkit/Makefile
index dc6dcaca1746..aad73b2eac00 100644
--- a/graphics/py-cgkit/Makefile
+++ b/graphics/py-cgkit/Makefile
@@ -40,10 +40,6 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/OpenGL:${PORTSDIR}/graphics/py-opengl \
.include <bsd.port.pre.mk>
-.if ( ${OSVERSION} < 502126 )
-BROKEN= does not compile
-.endif
-
.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
BROKEN= does not compile
.endif
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index ad7cff58e0c2..5665b741dd83 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -47,12 +47,6 @@ PLIST_SUB+= GIMP="@comment "
MAN1= ufraw.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 504105
-BROKEN= Needs memmem(3)
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '18s|^$$|#include <sys/types.h>|' ${WRKSRC}/dcraw.h
@${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' ${WRKSRC}/Makefile.in
@@ -60,4 +54,4 @@ post-patch:
@${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index 0b79282ce03b..e6728da53dee 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -35,10 +35,6 @@ INFO= xmorph
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502114
-CFLAGS+= -Dround=rint
-.endif
-
.if ${HAVE_GNOME:Mgtk20}!=""
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-gtk=2
diff --git a/graphics/xnview/Makefile b/graphics/xnview/Makefile
index c85ff40ee9b8..0cf08adef960 100644
--- a/graphics/xnview/Makefile
+++ b/graphics/xnview/Makefile
@@ -26,11 +26,9 @@ MLINKS= nview.1 nv.1 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
- LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
- DISTFILES+= NConvert-x86-unknown-FreeBSD6.x.tgz
- WRKSRC_NC= ${WRKDIR}/NConvert
-.endif
+LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
+DISTFILES+= NConvert-x86-unknown-FreeBSD6.x.tgz
+WRKSRC_NC= ${WRKDIR}/NConvert
.if ${OSVERSION} >= 700000
LIB_DEPENDS+= c.6:${PORTSDIR}/misc/compat6x
@@ -39,23 +37,14 @@ MLINKS= nview.1 nv.1 \
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/xnview ${PREFIX}/bin/xnview
${INSTALL_PROGRAM} ${WRKSRC}/bin/nview ${PREFIX}/bin/nv
-.if ${OSVERSION} >= 600000
${INSTALL_PROGRAM} ${WRKSRC_NC}/nconvert ${PREFIX}/bin/nconvert
-.else
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/nconvert ${PREFIX}/bin/nconvert
-.endif
${INSTALL_DATA} ${WRKSRC}/app-defaults/XnView.ad ${PREFIX}/lib/X11/app-defaults/XnView
cd ${WRKSRC}/man && ${INSTALL_MAN} xnview.1 nview.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.if ${OSVERSION} >= 600000
cd ${WRKSRC_NC} && \
${INSTALL_DATA} Formats.txt ReadMe.txt Usage.txt WhatsNew.txt ${DOCSDIR}
-.else
- cd ${WRKSRC} && \
- ${INSTALL_DATA} Formats.txt ReadMe.txt Usage.txt WhatsNew.txt ${DOCSDIR}
-.endif
.endif
.include <bsd.port.post.mk>
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index 0aa2890e54e0..e695db6c8b3f 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -65,10 +65,6 @@ LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp-app
CONFIGURE_ARGS+= --disable-gimp
.endif
-.if ${OSVERSION} < 500035
-CONFIGURE_ENV+= CFLAGS="${CFLAGS:C/-O[0-9]*//g}"
-.endif
-
pre-patch:
@${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} \
-i "" -e 's|\$$(DESTDIR)\$$(sbindir)||g'