aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-05 15:05:29 +0000
commit43f0c9f153cbb6a2e3db53e004582f6729057928 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /graphics
parent51a9b4dec5856fd0ce0b884de19626c1cc420758 (diff)
downloadports-43f0c9f153cbb6a2e3db53e004582f6729057928.tar.gz
ports-43f0c9f153cbb6a2e3db53e004582f6729057928.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Color-Palette/Makefile9
-rw-r--r--graphics/p5-Color-Scheme/Makefile3
-rw-r--r--graphics/p5-Graph-Easy/Makefile3
-rw-r--r--graphics/p5-URI-GoogleChart/Makefile9
4 files changed, 10 insertions, 14 deletions
diff --git a/graphics/p5-Color-Palette/Makefile b/graphics/p5-Color-Palette/Makefile
index 0d1060ef79de..c850b81f8a56 100644
--- a/graphics/p5-Color-Palette/Makefile
+++ b/graphics/p5-Color-Palette/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/p5-Color-Palette
-# Date created: 02 September 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Color-Palette
PORTVERSION= 0.100002
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Color::Palette.3 \
Color::Palette::Schema.3 \
diff --git a/graphics/p5-Color-Scheme/Makefile b/graphics/p5-Color-Scheme/Makefile
index a55206cc126d..f699d1b550eb 100644
--- a/graphics/p5-Color-Scheme/Makefile
+++ b/graphics/p5-Color-Scheme/Makefile
@@ -13,7 +13,8 @@ COMMENT= Generate pleasant color schemes
BUILD_DEPENDS= p5-Test-Differences>=0.47:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Color::Scheme.3
diff --git a/graphics/p5-Graph-Easy/Makefile b/graphics/p5-Graph-Easy/Makefile
index 33791bd86b40..1b4c0b2fc7b5 100644
--- a/graphics/p5-Graph-Easy/Makefile
+++ b/graphics/p5-Graph-Easy/Makefile
@@ -13,7 +13,8 @@ COMMENT= Render graphs as ASCII, HTML, SVG, or Graphviz
BUILD_DEPENDS= p5-Heap>0:${PORTSDIR}/devel/p5-Heap
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= graph-easy.1
diff --git a/graphics/p5-URI-GoogleChart/Makefile b/graphics/p5-URI-GoogleChart/Makefile
index b397befe285a..14733f26c108 100644
--- a/graphics/p5-URI-GoogleChart/Makefile
+++ b/graphics/p5-URI-GoogleChart/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: graphics/p5-URI-GoogleChart
-# Date created: 28 March 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= URI-GoogleChart
PORTVERSION= 1.02
@@ -18,7 +14,8 @@ COMMENT= Generate Google Chart URIs
BUILD_DEPENDS= p5-URI>0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::GoogleChart.3