aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-04-30 00:44:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-04-30 00:44:32 +0000
commit4ebba57eca24629c95e4c6381784c4f8b79ebb74 (patch)
tree8c847bbbc817ef48384502023f8dfefe6bc835e4 /graphics
parent633f9296f4a9a6d9f4988a62658038fdd8c8cc4f (diff)
downloadports-4ebba57eca24629c95e4c6381784c4f8b79ebb74.tar.gz
ports-4ebba57eca24629c95e4c6381784c4f8b79ebb74.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/megapov/Makefile2
-rw-r--r--graphics/mozjpeg/Makefile2
-rw-r--r--graphics/opencollada/Makefile2
-rw-r--r--graphics/opencolorio/Makefile2
-rw-r--r--graphics/povray36/Makefile4
-rw-r--r--graphics/povray37/Makefile2
6 files changed, 7 insertions, 7 deletions
diff --git a/graphics/megapov/Makefile b/graphics/megapov/Makefile
index de83a6468126..c47da9bded49 100644
--- a/graphics/megapov/Makefile
+++ b/graphics/megapov/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://megapov.inetart.net/packages/unix/
MAINTAINER= ports@FreeBSD.org
COMMENT= Unofficial extensions of POV-Ray
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: nputoutput.cpp:1: error: 64 bit CPU requiredd
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
diff --git a/graphics/mozjpeg/Makefile b/graphics/mozjpeg/Makefile
index 74c284b93a1c..4b908ae3a423 100644
--- a/graphics/mozjpeg/Makefile
+++ b/graphics/mozjpeg/Makefile
@@ -44,7 +44,7 @@ TURBOJPEG_CONFIGURE_WITH= turbojpeg
BROKEN_aarch64= Does not configure: error: SIMD support cannot be enabled
BROKEN_mips64= Does not configure: error: SIMD support cannot be enabled
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: undefined reference to htole32
BROKEN_sparc64= Does not configure: error: SIMD support cannot be enabled
post-patch:
diff --git a/graphics/opencollada/Makefile b/graphics/opencollada/Makefile
index 9a1132403008..a707990bc362 100644
--- a/graphics/opencollada/Makefile
+++ b/graphics/opencollada/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LIB_DEPENDS= libpcre.so:devel/pcre
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
USE_GITHUB= yes
GH_ACCOUNT= KhronosGroup
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 7d01d5be4b49..1e7975ede92e 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -38,7 +38,7 @@ SHEBANG_FILES= share/sphinx/ExtractRstFromSourceCPP.py \
BROKEN_aarch64= Does not compile: error: use of undeclared identifier __builtin_ia32_emms
BROKEN_armv6= Does not compile: error: use of undeclared identifier __builtin_ia32_emms
BROKEN_mips64= Does not compile: error: unrecognized command line option -msse2
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not compile: error: unrecognized command line option -msse2
BROKEN_sparc64= Does not compile: error: unrecognized command line option -msse2
.include <bsd.port.options.mk>
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 5ed7c04e4395..9c2f71a77420 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -14,11 +14,11 @@ DIST_SUBDIR= povray36
MAINTAINER= ports@FreeBSD.org
COMMENT= Persistence of Vision Ray Tracer
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
+BROKEN_powerpc64= Does not build: error: 64 bit CPU required
+
USE_XORG= x11
USES= gmake jpeg tar:bzip2
GNU_CONFIGURE= yes
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index ffe30fd14eb7..6378a8578682 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -13,7 +13,7 @@ COMMENT= Persistence of Vision Ray Tracer
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
-BROKEN_powerpc64= Does not build
+BROKEN_powerpc64= Does not build: c++: Internal error: Killed (program cc1plus)
OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
OPTIONS_DEFAULT=PNG JPEG