aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2019-02-20 06:59:45 +0000
committerCy Schubert <cy@FreeBSD.org>2019-02-20 06:59:45 +0000
commit4f0f664a006ecb4819758025bae108099f25a812 (patch)
tree66bd14d95829acb2029b76d148e387da15e3df05 /graphics
parentdc418e5b6977cc8c47cd325f8c4725dcf9b6dc87 (diff)
downloadports-4f0f664a006ecb4819758025bae108099f25a812.tar.gz
ports-4f0f664a006ecb4819758025bae108099f25a812.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpdf4/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/graphics/xpdf4/Makefile b/graphics/xpdf4/Makefile
index a714c374ad3f..fb31f2ae4a21 100644
--- a/graphics/xpdf4/Makefile
+++ b/graphics/xpdf4/Makefile
@@ -7,9 +7,6 @@ CATEGORIES= graphics print
MASTER_SITES= https://xpdfreader-dl.s3.amazonaws.com/
.if !defined(MASTERDIR)
PKGNAMESUFFIX= 4
-CONFLICTS_INSTALL= xpdf3-* xpdf-*
-.else
-CONFLICTS_INSTALL= xpdf3-* xpdf4-*
.endif
MAINTAINER= cy@FreeBSD.org
@@ -17,17 +14,21 @@ COMMENT= Display PDF files and convert them to other formats
LICENSE= GPLv2
-LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libpng.so:graphics/png
-
CONFLICTS_INSTALL= xpdf
-
-MANPREFIX= ${PREFIX}/share/xpdf
-SUB_FILES= xpdf-man.conf
+.if !defined(MASTERDIR)
+CONFLICTS_INSTALL+= xpdf3-* xpdf-*
+.else
+CONFLICTS_INSTALL+= xpdf3-* xpdf4-*
+.endif
USES= compiler:c++11-lang cmake localbase:ldflags \
desktop-file-utils qt:5
-USE_QT= buildtools_build,concurrent,core,gui,network,printsupport,qmake_build,svg,widgets
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png
+MANPREFIX= ${PREFIX}/share/xpdf
+SUB_FILES= xpdf-man.conf
+USE_QT= buildtools_build concurrent core gui network printsupport \
+ qmake_build svg widgets
CMAKE_ARGS+= -DOPI_SUPPORT:BOOL=ON -DCMAKE_DISABLE_FIND_PACKAGE_Qt4:BOOL=ON \
-DUSE_LCMS:BOOL=OFF -DSYSTEM_XPDFRC=${PREFIX}/etc/xpdfrc \
-DCMAKE_INSTALL_PREFIX=${PREFIX} \