aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorZsolt Udvari <uzsolt@FreeBSD.org>2024-02-24 13:31:54 +0000
committerZsolt Udvari <uzsolt@FreeBSD.org>2024-02-24 13:35:19 +0000
commit537cbffa5984539c50847e71989842f72cb3a118 (patch)
tree33623d60a992afe49793ea2e043556a57bc27d3b /graphics
parentbe907b012694b8884d90f67e5ca84812e32d24b8 (diff)
downloadports-537cbffa5984539c50847e71989842f72cb3a118.tar.gz
ports-537cbffa5984539c50847e71989842f72cb3a118.zip
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mupdf/Makefile33
-rw-r--r--graphics/mupdf/pkg-plist4
2 files changed, 21 insertions, 16 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 6f7384feef7c..76df26e1d01f 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -1,6 +1,7 @@
PORTNAME= mupdf
DISTVERSION= 1.23.9
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.mupdf.com/downloads/archive/
@@ -18,36 +19,40 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libjbig2dec.so:graphics/jbig2dec \
libopenjp2.so:graphics/openjpeg
-USES= cpe compiler:c++11-lang gl gmake jpeg pkgconfig xorg
-USE_XORG= x11 xcursor xext xinerama xrandr
+USES= compiler:c++11-lang cpe gl gmake jpeg pkgconfig xorg
+CPE_VENDOR= artifex
USE_GL= gl glut
USE_LDCONFIG= yes
+USE_XORG= x11 xcursor xext xinerama xrandr
-CPE_VENDOR= artifex
+MAKE_ARGS= build=release \
+ mandir=${PREFIX}/share/man \
+ prefix=${PREFIX} \
+ SOVERSION=${DISTVERSION} \
+ verbose=yes \
+ XCFLAGS+="-I${WRKSRC}/include/mupdf -fPIC" \
+ XLIBS+="-L${LOCALBASE}/lib -L${WRKSRC}/build/release"
+ALL_TARGET= all extra-libs
# pkg-config to avoid the conflict with openjpeg15
CFLAGS+= `pkg-config --cflags libopenjp2`
LDFLAGS+= `pkg-config --libs libjpeg libopenjp2` -ljbig2dec
-MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
- XCFLAGS+="-I${WRKSRC}/include/mupdf -fPIC" \
- XLIBS+="-L${LOCALBASE}/lib -L${WRKSRC}/build/release" \
- SOVERSION=${DISTVERSION}
-ALL_TARGET= all extra-libs
+BINARY_ALIAS= bash=/bin/sh
+
+PLIST_SUB= SOVERSION=${PORTVERSION}
-OPTIONS_DEFINE= DOCS JS SCROLL
+OPTIONS_DEFINE= DOCS JS SCROLL
OPTIONS_DEFAULT= SCROLL
JS_DESC= JavaScript support (V8 engine)
SCROLL_DESC= Build with scroll hacks
-JS_LIB_DEPENDS= libv8.so:lang/v8
-JS_MAKE_ARGS= V8_PRESENT=1 V8LIBS=-lv8
+JS_LIB_DEPENDS= libv8.so:lang/v8
+JS_MAKE_ARGS= V8_PRESENT=1 \
+ V8LIBS=-lv8
SCROLL_EXTRA_PATCHES= ${FILESDIR}/scroll_hack-platform__x11__pdfapp.c
-BINARY_ALIAS= bash=/bin/sh
-PLIST_SUB= SOVERSION=${PORTVERSION}
-
post-patch:
@${REINPLACE_CMD} -e 's/-pipe -O2//' -e 's/-ldl//' ${WRKSRC}/Makerules
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
index f22e40634d55..b05a489d69ee 100644
--- a/graphics/mupdf/pkg-plist
+++ b/graphics/mupdf/pkg-plist
@@ -76,8 +76,8 @@ lib/libmupdf-third.so
lib/libmupdf-third.so.%%SOVERSION%%
lib/libmupdf.so
lib/libmupdf.so.%%SOVERSION%%
-man/man1/mupdf.1.gz
-man/man1/mutool.1.gz
+share/man/man1/mupdf.1.gz
+share/man/man1/mutool.1.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README