aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-22 19:08:37 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-22 19:08:37 +0000
commit580851dc74f600d7bd9f38ea204f012f69f8f2e6 (patch)
tree521c29304d4a87a39df1dac8a582e1a0d3557916 /graphics
parentef20f8e1b6899c9140b88a50aa92f043816b5d11 (diff)
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autotrace/Makefile6
-rw-r--r--graphics/ming/Makefile7
-rw-r--r--graphics/ming/pkg-plist4
-rw-r--r--graphics/p5-ming/Makefile2
-rw-r--r--graphics/pencil/Makefile24
-rw-r--r--graphics/pstoedit/Makefile2
-rw-r--r--graphics/py-ming/Makefile2
-rw-r--r--graphics/ruby-ming/Makefile2
-rw-r--r--graphics/zphoto/Makefile2
9 files changed, 21 insertions, 30 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index fb6de2c80fc5..4c09f9ad4769 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -3,7 +3,7 @@
PORTNAME= autotrace
PORTVERSION= 0.31.1
-PORTREVISION= 25
+PORTREVISION= 26
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/AutoTrace/${PORTVERSION}
@@ -18,8 +18,8 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
USES= pathfix pkgconfig libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= $$(libpng-config --I_opts) ${PTHREAD_CFLAGS}
-LDFLAGS+= $$(libpng-config --L_opts) ${PTHREAD_LIBS}
+CPPFLAGS+= $$(libpng-config --I_opts)
+LDFLAGS+= $$(libpng-config --L_opts)
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= IMAGEMAGICK MING PSTOEDIT
diff --git a/graphics/ming/Makefile b/graphics/ming/Makefile
index 9c37d969df0f..9ef53b089692 100644
--- a/graphics/ming/Makefile
+++ b/graphics/ming/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ming
PORTVERSION= 0.4.5
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Releases/
@@ -25,14 +25,14 @@ LIB_DEPENDS+= libming.so:${PORTSDIR}/graphics/ming
OPTIONS_DEFINE= DOCS
.endif
-CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--includedir=${PREFIX}/include/ming
CPPFLAGS+= -I. -I.. -I${LOCALBASE}/include
LDFLAGS+= -L. -L.. -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES+= bison gmake pathfix shebangfix
+USES+= bison gmake libtool pathfix shebangfix
DOCS= HISTORY NEWS README TODO
DOCS_UTIL= README TIPS TODO swftoperl.html
@@ -67,7 +67,6 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}/ ${STAGEDIR}${DOCSDIR}/util/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/util/ && ${INSTALL_DATA} ${DOCS_UTIL} ${STAGEDIR}${DOCSDIR}/util/
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libming.so.5
.endif
.if defined(SLAVEPORT) && ${SLAVEPORT} == "p5"
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
diff --git a/graphics/ming/pkg-plist b/graphics/ming/pkg-plist
index 17ea429ed317..0224c93b4209 100644
--- a/graphics/ming/pkg-plist
+++ b/graphics/ming/pkg-plist
@@ -101,9 +101,9 @@ include/ming/util/swfoutput.h
include/ming/util/swftypes.h
include/ming/util/vasprintf.h
lib/libming.a
-lib/libming.la
lib/libming.so
-lib/libming.so.5
+lib/libming.so.1
+lib/libming.so.1.4.4
libdata/pkgconfig/libming.pc
%%PORTDOCS%%%%DOCSDIR%%/HISTORY
%%PORTDOCS%%%%DOCSDIR%%/NEWS
diff --git a/graphics/p5-ming/Makefile b/graphics/p5-ming/Makefile
index 9b7b007e915f..69fe0ef8faaa 100644
--- a/graphics/p5-ming/Makefile
+++ b/graphics/p5-ming/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ming
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics perl5
PKGNAMEPREFIX= p5-
diff --git a/graphics/pencil/Makefile b/graphics/pencil/Makefile
index 5ba05e331c45..d0bac4d6402b 100644
--- a/graphics/pencil/Makefile
+++ b/graphics/pencil/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pencil
PORTVERSION= 0.4.4b
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}-planner/Pencil/${PORTVERSION}eta
DISTNAME= ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFFIX}
@@ -13,21 +13,13 @@ COMMENT= Pencil - a traditional 2D animation software
LICENSE= GPLv2
-LIB_DEPENDS+= libming.so:${PORTSDIR}/graphics/ming \
- libpng15.so:${PORTSDIR}/graphics/png \
- libfreetype.so:${PORTSDIR}/print/freetype2 \
- libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
- libexpat.so:${PORTSDIR}/textproc/expat2 \
- libpcre.so:${PORTSDIR}/devel/pcre \
- libdrm.so:${PORTSDIR}/graphics/libdrm
-
-USES= gettext iconv qmake zip
-USE_GNOME= glib20
-USE_QT4= gui moc_build rcc_build xml_build opengl_build
-USE_XORG= xi xrender xrandr xfixes xcursor xinerama xext x11 xau xdmcp \
- xxf86vm xdamage
-USE_GL= gl glu
-QMAKE_ARGS+= INCLUDEPATH+=${LOCALBASE}/include/ming
+LIB_DEPENDS= libming.so:${PORTSDIR}/graphics/ming \
+ libpng.so:${PORTSDIR}/graphics/png
+
+USES= qmake zip
+USE_QT4= gui opengl xml moc_build rcc_build
+USE_GL= gl
+QMAKE_ARGS= INCLUDEPATH+=${LOCALBASE}/include/ming
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
PLIST_FILES= bin/pencil
diff --git a/graphics/pstoedit/Makefile b/graphics/pstoedit/Makefile
index 6ab97e8d0b13..428a9ffe284f 100644
--- a/graphics/pstoedit/Makefile
+++ b/graphics/pstoedit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pstoedit
PORTVERSION= 3.62
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics print
MASTER_SITES= SF
diff --git a/graphics/py-ming/Makefile b/graphics/py-ming/Makefile
index 6dc1462e8fa7..c7d56222b0a2 100644
--- a/graphics/py-ming/Makefile
+++ b/graphics/py-ming/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ming
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index 4a393a82cf46..f41b509db4ce 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ming
PORTVERSION= 0.4.3.${RUBY_MING_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= graphics ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= mingruby
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index a7f657863fb3..766a5016d37d 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zphoto
PORTVERSION= 1.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}