aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2011-09-19 22:21:56 +0000
committerMikhail Teterin <mi@FreeBSD.org>2011-09-19 22:21:56 +0000
commit5bc4cc47052869da71b7ce5ee6de2ed5075f546b (patch)
treec26749bdf095b444722fa33e62d0d1118a2f30f6 /graphics
parent5f0c7d72942c39026d198dff36d4f9d53a68f154 (diff)
downloadports-5bc4cc47052869da71b7ce5ee6de2ed5075f546b.tar.gz
ports-5bc4cc47052869da71b7ce5ee6de2ed5075f546b.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/libimg/Makefile1
-rw-r--r--graphics/libimg/files/Makefile.bsd1
-rw-r--r--graphics/libimg/files/patch-warnings9
3 files changed, 10 insertions, 1 deletions
diff --git a/graphics/libimg/Makefile b/graphics/libimg/Makefile
index 3cfa560b0776..448258946339 100644
--- a/graphics/libimg/Makefile
+++ b/graphics/libimg/Makefile
@@ -32,6 +32,7 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
USE_TK= 83+
USE_TK_BUILD= ${USE_TK}
MAKE_ENV+= TCL_VER=${TCL_VER}
+MAKE_JOBS_SAFE= yes
# We don't need the bundled libraries:
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libz/*' \
diff --git a/graphics/libimg/files/Makefile.bsd b/graphics/libimg/files/Makefile.bsd
index bce1f278ac14..7170d7467a7d 100644
--- a/graphics/libimg/files/Makefile.bsd
+++ b/graphics/libimg/files/Makefile.bsd
@@ -31,6 +31,7 @@ CFLAGS+= -DNDEBUG -Wall -I. -DUSE_TCL_STUBS -DUSE_TK_STUBS
CFLAGS+= -DVERSION=\"${PORTVERSION}\" -I${LOCALBASE}/include
CFLAGS+= -DHAVE_JPEGLIB_H -DHAVE_TIFF_H -DHAVE_DLFCN_H -DHAVE_IMG_H
CFLAGS+= -DHAVE_INTTYPES_H -DHAVE_STDINT_H -DHAVE_UNISTD_H -DSTDC_HEADERS
+CFLAGS+= -DUSE_INTERP_RESULT
all: pkgIndex.tcl
diff --git a/graphics/libimg/files/patch-warnings b/graphics/libimg/files/patch-warnings
index 930e07d25fb6..61bc1a82b9a8 100644
--- a/graphics/libimg/files/patch-warnings
+++ b/graphics/libimg/files/patch-warnings
@@ -1,5 +1,12 @@
--- imgObj.c 2002-01-15 16:00:08.000000000 -0500
-+++ imgObj.c 2011-09-14 01:42:03.000000000 -0400
++++ imgObj.c 2011-09-19 18:18:06.000000000 -0400
+@@ -23,5 +23,5 @@
+
+ static int initialized = 0;
+-static Tcl_ObjType* byteArrayType = 0;
++static const Tcl_ObjType* byteArrayType = 0;
+
+ int
@@ -33,5 +33,5 @@
return (initialized = IMG_PERL|IMG_OBJS);
#else