aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-08 12:36:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-06-08 17:28:01 +0000
commit5fb024ea6186531b2f2cc9482a9a883d54880551 (patch)
treefd109959c2a3940946927a280ffd9491cec1cf14 /graphics
parentf1a94dd860fe147e12b891e0cc16eb9ad3a52191 (diff)
downloadports-5fb024ea6186531b2f2cc9482a9a883d54880551.tar.gz
ports-5fb024ea6186531b2f2cc9482a9a883d54880551.zip
graphics/tiled: update to 1.7.0
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tiled/Makefile2
-rw-r--r--graphics/tiled/distinfo6
-rw-r--r--graphics/tiled/files/patch-src_tiled_main.cpp46
-rw-r--r--graphics/tiled/files/patch-src_tiled_tiled.pro11
4 files changed, 4 insertions, 61 deletions
diff --git a/graphics/tiled/Makefile b/graphics/tiled/Makefile
index 3a26fb8569cc..f2b4e4320c48 100644
--- a/graphics/tiled/Makefile
+++ b/graphics/tiled/Makefile
@@ -1,5 +1,5 @@
PORTNAME= tiled
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics editors games
diff --git a/graphics/tiled/distinfo b/graphics/tiled/distinfo
index 78cf71c31c38..10da50320545 100644
--- a/graphics/tiled/distinfo
+++ b/graphics/tiled/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619258429
-SHA256 (bjorn-tiled-v1.6.0_GH0.tar.gz) = c8bc2cd8f48c9085ac391cf17e351eccae9bed95b0a726f62d3a77f1fddba6ae
-SIZE (bjorn-tiled-v1.6.0_GH0.tar.gz) = 16730026
+TIMESTAMP = 1623151954
+SHA256 (bjorn-tiled-v1.7.0_GH0.tar.gz) = 836492b127cc3cda62d4ac0cdc3b6ade8dd814d4a4d8b44871ab07acef87a260
+SIZE (bjorn-tiled-v1.7.0_GH0.tar.gz) = 16742927
diff --git a/graphics/tiled/files/patch-src_tiled_main.cpp b/graphics/tiled/files/patch-src_tiled_main.cpp
deleted file mode 100644
index 9bcc5fa8e2d6..000000000000
--- a/graphics/tiled/files/patch-src_tiled_main.cpp
+++ /dev/null
@@ -1,46 +0,0 @@
---- src/tiled/main.cpp.orig 2021-04-23 13:13:21 UTC
-+++ src/tiled/main.cpp
-@@ -66,10 +66,6 @@ static QTextStream& stdOut()
- return ts;
- }
-
--#if QT_VERSION >= QT_VERSION_CHECK(5,14,0)
--using Qt::endl;
--#endif
--
- namespace {
-
- class CommandLineHandler : public CommandLineParser
-@@ -260,7 +256,7 @@ void CommandLineHandler::showVersion()
- if (!showedVersion) {
- showedVersion = true;
- stdOut() << QApplication::applicationDisplayName() << " "
-- << QApplication::applicationVersion() << endl;
-+ << QApplication::applicationVersion() << Qt::endl;
- quit = true;
- }
- }
-@@ -317,9 +313,9 @@ void CommandLineHandler::showExportFormats()
- }
- formats.sort(Qt::CaseSensitive);
-
-- stdOut() << tr("Map export formats:") << endl;
-+ stdOut() << tr("Map export formats:") << Qt::endl;
- for (const QString &name : formats)
-- stdOut() << " " << name << endl;
-+ stdOut() << " " << name << Qt::endl;
-
- formats.clear();
- const auto tilesetFormats = PluginManager::objects<TilesetFormat>();
-@@ -329,9 +325,9 @@ void CommandLineHandler::showExportFormats()
- }
- formats.sort(Qt::CaseSensitive);
-
-- stdOut() << tr("Tileset export formats:") << endl;
-+ stdOut() << tr("Tileset export formats:") << Qt::endl;
- for (const QString &name : formats)
-- stdOut() << " " << name << endl;
-+ stdOut() << " " << name << Qt::endl;
-
- quit = true;
- }
diff --git a/graphics/tiled/files/patch-src_tiled_tiled.pro b/graphics/tiled/files/patch-src_tiled_tiled.pro
deleted file mode 100644
index 7bc3803b84bf..000000000000
--- a/graphics/tiled/files/patch-src_tiled_tiled.pro
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tiled/tiled.pro.orig 2021-04-23 13:13:21 UTC
-+++ src/tiled/tiled.pro
-@@ -19,7 +19,7 @@ contains(QT_CONFIG, opengl):minQtVersion(6, 0, 0) {
- QT += openglwidgets
- }
-
--contains(QT_CONFIG, dbus) {
-+!contains(DISABLE_DBUS, yes):contains(QT_CONFIG, dbus) {
- QT += dbus
- DEFINES += TILED_ENABLE_DBUS
- }