aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-07-24 12:00:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-07-24 12:11:53 +0000
commit64e16df573cf569f1d1056963fff072e990a2c3b (patch)
tree499b9e1a28636ad04d9a4cc89e7ebd4bd2dcac6e /graphics
parent8d1799264b126343b400fe22a73c90882da7fe9b (diff)
downloadports-64e16df573cf569f1d1056963fff072e990a2c3b.tar.gz
ports-64e16df573cf569f1d1056963fff072e990a2c3b.zip
graphics/vulkan-extension-layer: add new port
There are some extensions and features in Vulkan that are not available everywhere due to various reasons. While not available, some extensions are capable of being done as layer and mapping to any Vulkan implementation regardless of it supporting the desired functionality or not. https://github.com/KhronosGroup/Vulkan-ValidationLayers
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/vulkan-extension-layer/Makefile19
-rw-r--r--graphics/vulkan-extension-layer/distinfo3
-rw-r--r--graphics/vulkan-extension-layer/files/patch-utils_vk__loader__platform.h11
-rw-r--r--graphics/vulkan-extension-layer/pkg-descr7
-rw-r--r--graphics/vulkan-extension-layer/pkg-plist5
6 files changed, 46 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 06d58239751e..2cee5538cdf5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1088,6 +1088,7 @@
SUBDIR += vp
SUBDIR += vpaint
SUBDIR += vulkan-caps-viewer
+ SUBDIR += vulkan-extension-layer
SUBDIR += vulkan-headers
SUBDIR += vulkan-loader
SUBDIR += vulkan-tools
diff --git a/graphics/vulkan-extension-layer/Makefile b/graphics/vulkan-extension-layer/Makefile
new file mode 100644
index 000000000000..421e1e39f02f
--- /dev/null
+++ b/graphics/vulkan-extension-layer/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= vulkan-extension-layer
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.185
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Layer providing Vulkan features when native support is unavailable
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+
+USES= cmake compiler:c++11-lib
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= KhronosGroup
+GH_PROJECT= Vulkan-ExtensionLayer
+
+.include <bsd.port.mk>
diff --git a/graphics/vulkan-extension-layer/distinfo b/graphics/vulkan-extension-layer/distinfo
new file mode 100644
index 000000000000..0fb508f8f83c
--- /dev/null
+++ b/graphics/vulkan-extension-layer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625608724
+SHA256 (KhronosGroup-Vulkan-ExtensionLayer-v1.2.185_GH0.tar.gz) = 86e80ae16f80469a8746f1c98d2fac760e02d29aca2f9b9fd3142179985d8760
+SIZE (KhronosGroup-Vulkan-ExtensionLayer-v1.2.185_GH0.tar.gz) = 430806
diff --git a/graphics/vulkan-extension-layer/files/patch-utils_vk__loader__platform.h b/graphics/vulkan-extension-layer/files/patch-utils_vk__loader__platform.h
new file mode 100644
index 000000000000..2f1cc369d485
--- /dev/null
+++ b/graphics/vulkan-extension-layer/files/patch-utils_vk__loader__platform.h
@@ -0,0 +1,11 @@
+--- utils/vk_loader_platform.h.orig 2021-07-21 20:54:27 UTC
++++ utils/vk_loader_platform.h
+@@ -33,7 +33,7 @@
+ #undef NOMINMAX
+ #include "vulkan/vk_sdk_platform.h"
+
+-#if defined(__linux__) || defined(__APPLE__)
++#if defined(__unix__) || defined(__APPLE__)
+ /* Linux-specific common code: */
+
+ // Headers:
diff --git a/graphics/vulkan-extension-layer/pkg-descr b/graphics/vulkan-extension-layer/pkg-descr
new file mode 100644
index 000000000000..202eaa5b3643
--- /dev/null
+++ b/graphics/vulkan-extension-layer/pkg-descr
@@ -0,0 +1,7 @@
+There are some extensions and features in Vulkan that are not
+available everywhere due to various reasons. While not available, some
+extensions are capable of being done as layer and mapping to any
+Vulkan implementation regardless of it supporting the desired
+functionality or not.
+
+WWW: https://github.com/KhronosGroup/Vulkan-ValidationLayers
diff --git a/graphics/vulkan-extension-layer/pkg-plist b/graphics/vulkan-extension-layer/pkg-plist
new file mode 100644
index 000000000000..24f41e7b4407
--- /dev/null
+++ b/graphics/vulkan-extension-layer/pkg-plist
@@ -0,0 +1,5 @@
+lib/libVkExtLayer_utils.a
+lib/libVkLayer_khronos_synchronization2.so
+lib/libVkLayer_khronos_timeline_semaphore.so
+share/vulkan/explicit_layer.d/VkLayer_khronos_synchronization2.json
+share/vulkan/explicit_layer.d/VkLayer_khronos_timeline_semaphore.json