aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:37 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:37 +0000
commit661b4e14b6d2eb63e55a2d4a6a76f68906229302 (patch)
treea52b82c3df998cffc999126af0657e97df43b1a3 /graphics
parent0af63d0fcef2fc10697f4b12e03ef98326b2d7e4 (diff)
downloadports-661b4e14b6d2eb63e55a2d4a6a76f68906229302.tar.gz
ports-661b4e14b6d2eb63e55a2d4a6a76f68906229302.zip
graphics/py-h3: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-h3/Makefile7
-rw-r--r--graphics/py-h3/files/patch-pyproject.toml8
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
index 06947694e389..d2553bcdfb6d 100644
--- a/graphics/py-h3/Makefile
+++ b/graphics/py-h3/Makefile
@@ -1,5 +1,6 @@
PORTNAME= h3
PORTVERSION= 3.7.7
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,12 +15,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= cmake:devel/cmake-core \
h3>=3.7.2:graphics/h3 \
- ${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libh3.so:graphics/h3
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
USES= localbase:ldflags ninja:build python
-USE_PYTHON= autoplist concurrent cython distutils pytest
+USE_PYTHON= autoplist concurrent cython pep517 pytest
CFLAGS+= -I${LOCALBASE}/include/h3
TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR} ${PYTHON_CMD}
diff --git a/graphics/py-h3/files/patch-pyproject.toml b/graphics/py-h3/files/patch-pyproject.toml
new file mode 100644
index 000000000000..52147e92455e
--- /dev/null
+++ b/graphics/py-h3/files/patch-pyproject.toml
@@ -0,0 +1,8 @@
+--- pyproject.toml.orig 2024-03-09 18:55:18 UTC
++++ pyproject.toml
+@@ -2,5 +2,4 @@ requires = [
+ requires = [
+ 'scikit-build',
+ 'cython',
+- 'cmake',
+ ]