aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2017-11-25 20:43:39 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2017-11-25 20:43:39 +0000
commit6f93e882b2a25ba2038f0f622765cb2158383e21 (patch)
tree1c39665f16f5c8ee6a3596e15350038f8f38cbc6 /graphics
parent1d3e38688318ce112a430600afdb2832348d3f42 (diff)
downloadports-6f93e882b2a25ba2038f0f622765cb2158383e21.tar.gz
ports-6f93e882b2a25ba2038f0f622765cb2158383e21.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kf5-kimageformats/Makefile11
-rw-r--r--graphics/kf5-kimageformats/pkg-plist4
-rw-r--r--graphics/krita/Makefile11
-rw-r--r--graphics/krita/pkg-plist8
4 files changed, 22 insertions, 12 deletions
diff --git a/graphics/kf5-kimageformats/Makefile b/graphics/kf5-kimageformats/Makefile
index b28a46d23c89..4d373f80bcca 100644
--- a/graphics/kf5-kimageformats/Makefile
+++ b/graphics/kf5-kimageformats/Makefile
@@ -2,16 +2,23 @@
PORTNAME= kimageformats
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 library providing support for additional image formats
-LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
- libHalf.so:graphics/ilmbase
+LIB_DEPENDS= libHalf.so:graphics/ilmbase
USES= cmake:outsource compiler:c++11-lib kde:5 pkgconfig tar:xz
USE_KDE= archive ecm
USE_QT5= buildtools_build core gui printsupport qmake_build widgets
+OPTIONS_DEFINE= OPENEXR
+OPTIONS_DEFAULT= OPENEXR
+OPTIONS_SUB= yes
+
+OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR
+OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
+
.include <bsd.port.mk>
diff --git a/graphics/kf5-kimageformats/pkg-plist b/graphics/kf5-kimageformats/pkg-plist
index 189ba7a2346b..991b4917d960 100644
--- a/graphics/kf5-kimageformats/pkg-plist
+++ b/graphics/kf5-kimageformats/pkg-plist
@@ -1,5 +1,5 @@
%%QT_PLUGINDIR%%/imageformats/kimg_eps.so
-%%QT_PLUGINDIR%%/imageformats/kimg_exr.so
+%%OPENEXR%%%%QT_PLUGINDIR%%/imageformats/kimg_exr.so
%%QT_PLUGINDIR%%/imageformats/kimg_kra.so
%%QT_PLUGINDIR%%/imageformats/kimg_ora.so
%%QT_PLUGINDIR%%/imageformats/kimg_pcx.so
@@ -11,7 +11,7 @@
%%QT_PLUGINDIR%%/imageformats/kimg_xcf.so
share/kservices5/qimageioplugins/dds.desktop
share/kservices5/qimageioplugins/eps.desktop
-share/kservices5/qimageioplugins/exr.desktop
+%%OPENEXR%%share/kservices5/qimageioplugins/exr.desktop
share/kservices5/qimageioplugins/jp2.desktop
share/kservices5/qimageioplugins/kra.desktop
share/kservices5/qimageioplugins/ora.desktop
diff --git a/graphics/krita/Makefile b/graphics/krita/Makefile
index 6d1c5084a954..9d5a7635d344 100644
--- a/graphics/krita/Makefile
+++ b/graphics/krita/Makefile
@@ -2,7 +2,7 @@
PORTNAME= krita
PORTVERSION= 3.1.2.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/3.1.2
DIST_SUBDIR= KDE/${PORTNAME}
@@ -14,8 +14,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
-LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
- libImath.so:graphics/ilmbase \
+LIB_DEPENDS= libImath.so:graphics/ilmbase \
libOpenColorIO.so:graphics/opencolorio \
libX11.so:x11/libX11 \
libboost_system.so:devel/boost-libs \
@@ -39,12 +38,16 @@ USE_QT5= buildtools_build concurrent core dbus gui network printsupport \
qmake_build quick svg testlib widgets x11extras xml
USE_XORG= ice sm xcb xext xi
-OPTIONS_DEFINE= GMIC
+OPTIONS_DEFINE= GMIC OPENEXR
+OPTIONS_DEFAULT= OPENEXR
OPTIONS_SUB= yes
GMIC_DESC= Build the G'Mic plugin
GMIC_CMAKE_BOOL= WITH_GMIC
+OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR
+OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
+
CONFLICTS_INSTALL= calligra-2*
PLIST_SUB+= SHLIB_VER=16.0.0 \
diff --git a/graphics/krita/pkg-plist b/graphics/krita/pkg-plist
index b0b49e630965..e4d4af0a1be4 100644
--- a/graphics/krita/pkg-plist
+++ b/graphics/krita/pkg-plist
@@ -45,8 +45,8 @@ lib/kritaplugins/kritadynapaintop.so
lib/kritaplugins/kritaembossfilter.so
lib/kritaplugins/kritaexample.so
lib/kritaplugins/kritaexperimentpaintop.so
-lib/kritaplugins/kritaexrexport.so
-lib/kritaplugins/kritaexrimport.so
+%%OPENEXR%%lib/kritaplugins/kritaexrexport.so
+%%OPENEXR%%lib/kritaplugins/kritaexrimport.so
lib/kritaplugins/kritaextensioncolorsfilters.so
lib/kritaplugins/kritafastcolortransferfilter.so
lib/kritaplugins/kritafilterop.so
@@ -203,7 +203,7 @@ lib/libkritawidgetutils.so.%%SHLIB_VER%%
share/applications/krita_bmp.desktop
share/applications/krita_brush.desktop
share/applications/krita_csv.desktop
-share/applications/krita_exr.desktop
+%%OPENEXR%%share/applications/krita_exr.desktop
share/applications/krita_heightmap.desktop
share/applications/krita_jpeg.desktop
share/applications/krita_odg.desktop
@@ -516,7 +516,7 @@ share/icons/hicolor/scalable/apps/calligrakrita.svgz
%%DATADIR%%/input/tabletpro.profile
%%DATADIR%%/metadata/schemas/dc.schema
%%DATADIR%%/metadata/schemas/exif.schema
-%%DATADIR%%/metadata/schemas/exrchannels.schema
+%%OPENEXR%%%%DATADIR%%/metadata/schemas/exrchannels.schema
%%DATADIR%%/metadata/schemas/mkn.schema
%%DATADIR%%/metadata/schemas/tiff.schema
%%DATADIR%%/metadata/schemas/xmp.schema