aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-12 08:19:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-12 08:19:18 +0000
commit796966c32d1d481f3b3dc56aad867ae0f93273e8 (patch)
tree18f369da59351747981478bc4032c46851fb99ac /graphics
parentc27b1d8bb2eeba9db2e803a4c3e5e050336d2c49 (diff)
downloadports-796966c32d1d481f3b3dc56aad867ae0f93273e8.tar.gz
ports-796966c32d1d481f3b3dc56aad867ae0f93273e8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/avir/Makefile29
-rw-r--r--graphics/avir/distinfo3
-rw-r--r--graphics/avir/pkg-descr9
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 88817b545b31..34cac4796797 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -60,6 +60,7 @@
SUBDIR += autopano-sift-c
SUBDIR += autotrace
SUBDIR += aview
+ SUBDIR += avir
SUBDIR += azpainter
SUBDIR += backfract
SUBDIR += barbecue
diff --git a/graphics/avir/Makefile b/graphics/avir/Makefile
new file mode 100644
index 000000000000..b428211a03b3
--- /dev/null
+++ b/graphics/avir/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= avir
+DISTVERSION= 2.4
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= High-quality image resizing/scaling C++ library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= avaneev
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/avir/avir.h \
+ include/avir/avir_dil.h \
+ include/avir/avir_float4_sse.h \
+ include/avir/avir_float8_avx.h \
+ include/avir/lancir.h
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/avir
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${STAGEDIR}${PREFIX}/include/avir/
+
+.include <bsd.port.mk>
diff --git a/graphics/avir/distinfo b/graphics/avir/distinfo
new file mode 100644
index 000000000000..5598d2bea7d4
--- /dev/null
+++ b/graphics/avir/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570867160
+SHA256 (avaneev-avir-2.4_GH0.tar.gz) = 0b6f13f715a1b9d6336c60b7753b9dbb48493813807367e91efe6adb11c0835d
+SIZE (avaneev-avir-2.4_GH0.tar.gz) = 2834974
diff --git a/graphics/avir/pkg-descr b/graphics/avir/pkg-descr
new file mode 100644
index 000000000000..f92bb50c4e48
--- /dev/null
+++ b/graphics/avir/pkg-descr
@@ -0,0 +1,9 @@
+High-quality pro image resizing / scaling C++ library, image resize.
+
+This library features routines for both down- and upsizing of 8- and 16-bit,
+1 to 4-channel images. Image resizing routines were implemented in
+multi-platform C++ code, and have a high level of optimality. Beside resizing,
+this library offers a sub-pixel shift operation. Built-in sRGB gamma correction
+is available.
+
+WWW: https://github.com/avaneev/avir