aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-11-06 13:27:16 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-11-06 13:27:16 +0000
commit7d12c1c7d398d7ba943d21552480ff21a4fbf8c8 (patch)
treee0f631d7ad628b5af43bd401cdbce92ed6039e8a /graphics
parent8d525b3e14beaa1fdfe8898d163c6f3fc3f1b25c (diff)
downloadports-7d12c1c7d398d7ba943d21552480ff21a4fbf8c8.tar.gz
ports-7d12c1c7d398d7ba943d21552480ff21a4fbf8c8.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/goom/Makefile37
-rw-r--r--graphics/goom/files/patch-src_mmx.h (renamed from graphics/goom/files/patch-src-mmx.h)2
-rw-r--r--graphics/goom/pkg-plist1
3 files changed, 17 insertions, 23 deletions
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index 1996ecb5d4ba..f3ef43db28a0 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= goom
PORTVERSION= 2k4.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}2k4/0
DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|}-src
@@ -11,33 +11,26 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|-|}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Visual effects library
+LICENSE= LGPL20
+
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S|.|-|}
-USES= pathfix libtool
+USES= pathfix libtool localbase
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-sdltest --enable-static
+CONFIGURE_ENV= ac_cv_path_SDL_CONFIG="no"
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-.if exists(${X11R6}/bin/xmms) || defined(WITH_XMMS)
-LIB_DEPENDS+= libxmms.so:multimedia/xmms
-PLIST_SUB+= XMMS=""
-.else
-PLIST_SUB+= XMMS="@comment "
-.endif
-
-pre-everything::
-.if !defined(WITH_XMMS)
- @${ECHO} ""
- @${ECHO} "Define WITH_XMMS to build goom xmms visualization plugin"
- @${ECHO} ""
-.endif
+BROKEN_powerpc= Does not build
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= XMMS
+OPTIONS_SUB= yes
-.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
-.endif
+XMMS_DESC= Build XMMS visualization plugin
+XMMS_LIB_DEPENDS= libxmms.so:multimedia/xmms
+XMMS_USES= gettext-runtime
+XMMS_USE= GNOME=glib12,gtk12 \
+ XORG=x11,xext,xi
+XMMS_CONFIGURE_ENV_OFF= ac_cv_path_XMMS_CONFIG="no"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/goom/files/patch-src-mmx.h b/graphics/goom/files/patch-src_mmx.h
index 3c174c604f24..16a8568e98b1 100644
--- a/graphics/goom/files/patch-src-mmx.h
+++ b/graphics/goom/files/patch-src_mmx.h
@@ -1,4 +1,4 @@
---- src/mmx.h.orig
+--- src/mmx.h.orig 2005-02-07 13:46:41 UTC
+++ src/mmx.h
@@ -715,13 +715,13 @@ void zoom_filter_xmmx (int prevX, int pr
{ \
diff --git a/graphics/goom/pkg-plist b/graphics/goom/pkg-plist
index 13e8b9574d11..c78654eb2b32 100644
--- a/graphics/goom/pkg-plist
+++ b/graphics/goom/pkg-plist
@@ -15,4 +15,5 @@ lib/libgoom2.so
lib/libgoom2.so.0
lib/libgoom2.so.0.0.0
libdata/pkgconfig/libgoom2.pc
+%%XMMS%%lib/xmms/Visualization/libxmmsgoom2.a
%%XMMS%%lib/xmms/Visualization/libxmmsgoom2.so