aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-25 18:33:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-25 18:33:44 +0000
commit7ea323c3bd49eba5d813b2cca2ddbf1655df0d49 (patch)
treec7f8ac555dbb8bf6cf331644594c65cfd8667a66 /graphics
parent04fe1b9af906b00d2d49103f2803187af758ba8e (diff)
downloadports-7ea323c3bd49eba5d813b2cca2ddbf1655df0d49.tar.gz
ports-7ea323c3bd49eba5d813b2cca2ddbf1655df0d49.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gpsmanshp/Makefile9
-rw-r--r--graphics/gpsmanshp/files/patch-Makefile5
2 files changed, 7 insertions, 7 deletions
diff --git a/graphics/gpsmanshp/Makefile b/graphics/gpsmanshp/Makefile
index 91a254d8e021..141dd1ab294c 100644
--- a/graphics/gpsmanshp/Makefile
+++ b/graphics/gpsmanshp/Makefile
@@ -19,11 +19,10 @@ LIB_DEPENDS= libshp.so:${PORTSDIR}/devel/shapelib \
TCLVERSION?= 8.4
PLIST_SUB= TCLVERSION=${TCLVERSION} PORTVERSION=${PORTVERSION}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/* ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/graphics/gpsmanshp/files/patch-Makefile b/graphics/gpsmanshp/files/patch-Makefile
index 7143f30b372f..bbd92634ba82 100644
--- a/graphics/gpsmanshp/files/patch-Makefile
+++ b/graphics/gpsmanshp/files/patch-Makefile
@@ -7,7 +7,7 @@
+TCLLVERSION = 84
-INSTALLDIR = /usr/lib/tcl$(TCLVERSION)
-+INSTALLDIR = ${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION)
++INSTALLDIR = ${DESTDIR}${PREFIX}/lib/tcl$(TCLVERSION)/gpsmanshp-$(VERSION)
-CFLAGS = -Wall -fPIC -c -I/usr/include/tcl$(TCLVERSION)
-LINKOPT = -lshp -ltcl$(TCLVERSION)
@@ -28,8 +28,9 @@
chmod 644 gpsmanshp.so pkgIndex.tcl
install: pkgIndex.tcl
- -mkdir $(INSTALLDIR)
+- -mkdir $(INSTALLDIR)
- cp gpsmanshp.so pkgIndex.tcl $(INSTALLDIR)
++ -mkdir -p $(INSTALLDIR)
+ install -c -s -m 555 -o root -g wheel gpsmanshp.so $(INSTALLDIR)/
+ install -c -m 555 -o root -g wheel pkgIndex.tcl $(INSTALLDIR)/