aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:01:39 +0000
commit83e363f9bc01be0f51798f4af3e6da410de4edc0 (patch)
tree85502bd77c982865fd85669228b6881df7efbea8 /graphics
parent12248c689872d086cc1374376bb8a7d24e8200bb (diff)
downloadports-83e363f9bc01be0f51798f4af3e6da410de4edc0.tar.gz
ports-83e363f9bc01be0f51798f4af3e6da410de4edc0.zip
graphics/py-imageio: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-imageio/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/py-imageio/Makefile b/graphics/py-imageio/Makefile
index 209d63f81b94..0737f75d033a 100644
--- a/graphics/py-imageio/Makefile
+++ b/graphics/py-imageio/Makefile
@@ -1,6 +1,6 @@
PORTNAME= imageio
PORTVERSION= 2.34.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= PYPI \
https://github.com/imageio/imageio/releases/download/v${PORTVERSION}/
@@ -14,7 +14,8 @@ WWW= https://imageio.readthedocs.io/en/stable/ \
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-# Note: www/py-requests comes from devel/py-fsspec[github]
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libfreeimage.so:graphics/freeimage
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=8.3.2:graphics/py-pillow@${PY_FLAVOR}
@@ -24,11 +25,12 @@ TEST_DEPENDS= opencv>=0:graphics/opencv \
${PYTHON_PKGNAMEPREFIX}gdal>=0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fsspec>=0:devel/py-fsspec@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tifffile>=0:graphics/py-tifffile@${PY_FLAVOR}
+# devel/py-fsspec[github]
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes