aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2015-01-19 20:32:52 +0000
committerCy Schubert <cy@FreeBSD.org>2015-01-19 20:32:52 +0000
commit85d168ab7e88ffb490342d416bd3a38162e9f8cb (patch)
tree715fa4c778fb374a81ea8272a7654776bc419cee /graphics
parentfad54c1a7e6244a9628caaa3a22d60d7584efcd0 (diff)
downloadports-85d168ab7e88ffb490342d416bd3a38162e9f8cb.tar.gz
ports-85d168ab7e88ffb490342d416bd3a38162e9f8cb.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpdf/Makefile9
-rw-r--r--graphics/xpdf/distinfo6
-rw-r--r--graphics/xpdf/files/patch-gmem95
-rw-r--r--graphics/xpdf/files/patch-splash_Makefile.in7
-rw-r--r--graphics/xpdf/files/patch-xpdf_Makefile.in10
5 files changed, 10 insertions, 117 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index 7e49518f1c00..236281689abf 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -1,12 +1,11 @@
# $FreeBSD$
PORTNAME= xpdf
-PORTVERSION= 3.03
-PORTREVISION= 6
+PORTVERSION= 3.04
CATEGORIES= graphics print
-MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
+MASTER_SITES= http://mirrors.rit.edu/zi/ \
+ ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN} \
- http://mirrors.rit.edu/zi/ \
http://komquats.com/distfiles/
MASTER_SITE_SUBDIR= support/xpdf
@@ -17,7 +16,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
GNU_CONFIGURE= yes
USES= gmake
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -O0
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-opi \
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf/distinfo
index 6e12a2345c66..8e5c949df70a 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf/distinfo
@@ -1,4 +1,2 @@
-SHA256 (xpdf-3.03.tar.gz) = 02cf63d8f6326eda644096cd0f969e1588702ad87222c1e9388a93c270fbceca
-SIZE (xpdf-3.03.tar.gz) = 795537
-SHA256 (patch-zz-xpdf-annot.20080728a) = c96308c0fb90450251a6f8a19b5436a5fd5d70b4d6af2626ba85d3c4b7300fe1
-SIZE (patch-zz-xpdf-annot.20080728a) = 69092
+SHA256 (xpdf-3.04.tar.gz) = 11390c74733abcb262aaca4db68710f13ffffd42bfe2a0861a5dfc912b2977e5
+SIZE (xpdf-3.04.tar.gz) = 825519
diff --git a/graphics/xpdf/files/patch-gmem b/graphics/xpdf/files/patch-gmem
deleted file mode 100644
index 46634281cd2b..000000000000
--- a/graphics/xpdf/files/patch-gmem
+++ /dev/null
@@ -1,95 +0,0 @@
---- goo/gmem.cc.orig Tue Feb 27 14:05:51 2007
-+++ goo/gmem.cc
-@@ -47,9 +47,9 @@
-
- #endif /* DEBUG_MEM */
-
--void *gmalloc(int size) GMEM_EXCEP {
-+void *gmalloc(size_t size) GMEM_EXCEP {
- #ifdef DEBUG_MEM
-- int size1;
-+ size_t size1;
- char *mem;
- GMemHdr *hdr;
- void *data;
-@@ -106,11 +106,11 @@
- #endif
- }
-
--void *grealloc(void *p, int size) GMEM_EXCEP {
-+void *grealloc(void *p, size_t size) GMEM_EXCEP {
- #ifdef DEBUG_MEM
- GMemHdr *hdr;
- void *q;
-- int oldSize;
-+ size_t oldSize;
-
- if (size <= 0) {
- if (p) {
-@@ -154,14 +154,14 @@
- #endif
- }
-
--void *gmallocn(int nObjs, int objSize) GMEM_EXCEP {
-- int n;
-+void *gmallocn(int nObjs, size_t objSize) GMEM_EXCEP {
-+ size_t n;
-
- if (nObjs == 0) {
- return NULL;
- }
- n = nObjs * objSize;
-- if (objSize <= 0 || nObjs < 0 || nObjs >= INT_MAX / objSize) {
-+ if (objSize == 0u || nObjs < 0 || (size_t)nObjs >= INT_MAX / objSize) {
- #if USE_EXCEPTIONS
- throw GMemException();
- #else
-@@ -172,8 +172,8 @@
- return gmalloc(n);
- }
-
--void *greallocn(void *p, int nObjs, int objSize) GMEM_EXCEP {
-- int n;
-+void *greallocn(void *p, int nObjs, size_t objSize) GMEM_EXCEP {
-+ size_t n;
-
- if (nObjs == 0) {
- if (p) {
-@@ -182,7 +182,7 @@
- return NULL;
- }
- n = nObjs * objSize;
-- if (objSize <= 0 || nObjs < 0 || nObjs >= INT_MAX / objSize) {
-+ if (objSize == 0u || nObjs < 0 || (size_t)nObjs >= INT_MAX / objSize) {
- #if USE_EXCEPTIONS
- throw GMemException();
- #else
---- goo/gmem.h.orig Tue Feb 27 14:05:51 2007
-+++ goo/gmem.h
-@@ -36,13 +36,13 @@
- * Same as malloc, but prints error message and exits if malloc()
- * returns NULL.
- */
--extern void *gmalloc(int size) GMEM_EXCEP;
-+extern void *gmalloc(size_t size) GMEM_EXCEP;
-
- /*
- * Same as realloc, but prints error message and exits if realloc()
- * returns NULL. If <p> is NULL, calls malloc instead of realloc().
- */
--extern void *grealloc(void *p, int size) GMEM_EXCEP;
-+extern void *grealloc(void *p, size_t size) GMEM_EXCEP;
-
- /*
- * These are similar to gmalloc and grealloc, but take an object count
-@@ -50,8 +50,8 @@
- * bytes, but there is an additional error check that the total size
- * doesn't overflow an int.
- */
--extern void *gmallocn(int nObjs, int objSize) GMEM_EXCEP;
--extern void *greallocn(void *p, int nObjs, int objSize) GMEM_EXCEP;
-+extern void *gmallocn(int nObjs, size_t objSize) GMEM_EXCEP;
-+extern void *greallocn(void *p, int nObjs, size_t objSize) GMEM_EXCEP;
-
- /*
- * Same as free, but checks for and ignores NULL pointers.
diff --git a/graphics/xpdf/files/patch-splash_Makefile.in b/graphics/xpdf/files/patch-splash_Makefile.in
index 2fbaccffa377..280cadcca468 100644
--- a/graphics/xpdf/files/patch-splash_Makefile.in
+++ b/graphics/xpdf/files/patch-splash_Makefile.in
@@ -1,10 +1,11 @@
-Index: splash/Makefile.in
+--- splash/Makefile.in.orig 2014-05-28 11:50:50.000000000 -0700
++++ splash/Makefile.in 2014-12-20 18:20:37.776117864 -0800
@@ -16,7 +16,7 @@
FOFISRCDIR = $(srcdir)/../fofi
FOFILIBDIR = ../fofi
--CXXFLAGS = @CXXFLAGS@ @DEFS@ -I.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir) @t1_CFLAGS@ @freetype2_CFLAGS@
-+CXXFLAGS = @CXXFLAGS@ @DEFS@ -I.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir) @t1_CFLAGS@ @freetype2_CFLAGS@ @X_CFLAGS@
+-CXXFLAGS = @CXXFLAGS@ @DEFS@ -I.. -I$(srcdir)/.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir) @freetype2_CFLAGS@
++CXXFLAGS = @CXXFLAGS@ @DEFS@ -I.. -I$(srcdir)/.. -I$(GOOSRCDIR) -I$(FOFISRCDIR) -I$(srcdir) @freetype2_CFLAGS@ @X_CFLAGS@
CXX = @CXX@
AR = @AR@
diff --git a/graphics/xpdf/files/patch-xpdf_Makefile.in b/graphics/xpdf/files/patch-xpdf_Makefile.in
deleted file mode 100644
index f9ad7c80f812..000000000000
--- a/graphics/xpdf/files/patch-xpdf_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: xpdf/Makefile.in
-@@ -112,7 +112,7 @@
- pdffonts$(EXE) pdfdetach$(EXE) pdftoppm$(EXE) pdfimages$(EXE)
-
- all-no-x: pdftops$(EXE) pdftotext$(EXE) pdfinfo$(EXE) pdffonts$(EXE) \
-- pdfdetach$(EXE) pdfimages$(EXE)
-+ pdfdetach$(EXE) pdftoppm$(EXE) pdfimages$(EXE)
-
- #------------------------------------------------------------------------
-