aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
committerRene Ladan <rene@FreeBSD.org>2018-11-02 13:32:34 +0000
commit8a502cb2d43b4059a5678ee4539ca03603104107 (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /graphics
parentf60d4bacdc58ec061406d72cace1ac1266952e39 (diff)
downloadports-8a502cb2d43b4059a5678ee4539ca03603104107.tar.gz
ports-8a502cb2d43b4059a5678ee4539ca03603104107.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/blender-doc/Makefile11
-rw-r--r--graphics/cloudcompare/Makefile1
-rw-r--r--graphics/drm-kmod/Makefile4
-rw-r--r--graphics/drm-next-kmod/Makefile3
-rw-r--r--graphics/drm-stable-kmod/Makefile3
-rw-r--r--graphics/dspdfviewer/Makefile4
-rw-r--r--graphics/giflib/Makefile4
-rw-r--r--graphics/giflib/files/extra-patch-hide-reallocarray24
-rw-r--r--graphics/gimp-app/pkg-message7
-rw-r--r--graphics/glfw/Makefile1
-rw-r--r--graphics/gpu-firmware-kmod/Makefile3
-rw-r--r--graphics/graphviz/Makefile2
12 files changed, 2 insertions, 65 deletions
diff --git a/graphics/blender-doc/Makefile b/graphics/blender-doc/Makefile
index c44875c3e828..28e88e5d0326 100644
--- a/graphics/blender-doc/Makefile
+++ b/graphics/blender-doc/Makefile
@@ -17,15 +17,6 @@ NO_ARCH= yes
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100077
-post-extract:
-# chmod -R bug.
-# Do not use "-exec ... +", because of the same bug, it will not work.
- @${FIND} ${WRKSRC} -type d -exec ${CHMOD} 755 {} \;
-.endif
-
pre-patch:
@cd ${WRKSRC}/htmlI/PartAT/volumetrics/gfx/ && \
${RM} -r "Nuova cartella" "Nuova cartella (2)"
@@ -34,4 +25,4 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} "htmlI htmlII" ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/cloudcompare/Makefile b/graphics/cloudcompare/Makefile
index 689c838d4052..4cdaccddc402 100644
--- a/graphics/cloudcompare/Makefile
+++ b/graphics/cloudcompare/Makefile
@@ -13,7 +13,6 @@ COMMENT= 3D point cloud processing software
LICENSE= GPLv2+ LGPL20+
LICENSE_COMB= multi
-BROKEN_FreeBSD_10= error: "SSE instruction set not enabled"
BROKEN_aarch64= fails to compile: mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'?
USES= cmake:outsource localbase:ldflags qt:5
diff --git a/graphics/drm-kmod/Makefile b/graphics/drm-kmod/Makefile
index 7bbd2a0a162a..aec438abb4c3 100644
--- a/graphics/drm-kmod/Makefile
+++ b/graphics/drm-kmod/Makefile
@@ -22,9 +22,7 @@ RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-legacy-kmod
IGNORE= legacy kmod not required on less than 12.0
.endif
.else
-.if ${OSVERSION} < 1101510
-IGNORE= not supported on 11.1 or older, no kernel support
-.elif ${OSVERSION} >= 1101510 && ${OSVERSION} < 1200000
+.if ${OSVERSION} >= 1101510 && ${OSVERSION} < 1200000
RUN_DEPENDS= ${KMODDIR}/drm.ko:graphics/drm-stable-kmod
.elif ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
IGNORE= not supported on older 12, no kernel support
diff --git a/graphics/drm-next-kmod/Makefile b/graphics/drm-next-kmod/Makefile
index 2295715fcaec..45439f30f314 100644
--- a/graphics/drm-next-kmod/Makefile
+++ b/graphics/drm-next-kmod/Makefile
@@ -29,9 +29,6 @@ GH_TAGNAME= b545cc4
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101511
-IGNORE= not supported on 11.1 or older, no kernel support
-.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200058
IGNORE= not supported on older CURRENT, no kernel support
.endif
diff --git a/graphics/drm-stable-kmod/Makefile b/graphics/drm-stable-kmod/Makefile
index c07e23c549cc..d00b0a144c1e 100644
--- a/graphics/drm-stable-kmod/Makefile
+++ b/graphics/drm-stable-kmod/Makefile
@@ -29,9 +29,6 @@ GH_TAGNAME= ef4d156
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101510
-IGNORE= not supported on 11.1 or older, no kernel support
-.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200045
IGNORE= not supported on older CURRENT, no kernel support
.endif
diff --git a/graphics/dspdfviewer/Makefile b/graphics/dspdfviewer/Makefile
index 463878caa679..5cc6d2fda15f 100644
--- a/graphics/dspdfviewer/Makefile
+++ b/graphics/dspdfviewer/Makefile
@@ -35,16 +35,12 @@ PLIST_FILES= bin/dspdfviewer \
# Build fails with LLVM 4.0. Reported upstream as #191:
# https://github.com/dannyedel/dspdfviewer/issues/191
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100511
CFLAGS+= -Wno-error=undefined-func-template
-.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200039
CFLAGS+= -Wno-error=zero-as-null-pointer-constant
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1102000
CFLAGS+= -Wno-error=redundant-parens
-.endif
.include <bsd.port.post.mk>
diff --git a/graphics/giflib/Makefile b/graphics/giflib/Makefile
index bd7acc7e9bb4..f433491fb562 100644
--- a/graphics/giflib/Makefile
+++ b/graphics/giflib/Makefile
@@ -35,11 +35,7 @@ CONFIGURE_ENV+= have_xmlto=no
.endif
.if ${OPSYS} == FreeBSD
-. if ${OSVERSION} >= 1100072
EXTRA_PATCHES= ${FILESDIR}/extra-patch-unbundle-reallocarray
-. else
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-hide-reallocarray
-. endif
.elif ${OPSYS} == DragonFly
EXTRA_PATCHES= ${FILESDIR}/extra-patch-hide-reallocarray-dfly
.endif
diff --git a/graphics/giflib/files/extra-patch-hide-reallocarray b/graphics/giflib/files/extra-patch-hide-reallocarray
deleted file mode 100644
index 3329a623bc8a..000000000000
--- a/graphics/giflib/files/extra-patch-hide-reallocarray
+++ /dev/null
@@ -1,24 +0,0 @@
---- lib/dgif_lib.c.orig 2016-04-02 15:34:00 UTC
-+++ lib/dgif_lib.c
-@@ -41,6 +41,9 @@ static int DGifDecompressInput(GifFileTy
- static int DGifBufferedInput(GifFileType *GifFile, GifByteType *Buf,
- GifByteType *NextByte);
-
-+extern void *
-+reallocarray(void *optr, size_t nmemb, size_t size) __hidden;
-+
- /******************************************************************************
- Open a new GIF file for read, given by its name.
- Returns dynamically allocated GifFileType pointer which serves as the GIF
---- lib/gifalloc.c.orig 2015-07-13 04:05:46 UTC
-+++ lib/gifalloc.c
-@@ -12,6 +12,9 @@
-
- #define MAX(x, y) (((x) > (y)) ? (x) : (y))
-
-+extern void *
-+reallocarray(void *optr, size_t nmemb, size_t size) __hidden;
-+
- /******************************************************************************
- Miscellaneous utility functions
- ******************************************************************************/
diff --git a/graphics/gimp-app/pkg-message b/graphics/gimp-app/pkg-message
deleted file mode 100644
index b7f8044b0baa..000000000000
--- a/graphics/gimp-app/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
-On FreeBSD 10.4 gimp can cause the following error.
-
-(script-fu:3985): LibGimp-ERROR **: shmat() failed: Invalid argument
-Could not attach to gimp shared memory segment
-
-This can be fixed by setting kern.ipc.shm_allow_removed=1 in /etc/sysctl.conf.
-FreeBSD 11.0-R and newer have this set by default.
diff --git a/graphics/glfw/Makefile b/graphics/glfw/Makefile
index 8acb17c219b9..ef623481efc4 100644
--- a/graphics/glfw/Makefile
+++ b/graphics/glfw/Makefile
@@ -26,7 +26,6 @@ OPTIONS_DEFAULT=X11
PLATFORM_DESC= Window creation platform
OPTIONS_SINGLE= PLATFORM
OPTIONS_SINGLE_PLATFORM= WAYLAND X11
-OPTIONS_EXCLUDE_FreeBSD_10= WAYLAND # needs dev/evdev/input.h
WAYLAND_BUILD_DEPENDS= wayland-protocols>=0:graphics/wayland-protocols
WAYLAND_CMAKE_BOOL= GLFW_USE_WAYLAND
diff --git a/graphics/gpu-firmware-kmod/Makefile b/graphics/gpu-firmware-kmod/Makefile
index bb1c2839821b..f04ad21e313c 100644
--- a/graphics/gpu-firmware-kmod/Makefile
+++ b/graphics/gpu-firmware-kmod/Makefile
@@ -26,9 +26,6 @@ GH_TAGNAME= da173cc
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101510
-IGNORE= not supported on 11.1 or older, no kernel support
-.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200000 && ${OSVERSION} < 1200019
IGNORE= not supported on older CURRENT, no kernel support
.endif
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 8c25d7021570..8e483d83ced3 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -255,10 +255,8 @@ post-patch:
${REINPLACE_CMD} -e 's|GTS_LIBS)|GTS_LIBS) $$(MATH_LIBS)|' \
${WRKSRC}/cmd/smyrna/Makefile.in
${CP} ${WRKSRC}/lib/cgraph/cgraph.h ${WRKSRC}/plugin/ming/
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100093
${REINPLACE_CMD} -e 's|SF_FLAGS|SFIO_FLAGS|g' \
${WRKSRC}/lib/sfio/*.[ch]
-.endif
post-patch-DOCS-off:
${REINPLACE_CMD} -e 's| install-txtDATA$$||' \