aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-14 12:48:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-14 12:48:32 +0000
commit930c79f2248a1299808f95b0e0f787bcb9187d61 (patch)
tree3ff937bf7c9b451fa30be38ff5a65b261c1c975c /graphics
parent133e0587239b8a68155abbce43746ed8d66aaaf5 (diff)
downloadports-930c79f2248a1299808f95b0e0f787bcb9187d61.tar.gz
ports-930c79f2248a1299808f95b0e0f787bcb9187d61.zip
- Allow to build with Embree intersection backend support (follow the
upstream and keep it off by default) - Add a piece of advice to pkg-message about how to help it find the fallback OSL shaders provided by the package
Notes
Notes: svn path=/head/; revision=568386
Diffstat (limited to 'graphics')
-rw-r--r--graphics/appleseed/Makefile6
-rw-r--r--graphics/appleseed/files/pkg-message.in4
2 files changed, 9 insertions, 1 deletions
diff --git a/graphics/appleseed/Makefile b/graphics/appleseed/Makefile
index ff24aacd5c85..8ac8578d135e 100644
--- a/graphics/appleseed/Makefile
+++ b/graphics/appleseed/Makefile
@@ -49,10 +49,14 @@ PLIST_SUB= APPHOME=${CMAKE_INSTALL_PREFIX}
SUB_FILES= pkg-message
SUB_LIST:= ${PLIST_SUB}
-OPTIONS_DEFINE= PYTHON STUDIO
+OPTIONS_DEFINE= EMBREE PYTHON STUDIO
OPTIONS_DEFAULT= PYTHON STUDIO
OPTIONS_SUB= yes
+EMBREE_DESC= Embree intersection backend support
+EMBREE_LIB_DEPENDS= libembree3.so:graphics/embree
+EMBREE_CMAKE_ON= -DWITH_EMBREE:BOOL=ON
+
PYTHON_USES= gl python:3.5+,build,run
PYTHON_USE= GL=gl
PYTHON_CMAKE_ON= -DWITH_PYTHON3_BINDINGS:BOOL=ON
diff --git a/graphics/appleseed/files/pkg-message.in b/graphics/appleseed/files/pkg-message.in
index 2cfd586ec48d..e0b2ebed6007 100644
--- a/graphics/appleseed/files/pkg-message.in
+++ b/graphics/appleseed/files/pkg-message.in
@@ -4,3 +4,7 @@ commands, respectively:
%%APPHOME%%/bin/appleseed.cli
%%APPHOME%%/bin/appleseed.studio
+
+Until https://github.com/appleseedhq/appleseed/issues/2520 is resolved,
+you might want to create $HOME/shaders -> %%APPHOME%%/shaders
+symlink to help it find OSL shaders.