aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-11 14:49:59 +0000
commit9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92 (patch)
treec4f78cbaf45ab044db3e157be708afd711a4e841 /graphics
parent0533abe3e7aae5c19e0a0ce9c1e82ed5e94f63e8 (diff)
downloadports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.tar.gz
ports-9f8b4bcde30c0ca3bf6cead5f48aa102536e0e92.zip
Support LIBS like LDFLAGS.
- Add LIBS="${LIBS}" to MAKE_ENV and CONFIGURE_ENV. - Add an option helper for LIBS. - Adjust all ports that already use LIBS. Also remove references to PTHREAD_CFLAGS and PTHREAD_LIBS while here. - Some ports did not support having a LIBS environment variable and required additional patches. Somewhat simplified a linker command line looks like: ${CC} ${src_LDFLAGS} ${LDFLAGS} ${src_LIBS} ${LIBS} where src_LDFLAGS and src_LIBS are controlled by upstream and LDFLAGS and LIBS can be controlled by us. If possible -L and -l flags need to be added to LIBS to make sure they appear after any -L and -l flags set by upstream. Many ports currently add -L${LOCALBASE}/lib to LDFLAGS but this may appear too early on the command line causing installed libraries to be linked in instead of freshly built ones. Additional changes: benchmarks/netio: Replace WITH_IPV6 with an IPV6 option. comms/gnokii: Replace some patches with USES=pathfix. Also remove -fPIC. graphics/gimageview: USES=libtool and install desktop file in DESKTOPDIR. graphics/visionworkbench: Remove FreeBSD 7 support. multimedia/libmovtar: New LIB_DEPENDS syntax. multimedia/opencinematools: Use standard do-build. net/siproxd: USES=libtool:keepla (port actually needs .la files for plugins) net-mgmt/nagios: Remove -fPIC. net-mgmt/nagios4: Remove -fPIC. print/cups-base: Only add -lssp_nonshared on i386 and OSVERSION < 1000036. security/p11-kit: Replace PTHREAD_LIBS in CONFIGURE_ENV with ac_cv_func_pthread_mutexattr_init=no in CONFIGURE_ARGS. This skips a test in configure that falsely detects pthread_mutexattr_init in our libc. sysutils/dar: Fix iconv detection. x11/rxvt-unicode: Remove -lstdc++ and patch configure to remove a FreeBSD hack and use $CXX as linker as on other platforms. PR: 190592 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=357486
Diffstat (limited to 'graphics')
-rw-r--r--graphics/EZWGL/Makefile2
-rw-r--r--graphics/bugle/Makefile3
-rw-r--r--graphics/colord/Makefile5
-rw-r--r--graphics/danpei/Makefile2
-rw-r--r--graphics/enblend/Makefile3
-rw-r--r--graphics/epeg/Makefile2
-rw-r--r--graphics/flam3/Makefile4
-rw-r--r--graphics/gcolor/Makefile2
-rw-r--r--graphics/gimageview/Makefile28
-rw-r--r--graphics/gimageview/files/patch-ltmain.sh25
-rw-r--r--graphics/gimageview/pkg-plist4
-rw-r--r--graphics/gimp-app/Makefile5
-rw-r--r--graphics/gimp-resynthesizer/Makefile2
-rw-r--r--graphics/gle/Makefile2
-rw-r--r--graphics/gltt/Makefile2
-rw-r--r--graphics/gphoto2/Makefile3
-rw-r--r--graphics/gtkgraph/Makefile2
-rw-r--r--graphics/jpeginfo/Makefile2
-rw-r--r--graphics/kudu/Makefile4
-rw-r--r--graphics/libvisual/Makefile4
-rw-r--r--graphics/libvisual04-plugins/Makefile2
-rw-r--r--graphics/php-facedetect/Makefile6
-rw-r--r--graphics/phplot/Makefile4
-rw-r--r--graphics/pngnq/Makefile3
-rw-r--r--graphics/povray37/Makefile15
-rw-r--r--graphics/radius-engine/Makefile4
-rw-r--r--graphics/stamp/Makefile2
-rw-r--r--graphics/tesseract/Makefile5
-rw-r--r--graphics/visionworkbench/Makefile19
-rw-r--r--graphics/xaos/Makefile10
-rw-r--r--graphics/xsane/Makefile5
-rw-r--r--graphics/zphoto/Makefile5
32 files changed, 56 insertions, 130 deletions
diff --git a/graphics/EZWGL/Makefile b/graphics/EZWGL/Makefile
index 87e1b375c8bc..5c9154ea7c84 100644
--- a/graphics/EZWGL/Makefile
+++ b/graphics/EZWGL/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_XORG= x11 xext
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LIBS+= -L${LOCALBASE}/lib
NOPRECIOUSMAKEVARS= yes # Otherwise 'make readmes' is broken
NO_STAGE= yes
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 796557d27075..e62d2bd3536d 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -20,9 +20,8 @@ USE_AUTOTOOLS= libltdl
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
CONFIGURE_ARGS=--enable-ltdl-install=no
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
- GL_LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
MAN1= gldb.1 gldb-gui.1
MAN3= bugle.3
diff --git a/graphics/colord/Makefile b/graphics/colord/Makefile
index 976bd28a2a42..5be1664c5100 100644
--- a/graphics/colord/Makefile
+++ b/graphics/colord/Makefile
@@ -34,9 +34,8 @@ CONFIGURE_ARGS= --disable-gudev \
# takes ages we don't want to wait.
CONFIGURE_ARGS+=--disable-print-profiles
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= USB_CFLAGS="-I/usr/include" \
- USB_LIBS="-L/usr/lib -lusb"
+LIBS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= USB_CFLAGS=" " USB_LIBS="-lusb"
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.freedesktop.ColorHelper.gschema.xml
diff --git a/graphics/danpei/Makefile b/graphics/danpei/Makefile
index b7b74454f254..e6695aa6d964 100644
--- a/graphics/danpei/Makefile
+++ b/graphics/danpei/Makefile
@@ -22,8 +22,8 @@ IMAGEMAGICK_RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
USES= gettext
USE_GNOME= gtk12 gdkpixbuf
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --without-included-gettext
PLIST_FILES= bin/danpei \
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 0e030b2adbcc..a968d57d4ca5 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -30,10 +30,9 @@ CONFIGURE_ARGS= MAKEINFO="${LOCALBASE}/bin/makeinfo"
USE_GL= glew glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= "LIBS=-lboost_system"
CONFIGURE_ARGS+= --with-boost-filesystem
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lboost_system
.include <bsd.port.pre.mk>
diff --git a/graphics/epeg/Makefile b/graphics/epeg/Makefile
index 141912e2f070..f4c3b07bae07 100644
--- a/graphics/epeg/Makefile
+++ b/graphics/epeg/Makefile
@@ -18,7 +18,7 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USES= pathfix
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/graphics/flam3/Makefile b/graphics/flam3/Makefile
index 10db06f2b482..91bfa034500b 100644
--- a/graphics/flam3/Makefile
+++ b/graphics/flam3/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
GNU_CONFIGURE= yes
USES= gmake pathfix pkgconfig
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
-CFLAGS+= -I${LOCALBASE}/include/libpng15 -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include/libpng15 -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/graphics/gcolor/Makefile b/graphics/gcolor/Makefile
index ff5068bd4319..07d65fe986d7 100644
--- a/graphics/gcolor/Makefile
+++ b/graphics/gcolor/Makefile
@@ -13,8 +13,8 @@ COMMENT= GTK-based color picker
PLIST_FILES= bin/gcolor
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index d2212e416a6b..17be5d28be2a 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gimageview
PORTVERSION= 0.2.27
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= graphics
MASTER_SITES= SF/gtkmmviewer/${PORTNAME}/${PORTVERSION}
@@ -13,15 +13,13 @@ COMMENT= Yet another GTK+ based image viewer
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng15.so:${PORTSDIR}/graphics/png
-USES= gmake pkgconfig
+USES= gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_XORG= xinerama ice
CONFIGURE_ARGS= --with-gtk2
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CFLAGS+= -DUSE_GTK2
CPPFLAGS+= -I${LOCALBASE}/include
-MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= SPLASH NLS LIBMNG LIBWMF LIBRSVG2 LIBEXIF MPLAYER LIBXINE IMLIB
@@ -56,24 +54,12 @@ MPLAYER_CONFIGURE_ENABLE=mplayer
MPLAYER_RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
LIBXINE_CONFIGURE_WITH= xine
-LIBXINE_LIB_DEPENDS= xine:${PORTSDIR}/multimedia/libxine
-
-.include <bsd.port.options.mk>
+LIBXINE_LIB_DEPENDS= libxine.so:${PORTSDIR}/multimedia/libxine
post-patch:
- @${REINPLACE_CMD} -e 's/DATADIRNAME=lib/DATADIRNAME=share/g' \
- -e 's|echo aout|echo elf|' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/gnome/apps/|/apps/|' \
- ${WRKSRC}/gimageview.spec \
+ @${REINPLACE_CMD} '/^desktopdir =/s|=.*|= ${DESKTOPDIR}|' \
${WRKSRC}/etc/Makefile.in
- @${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} \
- 's|= $$(DESTDIR)|= |' {} \;
-
-post-configure:
-.if ${PORT_OPTIONS:MIMLIB}
- @${FIND} ${WRKSRC} -name 'Makefile' | ${XARGS} ${REINPLACE_CMD} -Ee \
- 's/^(GDK_IMLIB_(CFLAGS|LIBS) =).*$$/$${1}/'
-.endif
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|= $$(DESTDIR)|= |' -e '/^CPPFLAGS =/s/\\/@CPPFLAGS@ \\/'
.include <bsd.port.mk>
diff --git a/graphics/gimageview/files/patch-ltmain.sh b/graphics/gimageview/files/patch-ltmain.sh
deleted file mode 100644
index 8afad632c287..000000000000
--- a/graphics/gimageview/files/patch-ltmain.sh
+++ /dev/null
@@ -1,25 +0,0 @@
---- ltmain.sh.orig Sat Nov 17 07:22:26 2001
-+++ ltmain.sh Wed Feb 20 16:21:57 2002
-@@ -2690,6 +2690,9 @@
- # Absolute path.
- rpath="$rpath$dir:"
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Relative path: add a thisdir entry.
- rpath="$rpath\$thisdir/$dir:"
-@@ -3360,10 +3363,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/gimageview/pkg-plist b/graphics/gimageview/pkg-plist
index a27cf3a8d7ec..d1fa442abeb7 100644
--- a/graphics/gimageview/pkg-plist
+++ b/graphics/gimageview/pkg-plist
@@ -32,7 +32,7 @@ lib/gimageview/thumbnail/libgimv_nautilus_thumb.so
lib/gimageview/thumbnail/libgimv_thumb.so
lib/gimageview/thumbnail/libgimv_xvpics_thumb.so
lib/gimageview/thumbnail_view/libgimv_thumbview_detail.so
-share/apps/Graphics/gimageview.desktop
+share/applications/gimageview.desktop
share/doc/gimageview/html/ja/01.html
share/doc/gimageview/html/ja/02.html
share/doc/gimageview/html/ja/03.html
@@ -136,5 +136,3 @@ share/pixmaps/gimv.png
@dirrm share/gimageview/pixmaps/default
@dirrm share/gimageview/pixmaps
@dirrm share/gimageview
-@dirrmtry share/apps/Graphics
-@dirrmtry share/apps
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 91513428282c..e2ff1dc79f83 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -51,10 +51,9 @@ CONFIGURE_ARGS?=--with-html-dir=${PREFIX}/share/doc/gimp \
--with-desktop-dir=${PREFIX}/share \
--docdir=${PREFIX}/share/doc/gimp \
--enable-default-binary
-CONFIGURE_ENV= GIMP_THREAD_LIBS=${PTHREAD_LIBS} \
- LIBS=${LIBS}
+CONFIGURE_ENV= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
.if !defined(GIMP_SLAVE)
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
index cd06dedcc898..09930042c34e 100644
--- a/graphics/gimp-resynthesizer/Makefile
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -19,7 +19,7 @@ GH_TAGNAME= v${PORTVERSION}
GH_COMMIT= 28cade5
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
+LIBS+= -L${LOCALBASE}/lib -lintl
USES= gettext gmake pkgconfig compiler:nestedfct
USE_AUTOTOOLS= aclocal automake
AUTOMAKE_ARGS= --add-missing
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
index 66a1c553bd56..3af1ffbcd2c8 100644
--- a/graphics/gle/Makefile
+++ b/graphics/gle/Makefile
@@ -18,7 +18,7 @@ USE_GL= glut
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= "LIBS=-L${LOCALBASE}/lib -lXext ${PTHREAD_LIBS}"
+LIBS+= -L${LOCALBASE}/lib -lXext
post-patch:
.for file in ex_angle.c ex_cut_round.c ex_raw.c extrude.c round_cap.c segment.c texgen.c
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index d3d43da42c82..5dbfc4021b76 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -15,8 +15,8 @@ LIB_DEPENDS= libttf.so:${PORTSDIR}/print/freetype
USES= gmake libtool
USE_GL= gl glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-ttf-includes=${LOCALBASE}/include/freetype1 \
--with-ttf-libraries=${LOCALBASE}/lib \
--with-gl-includes=${LOCALBASE}/include \
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 6caa55a78d25..334508703fc6 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -31,8 +31,7 @@ AALIB_CONFIGURE_WITH= aalib
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
-NLS_CONFIGURE_ENV= LIBS="-lintl"
+NLS_LIBS= -L${LOCALBASE}/lib -lintl
READLINE_USES= readline
READLINE_CONFIGURE_WITH= readline
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 89225cc82351..ac5928f0f113 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -15,8 +15,8 @@ USES= gettext gmake perl5
USE_GNOME= imlib
USE_PERL5= build
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/gtkgraph \
share/locale/fr/LC_MESSAGES/gtkgraph.mo \
diff --git a/graphics/jpeginfo/Makefile b/graphics/jpeginfo/Makefile
index b96ab2b8cd97..8f0db7f854fa 100644
--- a/graphics/jpeginfo/Makefile
+++ b/graphics/jpeginfo/Makefile
@@ -13,8 +13,8 @@ COMMENT= Generate listing and MD5, check jpegs for error, delete broken ones
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
MAKE_ARGS= mandir=${MANPREFIX}/man INSTALL_ROOT=${STAGEDIR}
PLIST_FILES= bin/jpeginfo man/man1/jpeginfo.1.gz
diff --git a/graphics/kudu/Makefile b/graphics/kudu/Makefile
index 8000f5025e64..d827189a82b1 100644
--- a/graphics/kudu/Makefile
+++ b/graphics/kudu/Makefile
@@ -20,9 +20,7 @@ USE_GL= gl
USE_PYTHON= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS} -lcompat"
+LIBS+= -L${LOCALBASE}/lib -lcompat
PLIST_FILES= bin/${PORTNAME}
PORTDATA= *
diff --git a/graphics/libvisual/Makefile b/graphics/libvisual/Makefile
index e1069dc04391..9ad413f2063a 100644
--- a/graphics/libvisual/Makefile
+++ b/graphics/libvisual/Makefile
@@ -16,8 +16,8 @@ COMMENT= Abstraction library that sits between apps and visual plugin
USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/graphics/libvisual04-plugins/Makefile b/graphics/libvisual04-plugins/Makefile
index e6aedd9f9674..bf0832aeb49e 100644
--- a/graphics/libvisual04-plugins/Makefile
+++ b/graphics/libvisual04-plugins/Makefile
@@ -25,8 +25,8 @@ CONFIGURE_ARGS= --disable-alsa \
--disable-gforce \
--disable-jess \
--prefix=${PREFIX}
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
MAJORMINOR= ${PORTVERSION:C/.[0-9]+$//}
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index 11dad0f92561..1b52061d7699 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -18,16 +18,14 @@ LIB_DEPENDS= libopencv_objdetect.so:${PORTSDIR}/graphics/opencv
GITVERSION= 4b1dfe1
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-LIBS+= -lopencv_core
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lopencv_core
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
CONFIGURE_ARGS+= --with-facedetect
-CONFIGURE_ENV+= LIBS="${LIBS}"
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/phplot/Makefile b/graphics/phplot/Makefile
index 159c4863d75d..f7471a1a670c 100644
--- a/graphics/phplot/Makefile
+++ b/graphics/phplot/Makefile
@@ -22,7 +22,7 @@ NO_BUILD= YES
PHPLOT_DIR= ${STAGEDIR}${PREFIX}/include/php/phplot
-LIBS= phplot.php rgb.inc.php
+LIBRARIES= phplot.php rgb.inc.php
OPTIONS_DEFINE= DOCS FONTS
OPTIONS_DEFAULT= FONTS
@@ -31,7 +31,7 @@ FONTS_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
do-install:
@${MKDIR} ${PHPLOT_DIR}
- ${INSTALL_DATA} ${LIBS:S,^,${WRKSRC}/,} ${PHPLOT_DIR}
+ ${INSTALL_DATA} ${LIBRARIES:S,^,${WRKSRC}/,} ${PHPLOT_DIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKDIR}/phplotdocs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/graphics/pngnq/Makefile b/graphics/pngnq/Makefile
index bd6e98d2ce4a..7482430ed0d8 100644
--- a/graphics/pngnq/Makefile
+++ b/graphics/pngnq/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= LIBS=-lpng
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -lpng
USES= pkgconfig
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index 45a9f7990905..6f48d7d14695 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -30,10 +30,10 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
DATADIR= ${PREFIX}/share/${PORTNAME}-${VERSION_BASE}
ETCDIR= ${PREFIX}/etc/${PORTNAME}/${VERSION_BASE}
-INCLUDES= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lboost_system
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lboost_system
-CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} --prefix=${PREFIX} \
+CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
--program-transform-name='s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/' \
--disable-optimiz
@@ -42,7 +42,6 @@ CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} --prefix=${PREFIX} \
.if ${PORT_OPTIONS:MX11}
USE_XORG= xpm sm ice x11
USE_SDL= sdl
-CONFIGURE_ARGS+= --x-include=${LOCALBASE}/include --x-libraries=${LOCALBASE}/libs
.else
CONFIGURE_ARGS+= --without-x
.endif
@@ -60,7 +59,6 @@ CONFIGURE_ARGS+=--disable-io-restrictions
BUILD_DEPENDS+= png>=1.4:${PORTSDIR}/graphics/png
.else
LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
-LIBS+= -lpng
.endif
.else
CONFIGURE_ARGS+=--without-libpng
@@ -71,7 +69,6 @@ CONFIGURE_ARGS+=--without-libpng
BUILD_DEPENDS+= jpeg>=6b:${PORTSDIR}/graphics/jpeg
.else
LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
-LIBS+= -ljpeg
.endif
.else
CONFIGURE_ARGS+=--without-libjpeg
@@ -82,7 +79,6 @@ CONFIGURE_ARGS+=--without-libjpeg
BUILD_DEPENDS+= tiff>=4:${PORTSDIR}/graphics/tiff
.else
LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff
-LIBS+= -ltiff
.endif
.else
CONFIGURE_ARGS+=--without-libtiff
@@ -93,8 +89,7 @@ CONFIGURE_ARGS+=--without-libtiff
BUILD_DEPENDS+= OpenEXR>=1.6:${PORTSDIR}/graphics/OpenEXR
.else
LIB_DEPENDS+= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
-LIBS+= -lIlmImf
-INCLUDES+= -I${LOCALBASE}/include/OpenEXR
+CPPFLAGS+= -I${LOCALBASE}/include/OpenEXR
.endif
.else
CONFIGURE_ARGS+=--without-openexr
@@ -108,8 +103,6 @@ CONFIGURE_ARGS+=NON_REDISTRIBUTABLE_BUILD=yes
BROKEN= Does not compile on sparc64: thread-local storage not supported
.endif
-CONFIGURE_ARGS+=CXXFLAGS="${CXXFLAGS} ${INCLUDES}"
-
MAN1= ${PORTNAME}${PKGNAMESUFFIX}.1
DOC_FILES= AUTHORS ChangeLog NEWS
diff --git a/graphics/radius-engine/Makefile b/graphics/radius-engine/Makefile
index a35a1a36c970..7987a49b9093 100644
--- a/graphics/radius-engine/Makefile
+++ b/graphics/radius-engine/Makefile
@@ -20,8 +20,8 @@ USES= pathfix pkgconfig
USE_SDL= sdl sound
USE_GL= glu
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= include/radius.h \
lib/libradius-engine.a \
diff --git a/graphics/stamp/Makefile b/graphics/stamp/Makefile
index d8688507b4f4..92a78f108dcf 100644
--- a/graphics/stamp/Makefile
+++ b/graphics/stamp/Makefile
@@ -13,8 +13,8 @@ COMMENT= Adds a graphical, configurable timestamp to a grayscale image
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_X11)
USE_GNOME= gtk12
.endif
diff --git a/graphics/tesseract/Makefile b/graphics/tesseract/Makefile
index d306637095f7..cc590ff47cc4 100644
--- a/graphics/tesseract/Makefile
+++ b/graphics/tesseract/Makefile
@@ -24,9 +24,8 @@ WRKSRC= ${WRKDIR}/tesseract-ocr
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBLEPT_HEADERSDIR="${LOCALBASE}/include/leptonica" \
- LIBS="${PTHREAD_LIBS}"
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= LIBLEPT_HEADERSDIR="${LOCALBASE}/include/leptonica"
+LIBS+= -L${LOCALBASE}/lib
DATADIR= ${PREFIX}/share/tessdata
PORTDATA= *
diff --git a/graphics/visionworkbench/Makefile b/graphics/visionworkbench/Makefile
index 526e1a77344f..cce1d7c861f4 100644
--- a/graphics/visionworkbench/Makefile
+++ b/graphics/visionworkbench/Makefile
@@ -34,21 +34,10 @@ LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
LIB_DEPENDS+= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
LIB_DEPENDS+= libcairomm-1.0.so:${PORTSDIR}/graphics/cairomm
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 800025
-CFLAGS+= -Dsqrtl=sqrt
-. if ${OSVERSION} < 800022
-CFLAGS+= -Dtgammaf=tgamma
-. endif
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
-CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${LDFLAGS}"
+NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s,-DBOOST_FILESYSTEM_VERSION=2,,g" ${WRKSRC}/configure
@@ -69,4 +58,4 @@ pre-configure:
regression-test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 0e532eb7af5c..85367ef20aa4 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
USES= gmake
GNU_CONFIGURE= yes
-OPTIONS_DEFINE= PTHREAD NLS
+OPTIONS_DEFINE= THREADS NLS
OPTIONS_MULTI= DRIVER
OPTIONS_MULTI_DRIVER= AALIB GTK2 X11
DRIVER_DESC= User Interface
@@ -37,12 +37,12 @@ X11_CONFIGURE_WITH= x11-driver x
NLS_USES= gettext iconv
NLS_CONFIGURE_ENABLE= nls
-PTHREAD_DESC= Enable SMP support (experimental)
-PTHREAD_CONFIGURE_WITH= pthread
-PTHREAD_CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+THREADS_DESC= Enable SMP support (experimental)
+THREADS_CONFIGURE_WITH= pthread
+THREADS_LIBS= ${PTHREAD_LIBS}
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
INFO= xaos
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index 4a9441138265..b86a1edf392e 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -39,13 +39,10 @@ GIMP_RUN_DEPENDS= ${LOCALBASE}/bin/gimp:${PORTSDIR}/graphics/gimp-app
GIMP_CONFIGURE_ENABLE= gimp2 gimp
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
+NLS_LIBS= -L${LOCALBASE}/lib -lintl
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MNLS}
-CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -lintl"
-.endif
-
.if ${PORT_OPTIONS:MGIMP}
SUB_FILES+= pkg-message
.endif
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index aa762b1daf6c..d4102aa52cda 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -23,9 +23,8 @@ ZIP_CONFIGURE_OFF= --disable-zip
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-avifile
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include \
- ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USE_EFL= imlib2
PLIST_FILES+= bin/wxzphoto
USES= perl5 gmake