aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-02 16:24:32 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-10-02 16:24:32 +0000
commita5000a5ef092cd42814265f163963c7822717c36 (patch)
tree05c3d6660975b28a8e1254b833852ebf64d81f8a /graphics
parent641063185c29f8944fed6f2dee40c689918ebff3 (diff)
downloadports-a5000a5ef092cd42814265f163963c7822717c36.tar.gz
ports-a5000a5ef092cd42814265f163963c7822717c36.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/iec16022/Makefile17
-rw-r--r--graphics/iec16022/distinfo5
-rw-r--r--graphics/iec16022/files/patch-image.c11
-rw-r--r--graphics/iec16022/pkg-descr2
-rw-r--r--graphics/iec16022/pkg-plist6
5 files changed, 27 insertions, 14 deletions
diff --git a/graphics/iec16022/Makefile b/graphics/iec16022/Makefile
index 6e2a99fc7314..de2c4eca10ea 100644
--- a/graphics/iec16022/Makefile
+++ b/graphics/iec16022/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= iec16022
-PORTVERSION= 0.2.4
-PORTREVISION= 2
+PORTVERSION= 0.2.7
+DISTVERSIONPREFIX= v
CATEGORIES= graphics
-MASTER_SITES= http://datenfreihafen.org/~stefan/iec16022/ \
- LOCAL/ehaupt
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Create 2D barcodes, also known as DataMatrix
@@ -15,9 +13,14 @@ LICENSE= GPLv2
LIB_DEPENDS= libpopt.so:devel/popt
+USE_GITHUB= yes
+GH_ACCOUNT= rdoeffinger
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= libtool pkgconfig
+USES= autoreconf gmake libtool pathfix pkgconfig
+
+PATHFIX_MAKEFILEIN= Makefile.am
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib -fPIC
@@ -26,8 +29,6 @@ INSTALL_TARGET= install-strip
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/iec16022.c \
${WRKSRC}/iec16022ecc200.c ${WRKSRC}/reedsol.c ${WRKSRC}/image.c
- @${REINPLACE_CMD} -e \
- "s|^\(pkgconfigdir\).*|\1 = ${PREFIX}/libdata/pkgconfig|" \
- ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/-Wno-unused-result/d' ${WRKSRC}/Makefile.am
.include <bsd.port.mk>
diff --git a/graphics/iec16022/distinfo b/graphics/iec16022/distinfo
index 3480961c94ee..ad4e5f3aa88a 100644
--- a/graphics/iec16022/distinfo
+++ b/graphics/iec16022/distinfo
@@ -1,2 +1,3 @@
-SHA256 (iec16022-0.2.4.tar.gz) = 0941afede03cecc9607b9abd3093c538d982f9f8b87294cf1c2f89306be3df12
-SIZE (iec16022-0.2.4.tar.gz) = 308129
+TIMESTAMP = 1475423331
+SHA256 (rdoeffinger-iec16022-v0.2.7_GH0.tar.gz) = 34f00da5f6c83dd14b2803e5ed0f5310310e452023fe989c59fc5489b78cd33a
+SIZE (rdoeffinger-iec16022-v0.2.7_GH0.tar.gz) = 32970
diff --git a/graphics/iec16022/files/patch-image.c b/graphics/iec16022/files/patch-image.c
new file mode 100644
index 000000000000..31359009a2be
--- /dev/null
+++ b/graphics/iec16022/files/patch-image.c
@@ -0,0 +1,11 @@
+--- image.c.orig 2016-10-02 16:05:20 UTC
++++ image.c
+@@ -40,6 +40,8 @@ static inline unsigned htonl(unsigned i)
+ #include <zlib.h>
+ #endif
+
++#include <unistd.h>
++
+ static unsigned char const bbc[] = {
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, //
+ 0x18, 0x18, 0x18, 0x18, 0x18, 0x00, 0x18, 0x00, // !
diff --git a/graphics/iec16022/pkg-descr b/graphics/iec16022/pkg-descr
index 5434d7ddbb99..e1eb6d19bc22 100644
--- a/graphics/iec16022/pkg-descr
+++ b/graphics/iec16022/pkg-descr
@@ -1,4 +1,4 @@
Create 2D barcodes, also known as Data Matrix. These barcodes are defined in
ISO/IEC 16022.
-WWW: http://datenfreihafen.org/projects/iec16022.html
+WWW: https://github.com/rdoeffinger/iec16022
diff --git a/graphics/iec16022/pkg-plist b/graphics/iec16022/pkg-plist
index 57e8c0c06d8b..354a26446931 100644
--- a/graphics/iec16022/pkg-plist
+++ b/graphics/iec16022/pkg-plist
@@ -2,9 +2,9 @@ bin/iec16022
include/iec16022/iec16022ecc200.h
include/iec16022/image.h
include/iec16022/reedsol.h
-lib/libiec16022.so.0.0.0
-lib/libiec16022.so.0
-lib/libiec16022.so
lib/libiec16022.a
+lib/libiec16022.so
+lib/libiec16022.so.0
+lib/libiec16022.so.0.1.0
libdata/pkgconfig/libiec16022.pc
man/man1/iec16022.1.gz