aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-06-24 20:21:17 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-06-24 20:21:17 +0000
commita7f614c7d13e5f35bfd4676b02ddd199086df824 (patch)
tree33ce9026f81e34a5ebe78f0c67e62ec659da5299 /graphics
parent151114b999e67aecb8d62651601677059d38fa80 (diff)
downloadports-a7f614c7d13e5f35bfd4676b02ddd199086df824.tar.gz
ports-a7f614c7d13e5f35bfd4676b02ddd199086df824.zip
Notes
Diffstat (limited to 'graphics')
-rw-r--r--graphics/graphviz/Makefile3
-rw-r--r--graphics/graphviz/files/patch-config_ruby.rb27
2 files changed, 29 insertions, 1 deletions
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 9c403531c5cb..25950217ee49 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -431,8 +431,9 @@ post-patch:
${XARGS} ${REINPLACE_CMD} \
-e 's|libdir=@libdir@|libdir=@libdir@/@PACKAGE@|';
@${REINPLACE_CMD} -e "s|/usr/include/php|${LOCALBASE}/include/php|g" \
- -e "s|vendorarch|installsitearch|g" \
+ -e "s|vendorarchdir|sitearchdir|g" \
-e "s|-lruby|-lruby${RUBY_SUFFIX}|g" \
+ -e "s|Config::|RbConfig::|" \
-e '/if test/ s| == | = |g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|#include "gui.h"|#include "gui/gui.h"|' \
${WRKSRC}/cmd/smyrna/tvnodes.h
diff --git a/graphics/graphviz/files/patch-config_ruby.rb b/graphics/graphviz/files/patch-config_ruby.rb
new file mode 100644
index 000000000000..0a6a42bd21f0
--- /dev/null
+++ b/graphics/graphviz/files/patch-config_ruby.rb
@@ -0,0 +1,27 @@
+--- config/config_ruby.rb.orig 2013-02-14 14:27:39.000000000 +0100
++++ config/config_ruby.rb 2013-06-24 18:34:23.000000000 +0200
+@@ -1,18 +1,18 @@
+ require 'rbconfig'
+
+-CONFIG = Config::MAKEFILE_CONFIG
++CONFIG = RbConfig::MAKEFILE_CONFIG
+
+
+ case ARGV[0]
+ when "archdir"
+- puts Config::expand(CONFIG["archdir"])
++ puts RbConfig::expand(CONFIG["archdir"])
+ when "lib"
+- puts Config::expand(CONFIG["libdir"])
++ puts RbConfig::expand(CONFIG["libdir"])
+ when "vendorarchdir"
+- puts Config::expand(CONFIG["vendorarchdir"])
++ puts RbConfig::expand(CONFIG["vendorarchdir"])
+ when "sitearchdir"
+- puts Config::expand(CONFIG["sitearchdir"])
++ puts RbConfig::expand(CONFIG["sitearchdir"])
+ when "sitelib"
+- puts Config::expand(CONFIG["sitedir"])
++ puts RbConfig::expand(CONFIG["sitedir"])
+ end
+