aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
committerRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
commitb217c7fc9cc4e56e26f88b17551499a17c4c6d24 (patch)
tree927d28feccb5a8860ed230fbec099ccb4255ada8 /graphics
parent80fa663d16236be2c6d5165f92327ed60b6a4b42 (diff)
downloadports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.tar.gz
ports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.zip
Mark ports recursively depending on Python 2.7 for expiration on June 23.
For ports optionally dependending on Python 2.7, just mark those options as expired. Remove konquerer from the x11/kde-baseapps metaport and bump its PORTREVISION. Submitted by: rene Reviewed by: portmgr, adridg, ehaupt, lme, madpilot, pizzamig, se, sunpoet, yuri Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D28665
Notes
Notes: svn path=/head/; revision=569118
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cegui/Makefile5
-rw-r--r--graphics/digikam/Makefile7
-rw-r--r--graphics/kimagemapeditor/Makefile3
-rw-r--r--graphics/kphotoalbum/Makefile7
-rw-r--r--graphics/luminance-qt5/Makefile3
-rw-r--r--graphics/qgis-ltr/Makefile3
-rw-r--r--graphics/qgis/Makefile3
7 files changed, 31 insertions, 0 deletions
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
index 510a19749cc4..91f22c2417ba 100644
--- a/graphics/cegui/Makefile
+++ b/graphics/cegui/Makefile
@@ -111,6 +111,11 @@ CMAKE_ARGS+= -DCEGUI_BUILD_PYTHON_MODULES=OFF # python support doesn't build
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MLUA}
+DEPRECATED= Uses EOL Python 2.7 via lang/tolua++
+EXPIRATION_DATE=2021-06-23
+.endif
+
.if ${PORT_OPTIONS:MEXPAT} || ${PORT_OPTIONS:MXERCES} || ${PORT_OPTIONS:MLIBXML2} || ${PORT_OPTIONS:MRAPIDXML} || ${PORT_OPTIONS:MTINYXML}
PLIST_SUB+= XMLPARSERS=""
.else
diff --git a/graphics/digikam/Makefile b/graphics/digikam/Makefile
index d91821a199b2..406298784ccb 100644
--- a/graphics/digikam/Makefile
+++ b/graphics/digikam/Makefile
@@ -101,4 +101,11 @@ WEBENGINE_CMAKE_BOOL= ENABLE_QWEBENGINE
PLIST_SUB= SHLIB_VER=${DISTVERSION}
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/kimagemapeditor/Makefile b/graphics/kimagemapeditor/Makefile
index bb9ac0c90461..ce49562c0c61 100644
--- a/graphics/kimagemapeditor/Makefile
+++ b/graphics/kimagemapeditor/Makefile
@@ -7,6 +7,9 @@ CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE generator of HTML image maps
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash guiaddons i18n iconthemes itemviews \
diff --git a/graphics/kphotoalbum/Makefile b/graphics/kphotoalbum/Makefile
index 7ef4419f7d08..4f673e13853e 100644
--- a/graphics/kphotoalbum/Makefile
+++ b/graphics/kphotoalbum/Makefile
@@ -35,4 +35,11 @@ OPTIONS_DEFAULT_i386= WEBENGINE
WEBENGINE_DESC= Add dependency on qt5-webengine
WEBENGINE_USE= QT=webengine
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index 48b3841d11fc..e4f9537a4a02 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -13,6 +13,9 @@ COMMENT= Complete open source solution for HDR photography
LICENSE= GPLv2
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:math/fftw3
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libHalf.so:graphics/ilmbase \
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index 77ceb2374eb1..af9fbc29f12a 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -19,6 +19,9 @@ COMMENT= Free and Open Source Geographic Information System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= gpsbabel>=1.5.4:astro/gpsbabel \
opencl>=0:devel/opencl \
${PYTHON_PKGNAMEPREFIX}cycler>=0.10.0:devel/py-cycler@${PY_FLAVOR} \
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 9e6908321f6b..5c847359d497 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -14,6 +14,9 @@ COMMENT= Free and Open Source Geographic Information System
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/doc/LICENSE
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= gpsbabel>=1.5.4:astro/gpsbabel \
opencl>=0:devel/opencl \
${PYTHON_PKGNAMEPREFIX}cycler>=0.10.0:devel/py-cycler@${PY_FLAVOR} \