aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-06-14 19:02:23 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-06-15 13:13:14 +0000
commitb9e84352c1ce5cc3318779978b99625e9d70608c (patch)
treee23d216bdeccb1e1893158dafd9a2dadf7390294 /graphics
parent1df4974e1f63c9aeb8c679d6c449a62e0eb4616c (diff)
downloadports-b9e84352c1ce5cc3318779978b99625e9d70608c.tar.gz
ports-b9e84352c1ce5cc3318779978b99625e9d70608c.zip
graphics/vulkan-tools: update to 1.2.181
Diffstat (limited to 'graphics')
-rw-r--r--graphics/vulkan-tools/Makefile4
-rw-r--r--graphics/vulkan-tools/distinfo8
-rw-r--r--graphics/vulkan-tools/files/patch-werror52
3 files changed, 56 insertions, 8 deletions
diff --git a/graphics/vulkan-tools/Makefile b/graphics/vulkan-tools/Makefile
index 92c0a323d2da..a0471ab0b99d 100644
--- a/graphics/vulkan-tools/Makefile
+++ b/graphics/vulkan-tools/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vulkan-tools
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.180
+DISTVERSION= 1.2.181
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
@@ -24,8 +24,6 @@ OPTIONS_DEFAULT= WAYLAND XCB XLIB
OPTIONS_SLAVE= DISPLAY
OPTIONS_SUB= yes
-WAYLAND_PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-WAYLAND_PATCHFILES= c6adbf0af27e.patch:-p1 # https://github.com/KhronosGroup/Vulkan-Tools/issues/469
WAYLAND_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
wayland-protocols>0:graphics/wayland-protocols
WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland
diff --git a/graphics/vulkan-tools/distinfo b/graphics/vulkan-tools/distinfo
index 1c795c4f13fd..48e6a5b4c9d6 100644
--- a/graphics/vulkan-tools/distinfo
+++ b/graphics/vulkan-tools/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1623100662
-SHA256 (KhronosGroup-Vulkan-Tools-v1.2.180_GH0.tar.gz) = c70014ef4eb2d1d5019d0d7a4a696a71dc3abbe331e7e656c3955a292ed93664
-SIZE (KhronosGroup-Vulkan-Tools-v1.2.180_GH0.tar.gz) = 843337
-SHA256 (c6adbf0af27e.patch) = 2df8225f1cae788347c49afb91b44bf90c154adf4c4f738ad5fa0e15c71b9b9f
-SIZE (c6adbf0af27e.patch) = 22898
+TIMESTAMP = 1623697343
+SHA256 (KhronosGroup-Vulkan-Tools-v1.2.181_GH0.tar.gz) = 903e03264d6dedc8c9d73d5044f0886e60de79b6849a062c3bd9a69a7667d069
+SIZE (KhronosGroup-Vulkan-Tools-v1.2.181_GH0.tar.gz) = 846689
diff --git a/graphics/vulkan-tools/files/patch-werror b/graphics/vulkan-tools/files/patch-werror
new file mode 100644
index 000000000000..129e4f155f35
--- /dev/null
+++ b/graphics/vulkan-tools/files/patch-werror
@@ -0,0 +1,52 @@
+Silence Clang warnings that GCC ignores
+https://github.com/KhronosGroup/Vulkan-Tools/issues/531
+https://github.com/KhronosGroup/Vulkan-Tools/issues/532
+
+--- cube/cube.c.orig 2021-06-14 19:02:23 UTC
++++ cube/cube.c
+@@ -3027,12 +3027,12 @@ static VkResult demo_create_display_surface(struct dem
+ VkDisplayPlaneCapabilitiesKHR planeCaps;
+ vkGetDisplayPlaneCapabilitiesKHR(demo->gpu, mode_props.displayMode, plane_index, &planeCaps);
+ // Find a supported alpha mode
+- VkCompositeAlphaFlagBitsKHR alphaMode = VK_DISPLAY_PLANE_ALPHA_OPAQUE_BIT_KHR;
++ VkCompositeAlphaFlagBitsKHR alphaMode = (VkCompositeAlphaFlagBitsKHR)VK_DISPLAY_PLANE_ALPHA_OPAQUE_BIT_KHR;
+ VkCompositeAlphaFlagBitsKHR alphaModes[4] = {
+- VK_DISPLAY_PLANE_ALPHA_OPAQUE_BIT_KHR,
+- VK_DISPLAY_PLANE_ALPHA_GLOBAL_BIT_KHR,
+- VK_DISPLAY_PLANE_ALPHA_PER_PIXEL_BIT_KHR,
+- VK_DISPLAY_PLANE_ALPHA_PER_PIXEL_PREMULTIPLIED_BIT_KHR,
++ (VkCompositeAlphaFlagBitsKHR)VK_DISPLAY_PLANE_ALPHA_OPAQUE_BIT_KHR,
++ (VkCompositeAlphaFlagBitsKHR)VK_DISPLAY_PLANE_ALPHA_GLOBAL_BIT_KHR,
++ (VkCompositeAlphaFlagBitsKHR)VK_DISPLAY_PLANE_ALPHA_PER_PIXEL_BIT_KHR,
++ (VkCompositeAlphaFlagBitsKHR)VK_DISPLAY_PLANE_ALPHA_PER_PIXEL_PREMULTIPLIED_BIT_KHR,
+ };
+ for (uint32_t i = 0; i < sizeof(alphaModes); i++) {
+ if (planeCaps.supportedAlpha & alphaModes[i]) {
+@@ -3050,7 +3050,7 @@ static VkResult demo_create_display_surface(struct dem
+ create_info.planeIndex = plane_index;
+ create_info.planeStackIndex = plane_props[plane_index].currentStackIndex;
+ create_info.transform = VK_SURFACE_TRANSFORM_IDENTITY_BIT_KHR;
+- create_info.alphaMode = alphaMode;
++ create_info.alphaMode = (VkDisplayPlaneAlphaFlagBitsKHR)alphaMode;
+ create_info.globalAlpha = 1.0f;
+ create_info.imageExtent = image_extent;
+
+--- cube/cube.cpp.orig 2021-06-14 19:02:23 UTC
++++ cube/cube.cpp
+@@ -405,16 +405,6 @@ LRESULT CALLBACK WndProc(HWND hWnd, UINT uMsg, WPARAM
+ #endif
+
+ #if defined(VK_USE_PLATFORM_WAYLAND_KHR)
+-static void handle_ping(void *data, wl_shell_surface *shell_surface, uint32_t serial) {
+- wl_shell_surface_pong(shell_surface, serial);
+-}
+-
+-static void handle_configure(void *data, wl_shell_surface *shell_surface, uint32_t edges, int32_t width, int32_t height) {}
+-
+-static void handle_popup_done(void *data, wl_shell_surface *shell_surface) {}
+-
+-static const wl_shell_surface_listener shell_surface_listener = {handle_ping, handle_configure, handle_popup_done};
+-
+ static void pointer_handle_enter(void *data, struct wl_pointer *pointer, uint32_t serial, struct wl_surface *surface, wl_fixed_t sx,
+ wl_fixed_t sy) {}
+